Linux Media Controller development
 help / color / mirror / Atom feed
From: Dikshita Agarwal <quic_dikshita@quicinc.com>
To: Konrad Dybcio <konrad.dybcio@linaro.org>,
	Stanimir Varbanov <stanimir.k.varbanov@gmail.com>,
	Vikash Garodia <quic_vgarodia@quicinc.com>,
	Bryan O'Donoghue <bryan.odonoghue@linaro.org>,
	Andy Gross <agross@kernel.org>,
	Bjorn Andersson <andersson@kernel.org>,
	"Mauro Carvalho Chehab" <mchehab@kernel.org>,
	Philipp Zabel <p.zabel@pengutronix.de>
Cc: Marijn Suijten <marijn.suijten@somainline.org>,
	Stanimir Varbanov <stanimir.varbanov@linaro.org>,
	Mauro Carvalho Chehab <mchehab+huawei@kernel.org>,
	<linux-media@vger.kernel.org>, <linux-arm-msm@vger.kernel.org>,
	<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v2 14/20] media: venus: pm_helpers: Remove pm_ops->core_put
Date: Mon, 4 Mar 2024 12:27:30 +0530	[thread overview]
Message-ID: <ec239f69-6ace-c4a4-409c-771f1d24ce81@quicinc.com> (raw)
In-Reply-To: <20230911-topic-mars-v2-14-3dac84b88c4b@linaro.org>



On 2/10/2024 2:39 AM, Konrad Dybcio wrote:
> Without an OPP table and with vcodec_pmdomains_num (so, v1, v3 and
> sdm845_legacy targets), core_put_v4 is a NOP, jut like core_put_v1.
> Unify them!
> 
> Signed-off-by: Konrad Dybcio <konrad.dybcio@linaro.org>
> ---
>  drivers/media/platform/qcom/venus/core.c       |  8 +++-----
>  drivers/media/platform/qcom/venus/pm_helpers.c | 17 +----------------
>  drivers/media/platform/qcom/venus/pm_helpers.h |  2 +-
>  3 files changed, 5 insertions(+), 22 deletions(-)
> 
> diff --git a/drivers/media/platform/qcom/venus/core.c b/drivers/media/platform/qcom/venus/core.c
> index 9bfd2a30084b..666adc5aac38 100644
> --- a/drivers/media/platform/qcom/venus/core.c
> +++ b/drivers/media/platform/qcom/venus/core.c
> @@ -426,15 +426,14 @@ static int venus_probe(struct platform_device *pdev)
>  err_core_deinit:
>  	hfi_core_deinit(core, false);
>  err_core_put:
> -	if (core->pm_ops->core_put)
> -		core->pm_ops->core_put(core);
> +	vcodec_domains_put(core);
> +
>  	return ret;
>  }
>  
>  static void venus_remove(struct platform_device *pdev)
>  {
>  	struct venus_core *core = platform_get_drvdata(pdev);
> -	const struct venus_pm_ops *pm_ops = core->pm_ops;
>  	struct device *dev = core->dev;
>  	int ret;
>  
> @@ -452,8 +451,7 @@ static void venus_remove(struct platform_device *pdev)
>  	pm_runtime_put_sync(dev);
>  	pm_runtime_disable(dev);
>  
> -	if (pm_ops->core_put)
> -		pm_ops->core_put(core);
> +	vcodec_domains_put(core);
>  
>  	v4l2_device_unregister(&core->v4l2_dev);
>  
> diff --git a/drivers/media/platform/qcom/venus/pm_helpers.c b/drivers/media/platform/qcom/venus/pm_helpers.c
> index 6f6de9ef1c6c..32f9ccfa9d8a 100644
> --- a/drivers/media/platform/qcom/venus/pm_helpers.c
> +++ b/drivers/media/platform/qcom/venus/pm_helpers.c
> @@ -318,13 +318,8 @@ static int load_scale_v1(struct venus_inst *inst)
>  	return ret;
>  }
>  
> -static void core_put_v1(struct venus_core *core)
> -{
> -}
> -
>  static const struct venus_pm_ops pm_ops_v1 = {
>  	.core_get = venus_clks_get,
> -	.core_put = core_put_v1,
>  	.load_scale = load_scale_v1,
>  };
>  
> @@ -396,7 +391,6 @@ static int venc_power_v3(struct device *dev, int on)
>  
>  static const struct venus_pm_ops pm_ops_v3 = {
>  	.core_get = venus_clks_get,
> -	.core_put = core_put_v1,
>  	.vdec_get = vdec_get_v3,
>  	.vdec_power = vdec_power_v3,
>  	.venc_get = venc_get_v3,
> @@ -893,7 +887,7 @@ static int vcodec_domains_get(struct venus_core *core)
>  	return ret;
>  }
>  
> -static void vcodec_domains_put(struct venus_core *core)
> +void vcodec_domains_put(struct venus_core *core)
>  {
>  	dev_pm_domain_detach_list(core->pmdomains);
>  
what is the base of this change?
I don't see dev_pm_domain_detach_list in mainline code.
Am I missing anything here?
> @@ -968,14 +962,6 @@ static int core_get_v4(struct venus_core *core)
>  	return 0;
>  }
>  
> -static void core_put_v4(struct venus_core *core)
> -{
> -	if (legacy_binding)
> -		return;
> -
> -	vcodec_domains_put(core);
> -}
> -
>  int venus_core_power(struct venus_core *core, int on)
>  {
>  	struct device *dev = core->dev;
> @@ -1123,7 +1109,6 @@ static int load_scale_v4(struct venus_inst *inst)
>  
>  static const struct venus_pm_ops pm_ops_v4 = {
>  	.core_get = core_get_v4,
> -	.core_put = core_put_v4,
>  	.vdec_get = vdec_get_v4,
>  	.vdec_put = vdec_put_v4,
>  	.vdec_power = vdec_power_v4,
> diff --git a/drivers/media/platform/qcom/venus/pm_helpers.h b/drivers/media/platform/qcom/venus/pm_helpers.h
> index 77db940a265c..3014b39aa6e3 100644
> --- a/drivers/media/platform/qcom/venus/pm_helpers.h
> +++ b/drivers/media/platform/qcom/venus/pm_helpers.h
> @@ -11,7 +11,6 @@ struct venus_core;
>  
>  struct venus_pm_ops {
>  	int (*core_get)(struct venus_core *core);
> -	void (*core_put)(struct venus_core *core);
>  
>  	int (*vdec_get)(struct device *dev);
>  	void (*vdec_put)(struct device *dev);
> @@ -28,6 +27,7 @@ struct venus_pm_ops {
>  
>  const struct venus_pm_ops *venus_pm_get(enum hfi_version version);
>  int venus_core_power(struct venus_core *core, int on);
> +void vcodec_domains_put(struct venus_core *core);
>  
>  static inline int venus_pm_load_scale(struct venus_inst *inst)
>  {
> 

  reply	other threads:[~2024-03-04  6:57 UTC|newest]

Thread overview: 60+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-07-12  5:48 [PATCH 0/2] add device managed version of dev_pm_domain_attach|detach_list() Dikshita Agarwal
2024-02-09 21:09 ` [PATCH v2 00/20] Venus cleanups Konrad Dybcio
2024-02-09 21:09   ` [PATCH v2 01/20] media: venus: pm_helpers: Only set rate of the core clock in core_clks_enable Konrad Dybcio
2024-07-12  5:48     ` Dikshita Agarwal
2024-07-12  6:07     ` Dikshita Agarwal
2024-07-16 10:49       ` Konrad Dybcio
2024-02-09 21:09   ` [PATCH v2 02/20] media: venus: pm_helpers: Rename core_clks_get to venus_clks_get Konrad Dybcio
2024-03-06 11:48     ` Bryan O'Donoghue
2024-03-26 21:24       ` Konrad Dybcio
2024-02-09 21:09   ` [PATCH v2 03/20] media: venus: pm_helpers: Add kerneldoc to venus_clks_get() Konrad Dybcio
2024-03-06 12:20     ` Bryan O'Donoghue
2024-03-26 21:23       ` Konrad Dybcio
2024-03-27  9:55         ` Bryan O'Donoghue
2024-03-27 17:23           ` Konrad Dybcio
2024-02-09 21:09   ` [PATCH v2 04/20] media: venus: core: Set OPP clkname in a common code path Konrad Dybcio
2024-02-09 21:09   ` [PATCH v2 05/20] media: venus: pm_helpers: Kill dead code Konrad Dybcio
2024-03-04  5:40     ` Dikshita Agarwal
2024-03-26 21:30       ` Konrad Dybcio
2024-02-09 21:09   ` [PATCH v2 06/20] media: venus: pm_helpers: Move reset acquisition to common code Konrad Dybcio
2024-03-04  5:47     ` Dikshita Agarwal
2024-02-09 21:09   ` [PATCH v2 07/20] media: venus: core: Constify all members of the resource struct Konrad Dybcio
2024-02-21  0:59     ` Richard Acayan
2024-02-09 21:09   ` [PATCH v2 08/20] media: venus: core: Deduplicate OPP genpd names Konrad Dybcio
2024-03-06 12:28     ` Bryan O'Donoghue
2024-02-09 21:09   ` [PATCH v2 09/20] media: venus: core: Get rid of vcodec_num Konrad Dybcio
2024-03-06 12:29     ` Bryan O'Donoghue
2024-02-09 21:09   ` [PATCH v2 10/20] media: venus: core: Drop cache properties in resource struct Konrad Dybcio
2024-03-06 12:32     ` Bryan O'Donoghue
2024-02-09 21:09   ` [PATCH v2 11/20] media: venus: core: Use GENMASK for dma_mask Konrad Dybcio
2024-03-06 13:19     ` Bryan O'Donoghue
2024-02-09 21:09   ` [PATCH v2 12/20] media: venus: core: Remove cp_start Konrad Dybcio
2024-03-06 13:20     ` Bryan O'Donoghue
2024-02-09 21:09   ` [PATCH v2 13/20] media: venus: pm_helpers: Commonize core_power Konrad Dybcio
2024-02-09 21:09   ` [PATCH v2 14/20] media: venus: pm_helpers: Remove pm_ops->core_put Konrad Dybcio
2024-03-04  6:57     ` Dikshita Agarwal [this message]
2024-03-04 22:52       ` Konrad Dybcio
2024-03-06  9:54         ` Dikshita Agarwal
2024-02-09 21:09   ` [PATCH v2 15/20] media: venus: core: Define a pointer to core->res Konrad Dybcio
2024-02-09 21:10   ` [PATCH v2 16/20] media: venus: pm_helpers: Simplify vcodec clock handling Konrad Dybcio
2024-02-09 21:10   ` [PATCH v2 17/20] media: venus: pm_helpers: Commonize getting clocks and GenPDs Konrad Dybcio
2024-03-04  7:13     ` Dikshita Agarwal
2024-03-26 21:31       ` Konrad Dybcio
2024-02-09 21:10   ` [PATCH v2 18/20] media: venus: pm_helpers: Commonize vdec_get() Konrad Dybcio
2024-02-09 21:10   ` [PATCH v2 19/20] media: venus: pm_helpers: Commonize venc_get() Konrad Dybcio
2024-02-09 21:10   ` [PATCH v2 20/20] media: venus: pm_helpers: Use reset_bulk API Konrad Dybcio
2024-02-14 13:31     ` Philipp Zabel
2024-02-14 21:20       ` Konrad Dybcio
2024-02-21 13:34         ` Philipp Zabel
2024-02-21 13:37           ` Konrad Dybcio
2024-02-21 13:45             ` Philipp Zabel
2024-02-14 12:56   ` [PATCH v2 00/20] Venus cleanups Bryan O'Donoghue
2024-02-14 21:43     ` Konrad Dybcio
2024-07-12  5:48 ` [PATCH 1/2] PM: domains: add device managed version of dev_pm_domain_attach|detach_list() Dikshita Agarwal
2024-07-13  2:42   ` kernel test robot
2024-07-14 23:08   ` Bryan O'Donoghue
2024-07-16  4:11   ` Pavan Kondeti
2024-07-12  5:48 ` [PATCH 2/2] media: venus: use device managed APIs for power domains Dikshita Agarwal
2024-07-13  3:16   ` kernel test robot
2024-07-14 22:59   ` Bryan O'Donoghue
2024-07-15 11:17 ` [PATCH 0/2] add device managed version of dev_pm_domain_attach|detach_list() Ulf Hansson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ec239f69-6ace-c4a4-409c-771f1d24ce81@quicinc.com \
    --to=quic_dikshita@quicinc.com \
    --cc=agross@kernel.org \
    --cc=andersson@kernel.org \
    --cc=bryan.odonoghue@linaro.org \
    --cc=konrad.dybcio@linaro.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=marijn.suijten@somainline.org \
    --cc=mchehab+huawei@kernel.org \
    --cc=mchehab@kernel.org \
    --cc=p.zabel@pengutronix.de \
    --cc=quic_vgarodia@quicinc.com \
    --cc=stanimir.k.varbanov@gmail.com \
    --cc=stanimir.varbanov@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox