From: Guo Ren <guoren@kernel.org>
To: Paul Walmsley <pjw@kernel.org>,
Palmer Dabbelt <palmer@dabbelt.com>,
Albert Ou <aou@eecs.berkeley.edu>,
Alexandre Ghiti <alex@ghiti.fr>,
Daniel Lezcano <daniel.lezcano@kernel.org>,
Thomas Gleixner <tglx@kernel.org>, Radu Rendec <radu@rendec.net>,
Anup Patel <anup@brainfault.org>,
Tiffany Lin <tiffany.lin@mediatek.com>,
Andrew-CT Chen <andrew-ct.chen@mediatek.com>,
Yunfei Dong <yunfei.dong@mediatek.com>,
Minghsiu Tsai <minghsiu.tsai@mediatek.com>,
Houlong Wei <houlong.wei@mediatek.com>,
Mauro Carvalho Chehab <mchehab@kernel.org>,
Matthias Brugger <matthias.bgg@gmail.com>,
AngeloGioacchino Del Regno
<angelogioacchino.delregno@collabora.com>
Cc: linux-riscv@lists.infradead.org, linux-kernel@vger.kernel.org,
linux-media@vger.kernel.org,
linux-arm-kernel@lists.infradead.org,
linux-mediatek@lists.infradead.org,
"tip-bot2 for GUO Ren (XuanTie)" <tip-bot2@linutronix.de>,
"GUO Ren (XuanTie)" <guoren@kernel.org>,
Nathan Chancellor <nathan@kernel.org>
Subject: [PATCH v2 0/6] riscv: Make IPI_MAX visible and use it consistently
Date: Fri, 11 Sep 2026 03:27:08 +0000 [thread overview]
Message-ID: <20260911-ipi_max-v2-0-a77826ff189e@kernel.org> (raw)
This series removes the implicit assumption that RISC-V supports exactly
eight IPI message types.
Currently, the SBI, CLINT and ACLINT SSWI IPI providers use
BITS_PER_BYTE when sizing the generic IPI mux, while IMSIC carries a
separate IMSIC_NR_IPI definition set to 8. These values happen to match
IPI_MAX today, but neither is the proper source of truth for the number
of RISC-V IPI message types.
Move enum ipi_message_type to asm/smp.h so IPI providers can use IPI_MAX
directly, then replace the BITS_PER_BYTE and IMSIC_NR_IPI uses with
IPI_MAX.
This also makes adding future RISC-V IPI message types independent of
the current eight-entry assumption.
A follow-up patch renames the MediaTek VPU mailbox terminator from
IPI_MAX to IPI_VPU_MAX. That token belongs to the VPU firmware IPI id
enum and should follow the same prefixed convention as IPI_VPU_INIT
(and SCP_IPI_MAX on the SCP side), instead of reusing the generic
IPI_MAX name.
---
GUO Ren (XuanTie) (4):
clocksource: clint: Use IPI_MAX for IPI muxing
irqchip/aclint-sswi: Use IPI_MAX for IPI muxing
irqchip/imsic: Use IPI_MAX instead of IMSIC_NR_IPI
media: mtk-vpu: rename IPI_MAX to IPI_VPU_MAX
tip-bot2 for GUO Ren (XuanTie) (2):
riscv: smp: Move enum ipi_message_type to asm/smp.h
riscv: sbi: Use IPI_MAX for SBI IPI muxing
arch/riscv/include/asm/smp.h | 12 ++++++++++++
arch/riscv/kernel/sbi-ipi.c | 4 ++--
arch/riscv/kernel/smp.c | 12 ------------
drivers/clocksource/timer-clint.c | 4 ++--
drivers/irqchip/irq-aclint-sswi.c | 4 ++--
drivers/irqchip/irq-riscv-imsic-early.c | 4 ++--
drivers/irqchip/irq-riscv-imsic-state.h | 1 -
drivers/media/platform/mediatek/vpu/mtk_vpu.c | 12 ++++++------
drivers/media/platform/mediatek/vpu/mtk_vpu.h | 4 ++--
9 files changed, 28 insertions(+), 29 deletions(-)
---
base-commit: 08df884136f1c1197bab2a27814404fd329d9aac
change-id: 20260911-ipi_max-ff71eeadf6fd
Best regards,
--
GUO Ren (XuanTie) <guoren@kernel.org>
next reply other threads:[~2026-09-11 3:28 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-11 3:27 Guo Ren [this message]
2026-09-11 3:27 ` [PATCH v2 1/6] riscv: smp: Move enum ipi_message_type to asm/smp.h Guo Ren
2026-09-11 3:27 ` [PATCH v2 2/6] riscv: sbi: Use IPI_MAX for SBI IPI muxing Guo Ren
2026-09-11 3:27 ` [PATCH v2 3/6] clocksource: clint: Use IPI_MAX for " GUO Ren (XuanTie)
2026-09-11 3:27 ` [PATCH v2 4/6] irqchip/aclint-sswi: " GUO Ren (XuanTie)
2026-09-11 3:27 ` [PATCH v2 5/6] irqchip/imsic: Use IPI_MAX instead of IMSIC_NR_IPI GUO Ren (XuanTie)
2026-09-11 3:27 ` [PATCH v2 6/6] media: mtk-vpu: rename IPI_MAX to IPI_VPU_MAX GUO Ren (XuanTie)
2026-09-13 19:53 ` [PATCH v2 0/6] riscv: Make IPI_MAX visible and use it consistently Radu Rendec
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260911-ipi_max-v2-0-a77826ff189e@kernel.org \
--to=guoren@kernel.org \
--cc=alex@ghiti.fr \
--cc=andrew-ct.chen@mediatek.com \
--cc=angelogioacchino.delregno@collabora.com \
--cc=anup@brainfault.org \
--cc=aou@eecs.berkeley.edu \
--cc=daniel.lezcano@kernel.org \
--cc=houlong.wei@mediatek.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=linux-mediatek@lists.infradead.org \
--cc=linux-riscv@lists.infradead.org \
--cc=matthias.bgg@gmail.com \
--cc=mchehab@kernel.org \
--cc=minghsiu.tsai@mediatek.com \
--cc=nathan@kernel.org \
--cc=palmer@dabbelt.com \
--cc=pjw@kernel.org \
--cc=radu@rendec.net \
--cc=tglx@kernel.org \
--cc=tiffany.lin@mediatek.com \
--cc=tip-bot2@linutronix.de \
--cc=yunfei.dong@mediatek.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox