From: "Philippe Mathieu-Daudé" <philmd@oss.qualcomm.com>
To: "Thomas Weißschuh" <thomas.weissschuh@linutronix.de>,
"Andy Lutomirski" <luto@kernel.org>,
"Thomas Gleixner" <tglx@kernel.org>,
"Vincenzo Frascino" <vincenzo.frascino@arm.com>,
"Thomas Bogendoerfer" <tsbogend@alpha.franken.de>
Cc: linux-kernel@vger.kernel.org, linux-mips@vger.kernel.org
Subject: Re: [PATCH 4/6] vDSO: Automatically select HAVE_GENERIC_VDSO if necessary
Date: Thu, 9 Jul 2026 13:09:45 +0200 [thread overview]
Message-ID: <0aea2963-ede7-46d3-b2f1-28c362170ce1@oss.qualcomm.com> (raw)
In-Reply-To: <20260709-vdso-have_generic_vdso-v1-4-d2e1061f268b@linutronix.de>
On 9/7/26 09:28, Thomas WeiÃschuh wrote:
> gettimeofday() and getrandom() in the vDSO require the vDSO datastore.
>
> Enable it automatically if either one of them is enabled so the
> architecture code doesn't need to know this.
>
> Signed-off-by: Thomas Weißschuh <thomas.weissschuh@linutronix.de>
> ---
> lib/vdso/Kconfig | 6 ++----
> 1 file changed, 2 insertions(+), 4 deletions(-)
Reviewed-by: Philippe Mathieu-Daudé <philmd@oss.qualcomm.com>
next prev parent reply other threads:[~2026-07-09 11:09 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-09 7:28 [PATCH 0/6] vDSO: Clean up the HAVE_GENERIC_VDSO kconfig symbol Thomas Weißschuh
2026-07-09 7:28 ` [PATCH 1/6] futex: Remove dependency on HAVE_GENERIC_VDSO from FUTEX_ROBUST_UNLOCK Thomas Weißschuh
2026-07-09 9:27 ` Vincenzo Frascino
2026-07-09 7:28 ` [PATCH 2/6] vDSO: Remove the dependency on HAVE_GENERIC_VDSO from ARCH_HAS_VDSO_ARCH_DATA Thomas Weißschuh
2026-07-09 9:28 ` Vincenzo Frascino
2026-07-09 7:28 ` [PATCH 3/6] MIPS: vdso: Stop using CONFIG_HAVE_GENERIC_VDSO Thomas Weißschuh
2026-07-09 9:29 ` Vincenzo Frascino
2026-07-09 7:28 ` [PATCH 4/6] vDSO: Automatically select HAVE_GENERIC_VDSO if necessary Thomas Weißschuh
2026-07-09 9:30 ` Vincenzo Frascino
2026-07-09 11:09 ` Philippe Mathieu-Daudé [this message]
2026-07-09 7:28 ` [PATCH 5/6] vDSO: Drop HAVE_GENERIC_VDSO from architecture kconfig files Thomas Weißschuh
2026-07-09 9:31 ` Vincenzo Frascino
2026-07-09 7:28 ` [PATCH 6/6] vDSO: Rename HAVE_GENERIC_VDSO to VDSO_DATASTORE Thomas Weißschuh
2026-07-09 9:31 ` Vincenzo Frascino
2026-07-09 11:10 ` Philippe Mathieu-Daudé
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=0aea2963-ede7-46d3-b2f1-28c362170ce1@oss.qualcomm.com \
--to=philmd@oss.qualcomm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mips@vger.kernel.org \
--cc=luto@kernel.org \
--cc=tglx@kernel.org \
--cc=thomas.weissschuh@linutronix.de \
--cc=tsbogend@alpha.franken.de \
--cc=vincenzo.frascino@arm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox