From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by smtp.lore.kernel.org (Postfix) with ESMTP id F08A9C7EE24 for ; Mon, 15 May 2023 09:26:50 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S233252AbjEOJ0s (ORCPT ); Mon, 15 May 2023 05:26:48 -0400 Received: from lindbergh.monkeyblade.net ([23.128.96.19]:60878 "EHLO lindbergh.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S239726AbjEOJ0Y (ORCPT ); Mon, 15 May 2023 05:26:24 -0400 Received: from metis.ext.pengutronix.de (metis.ext.pengutronix.de [IPv6:2001:67c:670:201:290:27ff:fe1d:cc33]) by lindbergh.monkeyblade.net (Postfix) with ESMTPS id 0754D270E for ; Mon, 15 May 2023 02:24:54 -0700 (PDT) Received: from drehscheibe.grey.stw.pengutronix.de ([2a0a:edc0:0:c01:1d::a2]) by metis.ext.pengutronix.de with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1pyUNq-0004G7-84; Mon, 15 May 2023 11:20:46 +0200 Received: from [2a0a:edc0:0:900:1d::77] (helo=ptz.office.stw.pengutronix.de) by drehscheibe.grey.stw.pengutronix.de with esmtp (Exim 4.94.2) (envelope-from ) id 1pyUNQ-000KQl-8J; Mon, 15 May 2023 11:20:20 +0200 Received: from ukl by ptz.office.stw.pengutronix.de with local (Exim 4.94.2) (envelope-from ) id 1pyUNP-004cYH-B9; Mon, 15 May 2023 11:20:19 +0200 Date: Mon, 15 May 2023 11:20:19 +0200 From: Uwe =?utf-8?Q?Kleine-K=C3=B6nig?= To: Inki Dae Cc: Heiko =?utf-8?Q?St=C3=BCbner?= , Xinliang Liu , Linus Walleij , dri-devel@lists.freedesktop.org, Russell King , Alim Akhtar , Anitha Chrisanthus , Marijn Suijten , Steven Price , Sumit Semwal , Jerome Brunet , Robert Foss , Karol Herbst , Samuel Holland , Kevin Hilman , =?utf-8?B?TWHDrXJh?= Canal , Javier Martinez Canillas , Kuogee Hsieh , Akhil P Oommen , Danilo Krummrich , NXP Linux Team , Miaoqian Lin , linux-rockchip@lists.infradead.org, linux-sunxi@lists.linux.dev, Rahul T R , Raphael Gallais-Pou , Jani Nikula , Sascha Hauer , etnaviv@lists.freedesktop.org, Stephen Boyd , Sean Paul , Johan Hovold , Hyun Kwon , Andrew Jeffery , Jingoo Han , Seung-Woo Kim , Noralf =?utf-8?Q?Tr=C3=B8nnes?= , kernel@pengutronix.de, Alex Deucher , freedreno@lists.freedesktop.org, Claudiu Beznea , Alexandre Belloni , linux-aspeed@lists.ozlabs.org, Tomi Valkeinen , Thierry Reding , Yongqin Liu , Mihail Atanassov , Liang He , Ville =?utf-8?B?U3lyasOkbMOk?= , lima@lists.freedesktop.org, Chunyan Zhang , Alexey Brodkin , Minghao Chi , Jonathan Hunter , Martin Blumenstingl , Ben Skeggs , Russell King , Alain Volmat , linux-mips@vger.kernel.org, Liu Ying , linux-arm-msm@vger.kernel.org, Maxime Ripard , linux-samsung-soc@vger.kernel.org, linux-amlogic@lists.infradead.org, linux-arm-kernel@lists.infradead.org, Neil Armstrong , Boris Brezillon , Douglas Anderson , John Stultz , Paul Kocialkowski , Kyungmin Park , Maxime Coquelin , Brian Starkey , Kuninori Morimoto , Yuan Can , Stefan Agner , Michal Simek , linux-tegra@vger.kernel.org, Laurent Pinchart , Andrzej Hajda , Sam Ravnborg , Rob Herring , Xinwei Kong , Jernej Skrabec , Chen-Yu Tsai , Mali DP Maintainers , Joel Stanley , nouveau@lists.freedesktop.org, Orson Zhai , Chun-Kuang Hu , Lyude Paul , Arnd Bergmann , Guo Zhengkui , Konrad Dybcio , Alison Wang , Abhinav Kumar , Christian Gmeiner , Mark Brown , Maxime Ripard , Baolin Wang , Daniel Vetter , Liu Shixin , Tomi Valkeinen , Deepak R Varma , Kieran Bingham , Ricardo Ribalda , Tian Tao , Shawn Guo , Yannick Fertre , linux-stm32@st-md-mailman.stormreply.com, Emma Anholt , Liviu Dudau , Alexandre Torgue , Sandy Huang , Paul Cercueil , David Airlie , Marek Vasut , linux-renesas-soc@vger.kernel.org, Jayshri Pawar , Jonas Karlman , Rob Clark , Philippe Cornu , Thomas Zimmermann , Melissa Wen , linux-mediatek@lists.infradead.org, Fabio Estevam , Laurentiu Palcu , Matthias Brugger , AngeloGioacchino Del Regno , Bjorn Andersson , Nicolas Ferre , Krzysztof Kozlowski , Qiang Yu , Philipp Zabel , Dmitry Baryshkov , Jyri Sarha , Lucas Stach Subject: Re: [PATCH 00/53] drm: Convert to platform remove callback returning void Message-ID: <20230515092019.a3uwmofkkujo772g@pengutronix.de> References: <20230507162616.1368908-1-u.kleine-koenig@pengutronix.de> MIME-Version: 1.0 Content-Type: multipart/signed; micalg=pgp-sha512; protocol="application/pgp-signature"; boundary="suzv37z45wvm64m4" Content-Disposition: inline In-Reply-To: X-SA-Exim-Connect-IP: 2a0a:edc0:0:c01:1d::a2 X-SA-Exim-Mail-From: ukl@pengutronix.de X-SA-Exim-Scanned: No (on metis.ext.pengutronix.de); SAEximRunCond expanded to false X-PTX-Original-Recipient: linux-mips@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-mips@vger.kernel.org --suzv37z45wvm64m4 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline Content-Transfer-Encoding: quoted-printable On Mon, May 15, 2023 at 04:50:57PM +0900, Inki Dae wrote: > Hi, >=20 > 2023=EB=85=84 5=EC=9B=94 8=EC=9D=BC (=EC=9B=94) =EC=98=A4=EC=A0=84 1:32, = Uwe Kleine-K=C3=B6nig =EB=8B=98=EC=9D=B4 = =EC=9E=91=EC=84=B1: > > > > Hello, > > > > this patch series adapts the platform drivers below drivers/gpu/drm > > to use the .remove_new() callback. Compared to the traditional .remove() > > callback .remove_new() returns no value. This is a good thing because >=20 > First of all, I apologize for the delay in providing my review comments. >=20 > Not related to this patch but seems that the "remove_new" callback > naming implicitly implies that there is no need to return anything > since its return type is void. To help users understand the intended > behavior based on the callback name, how about considering a modified > naming convention like "remove_no_return" or something similar? >=20 > The relevant patch has already been merged as outlined below, > author Uwe Kleine-K=C3=B6nig 2022-12-09 > 16:09:14 +0100 > committer Greg Kroah-Hartman 2023-01-17 > 19:04:17 +0100 > commit 5c5a7680e67ba6fbbb5f4d79fa41485450c1985c (patch) > tree 0b6dbc003a6bb4a3f7fb084d31326bbfa3ba3f7c > parent 7bbb89b420d9e290cb34864832de8fcdf2c140dc (diff) > download linux-5c5a7680e67ba6fbbb5f4d79fa41485450c1985c.tar.gz > platform: Provide a remove callback that returns no value >=20 > Maybe a trivial thing but how about renaming it? I think the postfix, > 'new', is a very generic word. I think you could introduce another > patch for it if you think it's reasonable. =2Eremove_new is only a temporary name. Once all drivers are converted, =2Eremove is changed to return void and then all drivers are converted back. While "remove_new" might not be a brilliant name choice, touching all already converted drivers again just to improve the temporary measures doesn't sound right. Best regards Uwe --=20 Pengutronix e.K. | Uwe Kleine-K=C3=B6nig = | Industrial Linux Solutions | https://www.pengutronix.de/ | --suzv37z45wvm64m4 Content-Type: application/pgp-signature; name="signature.asc" -----BEGIN PGP SIGNATURE----- iQEzBAABCgAdFiEEP4GsaTp6HlmJrf7Tj4D7WH0S/k4FAmRh+VIACgkQj4D7WH0S /k7epggAlsMX1TbSjMAIV+LPNrZU/ErXl1QWJt2/nA/iQmxppFkkR19U334HeeZf VXsu0FwIvUZpfndnO3hCw3pvEa4gQiTo7reQsd28ECZaLwTVQYvp6o/LceTtaOJ2 5+FeefPV0mHxQ6SiXZ7g7aA4gkkw2iJY9s7LaPHHXw0jpyOpcZHlNzJioLe4RHdT eFYzR99DVhYH81tw8szT4fpAS3Vw2Eqq5PyQHDRT12PrJdM0Ig+3ei53DU4adRWh w/kH6vGx2XBIbqNrXq5AcSjVnMvrKq7iKPRxMCz58JC4oCirfqT+7tGWbOgJLLEx BCbOuZXZE9d8Thjrbo3cXVRujnhsLg== =GMrP -----END PGP SIGNATURE----- --suzv37z45wvm64m4--