Linux MIPS Architecture development
 help / color / mirror / Atom feed
From: Justin Swartz <justin.swartz@risingedge.co.za>
To: "Arınç ÜNAL" <arinc.unal@arinc9.com>
Cc: Sergio Paracuellos <sergio.paracuellos@gmail.com>,
	Rob Herring <robh+dt@kernel.org>,
	Krzysztof Kozlowski <krzysztof.kozlowski+dt@linaro.org>,
	Conor Dooley <conor+dt@kernel.org>,
	Thomas Bogendoerfer <tsbogend@alpha.franken.de>,
	Matthias Brugger <matthias.bgg@gmail.com>,
	AngeloGioacchino Del Regno
	<angelogioacchino.delregno@collabora.com>,
	linux-mips@vger.kernel.org, devicetree@vger.kernel.org,
	linux-kernel@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org,
	linux-mediatek@lists.infradead.org
Subject: Re: [PATCH v2] mips: dts: ralink: mt7621: add cell count properties to usb
Date: Fri, 08 Mar 2024 15:57:42 +0200	[thread overview]
Message-ID: <59b0b2084ea1322c3db2bfe9f2c2c702@risingedge.co.za> (raw)
In-Reply-To: <7e9221ae-e53b-475f-9b6f-4cab58b2d109@arinc9.com>

On 2024-03-08 15:48, Arınç ÜNAL wrote:
> On 8.03.2024 16:21, Justin Swartz wrote:
>> 
>> On 2024-03-08 14:01, Arınç ÜNAL wrote:
>>> On 8.03.2024 01:37, Justin Swartz wrote:
>>>> Add default #address-cells and #size-cells properties to the
>>>> usb node, which should be suitable for hubs and devices without
>>>> explicitly declared interface nodes, as:
>>>> 
>>>>    "#address-cells":
>>>>      description: should be 1 for hub nodes with device nodes,
>>>>        should be 2 for device nodes with interface nodes.
>>>>      enum: [1, 2]
>>>> 
>>>>    "#size-cells":
>>>>      const: 0
>>>> 
>>>> -- Documentation/devicetree/bindings/usb/usb-device.yaml
>>>> 
>>>> This version of the patch places the properties according to
>>>> the order recommended by:
>>>> 
>>>>     Documentation/devicetree/bindings/dts-coding-style.rst
>>>> 
>>>> Signed-off-by: Justin Swartz <justin.swartz@risingedge.co.za>
>>>> ---
>>>>   arch/mips/boot/dts/ralink/mt7621.dtsi | 4 ++--
>>>>   1 file changed, 2 insertions(+), 2 deletions(-)
>>>> 
>>>> diff --git a/arch/mips/boot/dts/ralink/mt7621.dtsi 
>>>> b/arch/mips/boot/dts/ralink/mt7621.dtsi
>>>> index 5a89f0b8c..7532e17dd 100644
>>>> --- a/arch/mips/boot/dts/ralink/mt7621.dtsi
>>>> +++ b/arch/mips/boot/dts/ralink/mt7621.dtsi
>>>> @@ -289,10 +289,10 @@ usb: usb@1e1c0000 {
>>>>           reg = <0x1e1c0000 0x1000
>>>>                  0x1e1d0700 0x0100>;
>>>>           reg-names = "mac", "ippc";
>>>> -
>>>> +        #address-cells = <1>;
>>>> +        #size-cells = <0>;
>>>>           clocks = <&sysc MT7621_CLK_XTAL>;
>>>>           clock-names = "sys_ck";
>>>> -
>>> 
>>> Please keep the empty lines. It's easier to read. I don't see 
>>> anything on
>>> the Devicetree Sources (DTS) Coding Style that would restrict this.
>> 
>> The reason I removed them was due to the SoC DTSI example shown in [1]
>> lacking empty lines between properties, but then using them instead as
>> visual separation between properties and child nodes, or at least 
>> that's
>> how I understood it when I looked at it.
>> 
>> Personally, I prefer the look of the SoC DTSI example - but I don't 
>> mind
>> recreating the patch set with the empty lines between the properties 
>> left
>> entact.
>> 
>> As there is a mix of property spacing and ordering styles in 
>> mt7621.dtsi
>> already - what is the consensus on what a node in this file should 
>> look
>> like?
> 
> There's no precise spacing style I maintain here. I simply group 
> together
> properties that describe a single attribute, and separate those that
> describe different attributes.

I'll recreate v3 accordingly.


>> I also don't mind following that pattern and cleaning up the whole 
>> dtsi
>> according to that if it'll save us all time and energy in future.
> 
> If you'd like to improve the ordering style of the MT7621 device tree
> sources accordingly with
> Documentation/devicetree/bindings/dts-coding-style.rst, I'd be happy to
> review those patches.

Thanks, I'll make an attempt at this sometime soon.


Regards
Justin

  reply	other threads:[~2024-03-08 13:57 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <0001-mips-dts-ralink-mt7621-add-cell-count-properties-to-.patch>
2024-03-07 22:37 ` [PATCH v2] mips: dts: ralink: mt7621: add cell count properties to usb Justin Swartz
2024-03-08  9:32   ` Sergio Paracuellos
2024-03-08 12:01   ` Arınç ÜNAL
2024-03-08 13:21     ` Justin Swartz
2024-03-08 13:48       ` Arınç ÜNAL
2024-03-08 13:57         ` Justin Swartz [this message]
2024-03-07 14:58 [PATCH] mips: dts: ralink: mt7621: add cell count properties to usb0 Justin Swartz
2024-03-07 23:58 ` [PATCH v2] mips: dts: ralink: mt7621: add cell count properties to usb Justin Swartz

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=59b0b2084ea1322c3db2bfe9f2c2c702@risingedge.co.za \
    --to=justin.swartz@risingedge.co.za \
    --cc=angelogioacchino.delregno@collabora.com \
    --cc=arinc.unal@arinc9.com \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=krzysztof.kozlowski+dt@linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mediatek@lists.infradead.org \
    --cc=linux-mips@vger.kernel.org \
    --cc=matthias.bgg@gmail.com \
    --cc=robh+dt@kernel.org \
    --cc=sergio.paracuellos@gmail.com \
    --cc=tsbogend@alpha.franken.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox