From: SJ Park <sj@kernel.org>
To: xu.xin16@zte.com.cn
Cc: SJ Park <sj@kernel.org>,
akpm@linux-foundation.org, david@kernel.org, ljs@kernel.org,
ziy@nvidia.com, baolin.wang@linux.alibaba.com, baohua@kernel.org,
lance.yang@linux.dev, usama.arif@linux.dev,
chengming.zhou@linux.dev, qi.zheng@linux.dev, linux-mm@kvack.org,
linux-kernel@vger.kernel.org, npache@redhat.com,
ryan.roberts@arm.com, dev.jain@arm.com, wang.yaxin@zte.com.cn
Subject: Re: [PATCH v2 1/2] mm/mm_slot.h: add a helper function mm_slot_remove
Date: Mon, 13 Jul 2026 17:16:36 -0700 [thread overview]
Message-ID: <20260714001636.85603-1-sj@kernel.org> (raw)
In-Reply-To: <20260713143707966lCkTinO0i9zYAc1K2ZmqZ@zte.com.cn>
On Mon, 13 Jul 2026 14:37:07 +0800 (CST) <xu.xin16@zte.com.cn> wrote:
> From: xu xin <xu.xin16@zte.com.cn>
>
> Both THP and KSM manage per-mm scanning slots using the mm_slot
> structure. The slot is kept in a hash table and a list, and removal from
> both containers requires the same two operations: hash_del() and
> list_del().
>
> Introduce mm_slot_remove() to abstract the common hash_del() + list_del()
> sequence used in both khugepaged and KSM.
>
> No functional change is intended.
Looks good and clean to me!
>
> Signed-off-by: xu xin <xu.xin16@zte.com.cn>
Reviewed-by: SJ Park <sj@kernel.org>
[...]
> --- a/mm/mm_slot.h
> +++ b/mm/mm_slot.h
> @@ -52,4 +52,9 @@ static inline void mm_slot_free(struct kmem_cache *cache, void *objp)
> hash_add(_hashtable, &_mm_slot->hash, (unsigned long)_mm); \
> })
>
> +static inline void mm_slot_remove(struct mm_slot *slot)
> +{
> + hash_del(&slot->hash);
> + list_del(&slot->mm_node);
> +}
> #endif /* _LINUX_MM_SLOT_H */
I'd prefer keep having the one blank line bfore the #endif. Definitely not a
blocker but just thinking loud.
Thanks,
SJ
[...]
next prev parent reply other threads:[~2026-07-14 0:16 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-13 6:35 [PATCH v2 0/2] Two small patches to clean up mm/mm_slot.h xu.xin16
2026-07-13 6:37 ` [PATCH v2 1/2] mm/mm_slot.h: add a helper function mm_slot_remove xu.xin16
2026-07-13 11:48 ` Nico Pache
2026-07-13 13:51 ` Zi Yan
2026-07-13 15:19 ` Barry Song
2026-07-13 15:23 ` David Hildenbrand (Arm)
2026-07-13 16:03 ` Lorenzo Stoakes (ARM)
2026-07-14 0:16 ` SJ Park [this message]
2026-07-13 6:38 ` mm/mm_slot.h: clean up macro parameter names in mm_slot_lookup() and mm_slot_insert() xu.xin16
2026-07-13 6:41 ` [PATCH v2 2/2] " xu.xin16
2026-07-13 15:21 ` Barry Song
2026-07-14 0:32 ` xu.xin16
2026-07-13 16:13 ` Lorenzo Stoakes (ARM)
2026-07-14 0:41 ` xu.xin16
2026-07-14 1:06 ` Barry Song
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260714001636.85603-1-sj@kernel.org \
--to=sj@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=baohua@kernel.org \
--cc=baolin.wang@linux.alibaba.com \
--cc=chengming.zhou@linux.dev \
--cc=david@kernel.org \
--cc=dev.jain@arm.com \
--cc=lance.yang@linux.dev \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=ljs@kernel.org \
--cc=npache@redhat.com \
--cc=qi.zheng@linux.dev \
--cc=ryan.roberts@arm.com \
--cc=usama.arif@linux.dev \
--cc=wang.yaxin@zte.com.cn \
--cc=xu.xin16@zte.com.cn \
--cc=ziy@nvidia.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox