Linux-mm Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Usama Arif <usama.arif@linux.dev>
To: Christoph Hellwig <hch@lst.de>
Cc: Usama Arif <usama.arif@linux.dev>,
	baoquan.he@linux.dev, akpm@linux-foundation.org,
	chrisl@kernel.org, kasong@tencent.com, nphamcs@gmail.com,
	shikemeng@huaweicloud.com, youngjun.park@lge.com,
	ryncsn@gmail.com, trondmy@kernel.org, anna@kernel.org,
	sfrench@samba.org, linux-mm@kvack.org,
	linux-cifs@vger.kernel.org, linux-nfs@vger.kernel.org
Subject: Re: [PATCH 2/3] mm/swap: add a new swap_ops.h header to allow for pluggable swap ops
Date: Wed, 22 Jul 2026 09:32:17 -0700	[thread overview]
Message-ID: <20260722163218.1240273-1-usama.arif@linux.dev> (raw)
In-Reply-To: <20260722130615.3163560-3-hch@lst.de>

On Wed, 22 Jul 2026 15:06:08 +0200 Christoph Hellwig <hch@lst.de> wrote:

> Add a new header to declare the swap_iocb, swap_ops and swap_ctx to
> allow for swap_ops implementations outside of mm/page_io.c.  This
> will be used to remove the double indirection for file system-based
> swap.
> 
> Note that there already is a swapops.h header, which is totally
> unrelated to struct swap_ops.  The close naming is a bit unfortunate,
> but I could not think of a better name for this header.
> 
> Signed-off-by: Christoph Hellwig <hch@lst.de>
> ---
>  MAINTAINERS              |  1 +
>  include/linux/swap_ops.h | 39 +++++++++++++++++++++++++++++++++++++++
>  mm/madvise.c             |  1 +
>  mm/page_io.c             | 10 +---------
>  mm/shmem.c               |  1 +
>  mm/swap.h                | 23 +----------------------
>  mm/swap_state.c          |  1 +
>  mm/vmscan.c              |  1 +
>  8 files changed, 46 insertions(+), 31 deletions(-)
>  create mode 100644 include/linux/swap_ops.h
> 
> diff --git a/MAINTAINERS b/MAINTAINERS
> index 5da77924c6f0..cda42b7ed945 100644
> --- a/MAINTAINERS
> +++ b/MAINTAINERS
> @@ -17240,6 +17240,7 @@ S:	Maintained
>  F:	Documentation/ABI/testing/sysfs-kernel-mm-swap
>  F:	Documentation/mm/swap-table.rst
>  F:	include/linux/swap.h
> +F:	include/linux/swap_ops.h
>  F:	include/linux/swapfile.h
>  F:	include/linux/swapops.h
>  F:	mm/page_io.c
> diff --git a/include/linux/swap_ops.h b/include/linux/swap_ops.h
> new file mode 100644
> index 000000000000..e92b4f532604
> --- /dev/null
> +++ b/include/linux/swap_ops.h
> @@ -0,0 +1,39 @@
> +/* SPDX-License-Identifier: GPL-2.0 */
> +#ifndef _MM_SWAP_OPS_H
> +#define _MM_SWAP_OPS_H
> +
> +#include <linux/swap.h> /* for SWAP_CLUSTER_MAX */
> +
> +struct swap_iocb {
> +	union {
> +		struct kiocb	iocb;
> +		struct bio	bio;
> +	};
> +	struct bio_vec		bvecs[SWAP_CLUSTER_MAX];
> +	int			nr_bvecs;
> +	int			len;
> +};
> +
> +struct swap_io_ctx {
> +	struct swap_iocb	*sio;
> +	struct swap_info_struct	*sis;
> +};

zswap uses this struct, I think you need to include the header in zswap.c
as well, good to check if the build is passing with CONFIG_ZSWAP=y

> +
> +/*
> + * SWAP_OPS_F_REQUIRE_NOFS:
> + *	When set, all reclaim operations must operated as GFS_NOFS and not
> + *	just GFP_NOIO, as GFP_NOIO allocations could recourse into the
> + *	file system backing this swap file.
> + */
> +#define SWAP_OPS_F_REQUIRE_NOFS		(1U << 0)
> +
> +struct swap_ops {
> +	unsigned int		flags;
> +
> +	bool (*can_merge)(struct folio *folio, struct folio *prev_folio,
> +			size_t prev_folio_size, int rw);
> +	void (*submit_write)(struct swap_io_ctx *ctx);
> +	void (*submit_read)(struct swap_io_ctx *ctx);
> +};
> +
> +#endif /* _MM_SWAP_OPS_H */
> diff --git a/mm/madvise.c b/mm/madvise.c
> index 07a21ca31bad..c179938097bf 100644
> --- a/mm/madvise.c
> +++ b/mm/madvise.c
> @@ -32,6 +32,7 @@
>  #include <linux/leafops.h>
>  #include <linux/shmem_fs.h>
>  #include <linux/mmu_notifier.h>
> +#include <linux/swap_ops.h>
>  
>  #include <asm/tlb.h>
>  
> diff --git a/mm/page_io.c b/mm/page_io.c
> index c984a4023a65..e741e67d6592 100644
> --- a/mm/page_io.c
> +++ b/mm/page_io.c
> @@ -25,6 +25,7 @@
>  #include <linux/sched/task.h>
>  #include <linux/delayacct.h>
>  #include <linux/zswap.h>
> +#include <linux/swap_ops.h>
>  #include "swap.h"
>  #include "swap_table.h"
>  
> @@ -300,15 +301,6 @@ static bool folio_blkg_can_merge(struct folio *folio, struct folio *prev_folio)
>  #define bio_associate_blkg_from_page(bio, folio)		do { } while (0)
>  #endif /* CONFIG_MEMCG && CONFIG_BLK_CGROUP */
>  
> -struct swap_iocb {
> -	union {
> -		struct kiocb	iocb;
> -		struct bio	bio;
> -	};
> -	struct bio_vec		bvecs[SWAP_CLUSTER_MAX];
> -	int			nr_bvecs;
> -	int			len;
> -};
>  static mempool_t *sio_pool;
>  
>  int sio_pool_init(void)
> diff --git a/mm/shmem.c b/mm/shmem.c
> index 5071177059a9..797c42f024a0 100644
> --- a/mm/shmem.c
> +++ b/mm/shmem.c
> @@ -41,6 +41,7 @@
>  #include <linux/swapfile.h>
>  #include <linux/iversion.h>
>  #include <linux/unicode.h>
> +#include <linux/swap_ops.h>
>  #include "swap.h"
>  
>  static struct vfsmount *shm_mnt __ro_after_init;
> diff --git a/mm/swap.h b/mm/swap.h
> index abd26588abd2..19ea61c97df2 100644
> --- a/mm/swap.h
> +++ b/mm/swap.h
> @@ -8,6 +8,7 @@
>  struct mempolicy;
>  struct swap_iocb;
>  struct swap_memcg_table;
> +struct swap_io_ctx;
>  
>  #if defined(MAX_POSSIBLE_PHYSMEM_BITS)
>  #define SWAP_CACHE_PFN_BITS (MAX_POSSIBLE_PHYSMEM_BITS - PAGE_SHIFT)
> @@ -77,28 +78,6 @@ enum swap_cluster_flags {
>  	CLUSTER_FLAG_MAX,
>  };
>  
> -struct swap_io_ctx {
> -	struct swap_iocb	*sio;
> -	struct swap_info_struct	*sis;
> -};
> -
> -/*
> - * SWAP_OPS_F_REQUIRE_NOFS:
> - *	When set, all reclaim operations must operated as GFS_NOFS and not
> - *	just GFP_NOIO, as GFP_NOIO allocations could recourse into the
> - *	file system backing this swap file.
> - */
> -#define SWAP_OPS_F_REQUIRE_NOFS		(1U << 0)
> -
> -struct swap_ops {
> -	unsigned int		flags;
> -
> -	bool (*can_merge)(struct folio *folio, struct folio *prev_folio,
> -			size_t prev_folio_size, int rw);
> -	void (*submit_write)(struct swap_io_ctx *ctx);
> -	void (*submit_read)(struct swap_io_ctx *ctx);
> -};
> -
>  #ifdef CONFIG_SWAP
>  #include <linux/swapops.h> /* for swp_offset */
>  #include <linux/blk_types.h> /* for bio_end_io_t */
> diff --git a/mm/swap_state.c b/mm/swap_state.c
> index 5be825911e64..b76eb3d876fd 100644
> --- a/mm/swap_state.c
> +++ b/mm/swap_state.c
> @@ -23,6 +23,7 @@
>  #include <linux/huge_mm.h>
>  #include <linux/shmem_fs.h>
>  #include <linux/sysctl.h>
> +#include <linux/swap_ops.h>
>  #include "internal.h"
>  #include "swap_table.h"
>  #include "swap.h"
> diff --git a/mm/vmscan.c b/mm/vmscan.c
> index e26c6931f5fd..a12eb79c89c5 100644
> --- a/mm/vmscan.c
> +++ b/mm/vmscan.c
> @@ -58,6 +58,7 @@
>  #include <linux/random.h>
>  #include <linux/mmu_notifier.h>
>  #include <linux/parser.h>
> +#include <linux/swap_ops.h>
>  
>  #include <asm/tlbflush.h>
>  #include <asm/div64.h>
> -- 
> 2.53.0
> 
> 


  reply	other threads:[~2026-07-22 16:32 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-22 13:06 swap_ops updates Christoph Hellwig
2026-07-22 13:06 ` [PATCH 1/3] mm/swap: revert to single-folio writes for synchronous swap devices Christoph Hellwig
2026-07-22 16:36   ` Usama Arif
2026-07-22 16:57   ` Chris Li
2026-07-22 13:06 ` [PATCH 2/3] mm/swap: add a new swap_ops.h header to allow for pluggable swap ops Christoph Hellwig
2026-07-22 16:32   ` Usama Arif [this message]
2026-07-22 16:56   ` Chris Li
2026-07-22 13:06 ` [PATCH 3/3] mm/swap: move swap_ops into file systems for file system-based swap Christoph Hellwig
2026-07-22 17:07   ` Chris Li

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260722163218.1240273-1-usama.arif@linux.dev \
    --to=usama.arif@linux.dev \
    --cc=akpm@linux-foundation.org \
    --cc=anna@kernel.org \
    --cc=baoquan.he@linux.dev \
    --cc=chrisl@kernel.org \
    --cc=hch@lst.de \
    --cc=kasong@tencent.com \
    --cc=linux-cifs@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-nfs@vger.kernel.org \
    --cc=nphamcs@gmail.com \
    --cc=ryncsn@gmail.com \
    --cc=sfrench@samba.org \
    --cc=shikemeng@huaweicloud.com \
    --cc=trondmy@kernel.org \
    --cc=youngjun.park@lge.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox