From: SJ Park <sj@kernel.org>
To: SJ Park <sj@kernel.org>
Cc: Andrew Morton <akpm@linux-foundation.org>,
damon@lists.linux.dev, linux-kernel@vger.kernel.org,
linux-mm@kvack.org
Subject: Re: [PATCH v2 1/7] mm/damon/api: introduce DAMOS_FILTER_TYPE_PROBE_HITS_WSUM
Date: Fri, 11 Sep 2026 07:25:22 -0700 [thread overview]
Message-ID: <20260911142522.98013-1-sj@kernel.org> (raw)
In-Reply-To: <20260911135510.96914-2-sj@kernel.org>
On Fri, 11 Sep 2026 06:55:03 -0700 SJ Park <sj@kernel.org> wrote:
> Update DAMON kernel API to introduce new DAMOS core filter type,
> PROBE_HITS_WSUM. It will allow API callers to describe the DAMOS action
> target regions based on their probe_hits weighted sum. For describing
> the filtering target weighted sum range, add two type-dependent union
> fields to damos_filter.
>
> Signed-off-by: SJ Park <sj@kernel.org>
> ---
> include/linux/damon.h | 20 ++++++++++++++------
> 1 file changed, 14 insertions(+), 6 deletions(-)
>
> diff --git a/include/linux/damon.h b/include/linux/damon.h
> index 16800b3dc379b..9e84bdeb5616d 100644
> --- a/include/linux/damon.h
> +++ b/include/linux/damon.h
> @@ -399,14 +399,15 @@ struct damos_stat {
> * @DAMOS_FILTER_TYPE_UNMAPPED: Unmapped pages.
> * @DAMOS_FILTER_TYPE_ADDR: Address range.
> * @DAMOS_FILTER_TYPE_TARGET: Data Access Monitoring target.
> + * @DAMOS_FILTER_TYPE_PROBE_HITS_WSUM: probe_hits weighted sum range.
> * @NR_DAMOS_FILTER_TYPES: Number of filter types.
> *
> - * All types except &DAMOS_FILTER_TYPE_ADDR and &DAMOS_FILTER_TYPE_TARGET
> - * are handled by the underlying &struct damon_operations as a part of scheme
> - * action trying, and therefore accounted as 'tried'. In contrast,
> - * &DAMOS_FILTER_TYPE_ADDR and &DAMOS_FILTER_TYPE_TARGET filters are handled
> - * by the core layer before trying of the action, and therefore not accounted
> - * as 'tried'.
> + * All types except &DAMOS_FILTER_TYPE_ADDR, &DAMOS_FILTER_TYPE_TARGET and
> + * &DAMOS_FILTER_TYPE_PROBE_HITS_WSUM are handled by the underlying &struct
> + * damon_operations as a part of scheme action trying, and therefore accounted
> + * as 'tried'. In contrast, &DAMOS_FILTER_TYPE_ADDR and
> + * &DAMOS_FILTER_TYPE_TARGET filters are handled by the core layer before
> + * trying of the action, and therefore not accounted as 'tried'.
Sashiko found [1] the second sentence is also better to be updated. Reposting
this patch only for the trivial change feels too much to me. Andrew, could you
please add attaching patch as a fixup? Please let me know if you prefer
reposting the series.
[1] https://lore.kernel.org/20260911142049.97838-1-sj@kernel.org
Thanks,
SJ
[...]
=== >8 ===
From 8095628debba5ececa0664314ef4a3b777ef0fbf Mon Sep 17 00:00:00 2001
From: SJ Park <sj@kernel.org>
Date: Fri, 11 Sep 2026 07:20:01 -0700
Subject: [PATCH] mm/damon/api: clarify DAMOS_FILTER_TYPE_PROBE_HITS_WSUM
behavior
Clarify it's behavior.
Signed-off-by: SJ Park <sj@kernel.org>
---
include/linux/damon.h | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/include/linux/damon.h b/include/linux/damon.h
index 33929a400aa7a..23df189015198 100644
--- a/include/linux/damon.h
+++ b/include/linux/damon.h
@@ -440,9 +440,9 @@ struct damos_stat {
* All types except &DAMOS_FILTER_TYPE_ADDR, &DAMOS_FILTER_TYPE_TARGET and
* &DAMOS_FILTER_TYPE_PROBE_HITS_WSUM are handled by the underlying &struct
* damon_operations as a part of scheme action trying, and therefore accounted
- * as 'tried'. In contrast, &DAMOS_FILTER_TYPE_ADDR and
- * &DAMOS_FILTER_TYPE_TARGET filters are handled by the core layer before
- * trying of the action, and therefore not accounted as 'tried'.
+ * as 'tried'. In contrast, &DAMOS_FILTER_TYPE_ADDR, &DAMOS_FILTER_TYPE_TARGET
+ * and &DAMOS_FILTER_TYPE_PROBE_HITS_WSUM filters are handled by the core layer
+ * before trying of the action, and therefore not accounted as 'tried'.
*
* Support for the operations-handled filters depends on the running
* &struct damon_operations.
--
2.47.3
next prev parent reply other threads:[~2026-09-11 14:25 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-11 13:55 [PATCH v2 0/7] mm/damon: introduce probe_hits_wsum DAMOS core filter SJ Park
2026-09-11 13:55 ` [PATCH v2 1/7] mm/damon/api: introduce DAMOS_FILTER_TYPE_PROBE_HITS_WSUM SJ Park
2026-09-11 14:25 ` SJ Park [this message]
2026-09-11 13:55 ` [PATCH v2 2/7] mm/damon/core: extend probe_hits_wsum() for moving sum based calculation SJ Park
2026-09-11 13:55 ` [PATCH v2 3/7] mm/damon/core: support probe_hits_wsum damos core filter SJ Park
2026-09-11 13:55 ` [PATCH v2 4/7] mm/damon/sysfs-schemes: rename sysfs_filter->sz_range to range_{min,max} SJ Park
2026-09-11 13:55 ` [PATCH v2 5/7] mm/damon/sysfs-schemes: support probe_hits_wsum damos core filter SJ Park
2026-09-11 13:55 ` [PATCH v2 6/7] Docs/mm/damon/design: update for probe_hits_wsum DAMOS " SJ Park
2026-09-11 13:55 ` [PATCH v2 7/7] Docs/admin-guide/mm/damon/usage: update for probe_hits_wsum DAMOS filter SJ Park
2026-09-11 14:28 ` [PATCH v2 0/7] mm/damon: introduce probe_hits_wsum DAMOS core filter SJ Park
2026-09-11 23:19 ` Andrew Morton
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260911142522.98013-1-sj@kernel.org \
--to=sj@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=damon@lists.linux.dev \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox