From: Yeoreum Yun <yeoreum.yun@arm.com>
To: Lorenzo Stoakes <ljs@kernel.org>,
"Liam R. Howlett" <liam@infradead.org>,
Vlastimil Babka <vbabka@kernel.org>,
Mike Rapoport <rppt@kernel.org>,
Suren Baghdasaryan <surenb@google.com>,
Michal Hocko <mhocko@suse.com>, Zi Yan <ziy@nvidia.com>,
Baolin Wang <baolin.wang@linux.alibaba.com>,
Nico Pache <nico.pache@linux.dev>,
Ryan Roberts <ryan.roberts@arm.com>, Dev Jain <dev.jain@arm.com>,
Barry Song <baohua@kernel.org>,
Lance Yang <lance.yang@linux.dev>,
Usama Arif <usama.arif@linux.dev>,
Kiryl Shutsemau <kas@kernel.org>, Peter Xu <peterx@redhat.com>,
linux-mm@kvack.org, linux-kselftest@vger.kernel.org,
linux-kernel@vger.kernel.org
Cc: Andrew Morton <akpm@linux-foundation.org>,
David Hildenbrand <david@kernel.org>,
Shuah Khan <shuah@kernel.org>, Jason Gunthorpe <jgg@ziepe.ca>,
Leon Romanovsky <leon@kernel.org>,
Sarthak Sharma <sarthak.sharma@arm.com>,
Yeoreum Yun <yeoreum.yun@arm.com>
Subject: [PATCH v3 3/3] kselftest: mm: introduce size_to_shift() helper
Date: Mon, 14 Sep 2026 08:30:48 +0100 [thread overview]
Message-ID: <20260914-fix_hpage_macro-v3-3-c9a305a01d39@arm.com> (raw)
In-Reply-To: <20260914-fix_hpage_macro-v3-0-c9a305a01d39@arm.com>
Introduce size_to_shift() for future users that need to
obtain shift of a huge-page which is other than pmd_psize().
Suggested-by: David Hildenbrand (Arm) <david@kernel.org>
Signed-off-by: Yeoreum Yun <yeoreum.yun@arm.com>
---
tools/testing/selftests/mm/vm_util.c | 10 +++++++++-
tools/testing/selftests/mm/vm_util.h | 1 +
2 files changed, 10 insertions(+), 1 deletion(-)
diff --git a/tools/testing/selftests/mm/vm_util.c b/tools/testing/selftests/mm/vm_util.c
index fd1432dc6152..1fef1266429f 100644
--- a/tools/testing/selftests/mm/vm_util.c
+++ b/tools/testing/selftests/mm/vm_util.c
@@ -157,6 +157,14 @@ bool check_for_pattern(FILE *fp, const char *pattern, char *buf, size_t len)
return false;
}
+uint64_t size_to_shift(uint64_t size)
+{
+ if (__builtin_popcountll(size) != 1)
+ return 0;
+
+ return ffsl(size) - 1;
+}
+
uint64_t pmd_psize(void)
{
int fd;
@@ -194,7 +202,7 @@ uint64_t pmd_pshift(void)
if (!__pmd_psize)
return 0;
- __pmd_pshift = ffsl(__pmd_psize) - 1;
+ __pmd_pshift = size_to_shift(__pmd_psize);
return __pmd_pshift;
}
diff --git a/tools/testing/selftests/mm/vm_util.h b/tools/testing/selftests/mm/vm_util.h
index 71af4804f8f2..0048e0e82770 100644
--- a/tools/testing/selftests/mm/vm_util.h
+++ b/tools/testing/selftests/mm/vm_util.h
@@ -90,6 +90,7 @@ bool pagemap_is_populated(int fd, char *start);
unsigned long pagemap_get_pfn(int fd, char *start);
void clear_softdirty(void);
bool check_for_pattern(FILE *fp, const char *pattern, char *buf, size_t len);
+uint64_t size_to_shift(uint64_t size);
uint64_t pmd_psize(void);
uint64_t pmd_pshift(void);
unsigned long rss_anon(void);
--
2.43.0
next prev parent reply other threads:[~2026-09-14 7:31 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-14 7:30 [PATCH v3 0/3] kselftest: mm: remove HPAGE_SIZE and HPAGE_SHIFT macro Yeoreum Yun
2026-09-14 7:30 ` [PATCH v3 1/3] kselftest: mm: rename read_pmd_pagesize() to pmd_psize() Yeoreum Yun
2026-09-14 13:59 ` David Hildenbrand (Arm)
2026-09-15 2:14 ` Zi Yan
2026-09-15 8:54 ` Lorenzo Stoakes (ARM)
2026-09-14 7:30 ` [PATCH v3 2/3] kselftest: mm: remove HPAGE_SIZE and HPAGE_SHIFT macro Yeoreum Yun
2026-09-14 14:08 ` David Hildenbrand (Arm)
2026-09-14 16:46 ` Yeoreum Yun
2026-09-15 2:26 ` Zi Yan
2026-09-15 9:39 ` Yeoreum Yun
2026-09-14 7:30 ` Yeoreum Yun [this message]
2026-09-14 14:01 ` [PATCH v3 3/3] kselftest: mm: introduce size_to_shift() helper David Hildenbrand (Arm)
2026-09-14 14:06 ` Yeoreum Yun
2026-09-14 14:08 ` David Hildenbrand (Arm)
2026-09-15 9:01 ` Lorenzo Stoakes (ARM)
2026-09-15 9:47 ` Yeoreum Yun
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260914-fix_hpage_macro-v3-3-c9a305a01d39@arm.com \
--to=yeoreum.yun@arm.com \
--cc=akpm@linux-foundation.org \
--cc=baohua@kernel.org \
--cc=baolin.wang@linux.alibaba.com \
--cc=david@kernel.org \
--cc=dev.jain@arm.com \
--cc=jgg@ziepe.ca \
--cc=kas@kernel.org \
--cc=lance.yang@linux.dev \
--cc=leon@kernel.org \
--cc=liam@infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-kselftest@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=ljs@kernel.org \
--cc=mhocko@suse.com \
--cc=nico.pache@linux.dev \
--cc=peterx@redhat.com \
--cc=rppt@kernel.org \
--cc=ryan.roberts@arm.com \
--cc=sarthak.sharma@arm.com \
--cc=shuah@kernel.org \
--cc=surenb@google.com \
--cc=usama.arif@linux.dev \
--cc=vbabka@kernel.org \
--cc=ziy@nvidia.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox