From: Julian Braha <julianbraha@gmail.com>
To: Kaitao Cheng <kaitao.cheng@linux.dev>,
Andrew Morton <akpm@linux-foundation.org>,
David Hildenbrand <david@kernel.org>,
Lorenzo Stoakes <ljs@kernel.org>,
"Liam R . Howlett" <liam@infradead.org>,
Vlastimil Babka <vbabka@kernel.org>,
Mike Rapoport <rppt@kernel.org>,
Suren Baghdasaryan <surenb@google.com>,
Michal Hocko <mhocko@suse.com>
Cc: linux-mm@kvack.org, linux-kernel@vger.kernel.org,
Muchun Song <muchun.song@linux.dev>,
Kaitao Cheng <chengkaitao@kylinos.cn>
Subject: Re: [PATCH] mm/kconfig: Drop redundant memory hotplug dependencies
Date: Wed, 8 Jul 2026 15:10:29 +0100 [thread overview]
Message-ID: <4769c44a-4345-4015-afd8-1bba2474d81e@gmail.com> (raw)
In-Reply-To: <20260707090331.52971-1-kaitao.cheng@linux.dev>
Hi Kaitao,
On 7/7/26 10:03, Kaitao Cheng wrote:
> MHP_MEMMAP_ON_MEMORY is defined inside the MEMORY_HOTPLUG block, and
> MEMORY_HOTPLUG already depends on SPARSEMEM_VMEMMAP. Keep the explicit
> MEMORY_HOTPLUG dependency for local readability, but drop the redundant
> SPARSEMEM_VMEMMAP dependency.
I love a good kconfig cleanup, but why keep both the
'if MEMORY_HOTPLUG..endif' and the 'depends on MEMORY_HOTPLUG'?
The "local readability" could be achieved with a comment if keeping the
'if..endif'.
And if we don't want the comment and would prefer the explicit
'depends on', then why not remove the 'if..endif'?
- Julian Braha
prev parent reply other threads:[~2026-07-08 14:10 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-07 9:03 [PATCH] mm/kconfig: Drop redundant memory hotplug dependencies Kaitao Cheng
2026-07-07 10:06 ` David Hildenbrand (Arm)
2026-07-07 11:05 ` Muchun Song
2026-07-07 11:11 ` Lorenzo Stoakes
2026-07-08 14:10 ` Julian Braha [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4769c44a-4345-4015-afd8-1bba2474d81e@gmail.com \
--to=julianbraha@gmail.com \
--cc=akpm@linux-foundation.org \
--cc=chengkaitao@kylinos.cn \
--cc=david@kernel.org \
--cc=kaitao.cheng@linux.dev \
--cc=liam@infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=ljs@kernel.org \
--cc=mhocko@suse.com \
--cc=muchun.song@linux.dev \
--cc=rppt@kernel.org \
--cc=surenb@google.com \
--cc=vbabka@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox