Linux-mm Archive on lore.kernel.org
 help / color / mirror / Atom feed
 messages from 2026-06-29 12:24:25 to 2026-06-29 17:39:13 UTC [more...]

[PATCH v2 00/13] Dynamic Kernel Stacks
 2026-06-29 17:38 UTC  (26+ messages)
` [PATCH v2 12/13] x86: Add support for dynamic kernel stacks via FRED

[PATCH v2 0/2] mm/vmpressure: reduce CPU, memory and code overhead on cgroup v2
 2026-06-29 17:23 UTC  (12+ messages)
` [PATCH v2 1/2] mm/vmpressure: skip tree=true accounting "
` [PATCH v2 2/2] mm/vmpressure: split v1 userspace eventfd code into vmpressure-v1.c

[PATCH v2 0/3] mm: cleanup clear_not_present_full_ptes()
 2026-06-29 17:22 UTC  (5+ messages)
` [PATCH v2 1/3] sparc/mm: drop custom pte_clear_not_present_full()
` [PATCH v2 2/3] mm: drop pte_clear_not_present_full()
` [PATCH v2 3/3] mm: cleanup clear_not_present_full_ptes() and rename to clear_non_present_ptes()

[PATCH] mm/vmalloc: widen guard region to defeat ENTER-based stack pivot
 2026-06-29 17:21 UTC  (7+ messages)

[PATCH 00/30] mm: make VMA page offset handling more consistent
 2026-06-29 17:11 UTC  (40+ messages)
` [PATCH 01/30] mm: move vma_start_pgoff() into mm.h and clean up
` [PATCH 02/30] mm: add kdoc comments for vma_start/last_pgoff()
` [PATCH 03/30] tools/testing/vma: use vma_start_pgoff() in merge tests
` [PATCH 04/30] mm: introduce and use vma_end_pgoff()
` [PATCH 05/30] mm/rmap: update mm/interval_tree.c comments
` [PATCH 07/30] mm/rmap: elide unnecessary static inline's in interval_tree.c
` [PATCH 08/30] mm/rmap: rename vma_interval_tree_*() to mapping_interval_tree_*()
` [PATCH 09/30] mm/rmap: parameterise anon_vma_interval_tree_*() by anon_vma
` [PATCH 10/30] MAINTAINERS: Move mm/interval_tree.c to rmap section
` [PATCH 11/30] mm/vma: introduce and use vmg_pages(), vmg_[start, end]_pgoff()
` [PATCH 12/30] mm/vma: clean up anon_vma_compatible()
` [PATCH 13/30] mm/vma: refactor vmg_adjust_set_range() for clarity
` [PATCH 14/30] mm/vma: minor cleanup of expand_[upwards, downwards]()
` [PATCH 15/30] mm: introduce and use linear_page_delta()
` [PATCH 16/30] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
` [PATCH 17/30] mm: prefer vma_[start,end]_pgoff() to vma->vm_pgoff in kernel/
` [PATCH 18/30] mm/vma: remove duplicative vma_pgoff_offset() helper
` [PATCH 19/30] mm: use linear_page_[index, delta]() consistently
` [PATCH 20/30] mm/vma: introduce vma_assert_can_modify()
` [PATCH 21/30] mm/vma: add and use vma_[add/sub]_pgoff()
` [PATCH 22/30] mm/vma: move __install_special_mapping() to vma.c
` [PATCH 23/30] mm/vma: make vma_set_range() static, drop insert_vm_struct() decl
` [PATCH 24/30] mm/vma: update vma_shrink() to not pass unnecessary pgoff parameter
` [PATCH 25/30] mm/vma: update vmg_adjust_set_range() to offset pgoff instead
` [PATCH 26/30] mm/vma: introduce and use vma_set_pgoff()
` [PATCH 27/30] mm/vma: correct incorrect vma.h inclusion
` [PATCH 28/30] mm/vma: use guard clauses in can_vma_merge_[before, after]()
` [PATCH 29/30] tools/testing/vma: default VMA flag bits to 64-bit
` [PATCH 30/30] tools/testing/vma: output compared expression on ASSERT_[EQ, NE]()

[PATCH 0/2] mm: memory-failure: fix HWPoison flag race with non-atomic page flag ops
 2026-06-29 17:04 UTC  (9+ messages)

[PATCH] mm/damon/vaddr: remove redundant RCU lock
 2026-06-29 16:53 UTC 

[PATCH 0/4] Keep subpage private zero at free and folio split time
 2026-06-29 16:50 UTC  (13+ messages)
` [PATCH 1/4] mm/compaction: stop recording free page order in page->private
` [PATCH 2/4] mm/huge_memory: add page->private check back in __split_folio_to_order()
` [PATCH 3/4] mm/page_alloc: make sure subpage->private is zero at page free time
` [PATCH 4/4] mm/page_alloc: remove set_page_private() in prep_compound_tail()

[PATCH 0/1] liveupdate: Add internal APIs for file preservation
 2026-06-29 16:50 UTC  (6+ messages)
` [PATCH 1/1] liveupdate: luo_file: "

[PATCH 0/6] treewide: remove unnecessary invalid range checks in memblock iteration loops
 2026-06-29 16:48 UTC  (5+ messages)

[akpm-mm:mm-new 107/142] mm/zsmalloc.c:800:21: warning: 'obj_to_class_idx' defined but not used
 2026-06-29 16:47 UTC  (2+ messages)

[PATCH v3] mm: annotate data-race in cpu_needs_drain()
 2026-06-29 16:45 UTC  (5+ messages)

[PATCH v2] docs/mm: Fix braces
 2026-06-29 16:41 UTC  (2+ messages)

[PATCH v2 0/8] treewide: remove unnecessary invalid range checks in memblock iteration loops
 2026-06-29 16:37 UTC  (9+ messages)
` [PATCH v2 1/8] arm64: mm: remove unreachable invalid range check in kasan_init_shadow()
` [PATCH v2 2/8] LoongArch: remove unreachable invalid range check in kasan_init()
` [PATCH v2 3/8] riscv: remove unreachable invalid range check in create_linear_mapping_page_table()
` [PATCH v2 4/8] riscv: remove unreachable invalid range check in kasan_init()
` [PATCH v2 5/8] ARM: "
` [PATCH v2 6/8] powerpc64/kasan: Remove unreachable invalid range check in kasan_init_phys_region()
` [PATCH v2 7/8] mm: remove unnecessary empty range check in early_calculate_totalpages()
` [PATCH v2 8/8] mm/hugetlb: remove unnecessary empty range check in hugetlb_bootmem_set_nodes()

[PATCH] mm: mempolicy: fix automatic numa balancing for shmem
 2026-06-29 16:33 UTC 

[PATCH] mm: A second pagecache maintainer
 2026-06-29 16:32 UTC  (3+ messages)

[PATCH v7 00/15] userfaultfd: working set tracking for VM guest memory
 2026-06-29 16:02 UTC  (3+ messages)
` [PATCH v7 07/15] mm: preserve RWP marker across PTE rewrites

[PATCH v10 0/6] mm/memory-failure: add panic option for unrecoverable pages
 2026-06-29 15:50 UTC  (4+ messages)
` [PATCH v10 6/6] selftests/mm: add hwpoison-panic destructive test

[PATCH] mm: vmscan: remove the redundant FOLIOREF_RECLAIM_CLEAN logic
 2026-06-29 15:43 UTC  (3+ messages)

[PATCH v3 00/16] mm: Some cleanups for page allocator APIs
 2026-06-29 15:31 UTC  (21+ messages)
` [PATCH v3 01/16] mm/page_alloc: rename ALLOC_TRYLOCK -> ALLOC_NOLOCK
` [PATCH v3 02/16] mm/page_alloc: some renames to clarify alloc_flags scopes
` [PATCH v3 03/16] mm: name some args in a function declaration
` [PATCH v3 04/16] mm: Split out internal page_alloc.h
` [PATCH v3 05/16] mm/page_alloc: unify __alloc_frozen_pages[_nolock]_noprof()
` [PATCH v3 06/16] mm/page_alloc: relax GFP WARN in nolock allocs
` [PATCH v3 07/16] mm: move some stuff to mm/page_alloc.h
` [PATCH v3 08/16] perf/x86/intel: Use higher-level allocator API
` [PATCH v3 09/16] KVM: VMX: "
  ` -EXT-[PATCH "
` [PATCH v3 10/16] x86/virt: "
` [PATCH v3 11/16] sgi-xp: "
` [PATCH v3 12/16] net/funeth: Switch to "
` [PATCH v3 13/16] mm: Remove __alloc_pages_node()
` [PATCH v3 14/16] mm: Move __alloc_pages() to mm/page_alloc.h
` [PATCH v3 15/16] mm: replace __GFP_NO_CODETAG with ALLOC_NO_CODETAG
` [PATCH v3 16/16] mm: remove the __GFP_NO_OBJ_EXT flag

[PATCH 00/18] maple_tree: lock checking and clean ups
 2026-06-29 15:22 UTC  (21+ messages)
` [PATCH 01/18] maple_tree: Add rcu locking check when LOCKDEP is enabled
` [PATCH 02/18] locking/lockdep: Add sequence counter to held_lock
` [PATCH 03/18] maple_tree: Add write lock checking with lockdep sequence numbers
  ` [PATCH fixup] maple_tree: Static define mas_lockdep_map()
` [PATCH 04/18] maple_tree: Documentation fix
` [PATCH 05/18] maple_tree: Drop dead code from mas_extend_spanning_null()
` [PATCH 06/18] maple_tree: Drop MAPLE_ALLOC_SLOTS
` [PATCH 07/18] maple_tree: Clarify comments on mas_nomem()
` [PATCH 08/18] maple_tree: Use prefetched value in mas_wr_store_type()
` [PATCH 09/18] maple_tree: Optimise mas_wr_node_store() when not in rcu mode
` [PATCH 10/18] maple_tree: micro optimisation of mas_wr_store_type()
` [PATCH 11/18] maple_tree: Add bulk parent set helper
  ` [PATCH fixup] maple_tree: Fix dereference of rcu type
` [PATCH 12/18] maple_tree: Catch race in mas_alloc_cyclic()
` [PATCH 13/18] maple_tree: Document that erase may use GFP_KERNEL for allocations
` [PATCH 14/18] maple_tree: WARN_ON_ONCE when allocations fail
` [PATCH 15/18] maple_tree: Document erase and allocations better
` [PATCH 16/18] maple_tree: Change two GFP flags in tests
` [PATCH 17/18] maple_tree: Fix argument name in header
` [PATCH 18/18] maple_tree: Avoid extra gap calculation

[PATCH v2 0/9] kmem_cache instances with static storage duration
 2026-06-29 15:20 UTC  (5+ messages)
` [RFC PATCH v3 00/10] "

[RFC PATCH 00/10] mm/rmap: index MAP_PRIVATE file-backed folios by virt pgoff
 2026-06-29 15:03 UTC  (11+ messages)
` [RFC PATCH 01/10] mm/vma: introduce VMA virtual page offset field and add helpers
` [RFC PATCH 02/10] mm: introduce linear_virt_page_index()
` [RFC PATCH 03/10] mm: abstract vma_address() and introduce vma_anon_address()
` [RFC PATCH 04/10] mm: update print_bad_page_map() to show virtual page index
` [RFC PATCH 05/10] mm: introduce and use vma_filebacked_address()
` [RFC PATCH 06/10] mm: propagate VMA virtual page offset on map, remap, split + merge
` [RFC PATCH 07/10] mm/rmap: track whether the page VMA mapped walk is anonymous
` [RFC PATCH 08/10] mm: introduce and use linear_folio_page_index()
` [RFC PATCH 09/10] mm/rmap: use virt pgoff for MAP_PRIVATE file-backed anon folios
` [RFC PATCH 10/10] tools/testing/vma: expand VMA merge tests to assert virt pgoff

[PATCH v3 0/2] mm/damon/core: detect internal variation above max_nr_regions/2
 2026-06-29 14:56 UTC  (3+ messages)
` [PATCH v3 1/2] mm/damon/core: split a fraction of regions when nr_regions exceeds max/2
` [PATCH v3 2/2] mm/damon/tests/core-kunit: test split above max_nr_regions/2

[PATCH 0/5] mm/damon: five misc fixups
 2026-06-29 14:55 UTC  (6+ messages)
` [PATCH 1/5] mm/damon/core: use kvmalloc for target regions array
` [PATCH 2/5] mm/damon/stat: use secs_to_jiffies() instead of msecs_to_jiffies()
` [PATCH 3/5] Docs/{admin-guide,mm}/damon: fix DAMON documentation details
` [PATCH 4/5] samples/damon: Fix typos in Kconfig help text
` [PATCH 5/5] mm/damon/tests/core-kunit: add KUnit test for walk_control_obsolete behavior

[PATCH v2 0/2] selftests/damon: test kdamond refresh_ms
 2026-06-29 14:49 UTC  (3+ messages)
` [PATCH v2 1/2] selftests/damon/_damon_sysfs: support "
` [PATCH v2 2/2] selftests/damon/sysfs_refresh: test "

[PATCH v5 0/2] selftests/damon: fix memcg_path staging handling
 2026-06-29 14:48 UTC  (3+ messages)
` [PATCH v5 1/2] selftests/damon/_damon_sysfs.py: fix memcg_path assignment
` [PATCH v5 2/2] selftests/damon/sysfs.py: validate memcg_path staging readback

[PATCH v3 0/3] selftests/damon: misc fixes for test bugs
 2026-06-29 14:46 UTC  (4+ messages)
` [PATCH v3 1/3] selftests/damon: prevent cross-context state pollution in DamonCtx
` [PATCH v3 2/3] selftests/damon/damos_tried_regions: fix expectation output and join TypeError
` [PATCH v3 3/3] selftests/damon: fix dead code, skipped checks, and broken lookups

[PATCH v3] samples/damon/mtier: fail early if address range parameters are invalid
 2026-06-29 14:44 UTC 

[PATCH v10 3/3] ksm: add mremap selftests for ksm_rmap_walk
 2026-06-29 14:43 UTC  (2+ messages)

[RFC PATCH 00/40] mm: reliable 1GB page allocation
 2026-06-29 14:39 UTC  (6+ messages)

[PATCH v6] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
 2026-06-29 14:37 UTC  (2+ messages)

[PATCH] tmpfs: zero unused folio tail for long symlinks
 2026-06-29 13:57 UTC  (3+ messages)

[PATCH v2 9/9] mm: zswap: per-node kmem accounting for zswap/zsmalloc
 2026-06-29 13:38 UTC  (5+ messages)

[PATCH 0/6] samples/damon: handle damon_{start,stop}() failures
 2026-06-29 13:26 UTC  (2+ messages)

[PATCH] MAINTAINERS: s/SeongJae/SJ/
 2026-06-29 13:24 UTC  (2+ messages)

[PATCH] MAINTAINERS: s/SeongJae/SJ/
 2026-06-29 13:23 UTC  (2+ messages)

[PATCH v16 00/18] arm64: entry: Convert to Generic Entry
 2026-06-29 13:06 UTC  (19+ messages)
` [PATCH v16 01/18] seccomp: Convert __secure_computing() to return boolean
` [PATCH v16 02/18] syscall_user_dispatch: Introduce a weak fallback for arch_syscall_is_vdso_sigreturn()
` [PATCH v16 03/18] arm64: ptrace: Pass thread flags to syscall_trace_enter/exit()
` [PATCH v16 04/18] arm64: ptrace: Use syscall_get_nr() helper for syscall_trace_enter()
` [PATCH v16 05/18] arm64: ptrace: Expand secure_computing() in place
` [PATCH v16 06/18] arm64: ptrace: Use syscall_get_arguments() helper for audit
` [PATCH v16 07/18] arm64: ptrace: Protect rseq_syscall() from tracer PC modifications
` [PATCH v16 08/18] arm64: ptrace: Rename syscall_trace_exit() to syscall_exit_work()
` [PATCH v16 09/18] arm64: syscall: Rework the syscall exit path in el0_svc_common()
` [PATCH v16 10/18] arm64: ptrace: Extract syscall_exit_to_user_mode_work() helper
` [PATCH v16 11/18] arm64: ptrace: Align syscall exit work semantics with generic entry
` [PATCH v16 12/18] arm64: syscall: Use exit-specific flags check in el0_svc_common()
` [PATCH v16 13/18] arm64: syscall: Simplify el0_svc_common() syscall exit path
` [PATCH v16 14/18] arm64: syscall: Simplify syscall exit path in el0_svc_common()
` [PATCH v16 15/18] arm64: ptrace: Skip syscall exit reporting for PTRACE_SYSEMU_SINGLESTEP
` [PATCH v16 16/18] arm64: entry: Convert to generic entry
` [PATCH v16 17/18] arm64: Inline el0_svc_common()
` [PATCH v16 18/18] arm64: vdso: Expose sigreturn address on vdso to the kernel

[PATCH 1/2] mm/vmpressure: skip tree=true accounting on cgroup v2
 2026-06-29 12:35 UTC  (2+ messages)

[PATCH v4 00/12] Optimize anonymous large folio unmapping
 2026-06-29 12:30 UTC  (5+ messages)
` [PATCH v4 03/12] mm/rmap: refactor some code around lazyfree "


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox