Linux-mm Archive on lore.kernel.org
 help / color / mirror / Atom feed
 messages from 2026-07-31 09:41:46 to 2026-08-01 11:49:42 UTC [more...]

[PATCH v2 0/3] mm/vmalloc: stop truncating byte counts derived from nr_pages
 2026-08-01 11:49 UTC  (2+ messages)
` [PATCH v4] mm/vmalloc: make vm_struct.nr_pages an unsigned long

[PATCH v4 0/5] tracing: add ref_trace_final_put tracing
 2026-08-01 10:59 UTC  (6+ messages)
` [PATCH v4 1/5] tracing: add ref_trace_final_put tracepoint
` [PATCH v4 2/5] refcount: "
` [PATCH v4 3/5] percpu-refcount: add ref_trace_final_put trace
` [PATCH v4 4/5] kunit: add test for ref_trace_final_put
` [PATCH v4 5/5] MAINTAINERS: add entries "

[PATCH] mm/sparse: correct init section annotations
 2026-08-01 10:17 UTC  (4+ messages)

[PATCH RFC] mm/gup: batch contiguous pages in follow_page_mask() and return them via a pages array
 2026-08-01  9:54 UTC  (4+ messages)

[PATCH v2 0/2] Honor XA_FLAGS_ACCOUNT in xas_split_alloc() and charge to folio's memcg
 2026-08-01  9:38 UTC  (7+ messages)
` [PATCH v2 1/2] mm/huge_memory: use folio's memcg inside __folio_split()
` [PATCH v2 2/2] xarray: honor XA_FLAGS_ACCOUNT in xas_split_alloc()

[PATCH v4] mm/page_reporting: Add page_reporting_delay_ms module parameter
 2026-08-01  9:25 UTC  (5+ messages)

[PATCH v6 00/22] kho: make boot time huge page allocation work nicely with KHO
 2026-08-01  8:48 UTC  (23+ messages)
` [PATCH v6 01/22] kho: generalize radix tree APIs
` [PATCH v6 02/22] kho: make radix max key width more obvious
` [PATCH v6 03/22] kho: disallow wide keys in radix tree
` [PATCH v6 04/22] kho: return virtual address of mem_map from kho_get_mem_map()
` [PATCH v6 05/22] kho: store incoming radix tree in kho_in
` [PATCH v6 06/22] kho: move all memory retrieval logic to kho_mem_retrieve()
` [PATCH v6 07/22] kho: add a struct for radix callbacks
` [PATCH v6 08/22] kho: add callback for table pages
` [PATCH v6 09/22] kho: add data argument to radix walk callback
` [PATCH v6 10/22] kho: allow early-boot usage of the KHO radix tree
` [PATCH v6 11/22] kho: allow destroying "
` [PATCH v6 12/22] kho: add kho_radix_init_tree()
` [PATCH v6 13/22] kho: expose kho_scratch_overlap() to kexec_handover.h
` [PATCH v6 14/22] kho: initialize kho_scratch pointer earlier in boot
` [PATCH v6 15/22] kho: initialize preserved memory map radix tree earlier
` [PATCH v6 16/22] mm/mm_init: simplify deferred_free_pages() migratetype init
` [PATCH v6 17/22] mm/mm_init: don't rely on memblock to get KHO scratch migratetype
` [PATCH v6 18/22] kho: extend scratch
` [PATCH v6 19/22] memblock: always include KHO headers
` [PATCH v6 20/22] memblock: make HugeTLB bootmem allocation work with KHO
` [PATCH v6 21/22] memblock: add memblock_reserved_hugetlb_size()
` [PATCH v6 22/22] kho: exclude hugetlb memory from scratch size calculation

[PATCH] mm/page_alloc: only update lowmem_reserve_ratio on sysctl write
 2026-08-01  7:36 UTC  (3+ messages)
` [PATCH v2] "

[PATCH v1 0/2] mm: split underused anonymous mTHP folios
 2026-08-01  7:33 UTC  (11+ messages)
` [PATCH v1 2/2] mm/memory: add anonymous mTHP folios to deferred split list

[PATCH v2 0/4] add anon mTHP collapse test cases
 2026-08-01  6:26 UTC  (5+ messages)
` [PATCH v2 1/4] selftests: mm: extend the check_huge() to support mTHP check
` [PATCH v2 2/4] selftests: mm: move gather_after_split_folio_orders() into vm_util.c file
` [PATCH v2 3/4] selftests: mm: implement the mTHP-sized hugepage check helpers
` [PATCH v2 4/4] selftests: mm: add mTHP collapse test cases

[RFC PATCH v3 0/6] mm: mglru: fix swappiness behavior
 2026-08-01  6:18 UTC  (5+ messages)
` [RFC PATCH v3 2/6] mm: mglru: let scan_folios() scan both reclaimable generations
` [RFC PATCH v3 4/6] mm: mglru: improve scan_folios() exhaustion detection

[PATCH 0/4] add anon mTHP collapse test cases
 2026-08-01  5:37 UTC  (5+ messages)
` [PATCH 3/4] selftests: mm: implement the mTHP-sized hugepage check helpers
` [PATCH 4/4] selftests: mm: add mTHP collapse test cases

[PATCH] selftests/cgroup: test_zswap: skip test_no_kmem_bypass if debugfs is unavailable
 2026-08-01  4:12 UTC 

[akpm-mm:mm-new] BUILD SUCCESS WITH UNVERIFIED WARNING 9e25ce807d1c5df0fb7ec68cc9eb4253ac4bd055
 2026-08-01  3:59 UTC 

[PATCH v2 0/2] Fix and optimize LoongArch module loading
 2026-08-01  3:29 UTC  (5+ messages)
` [PATCH v2 2/2] LoongArch: Skip address pairing for non-exec sections

[PATCH 0/5] mm/gup: batch contiguous pages in follow_page_mask()
 2026-08-01  3:15 UTC  (6+ messages)
` [PATCH 1/5] mm/gup: convert follow_page_mask() to return a long
` [PATCH 2/5] mm/gup: split follow_page_pte_commit() out of follow_page_pte()
` [PATCH 3/5] mm/gup: add gup_fill_pages() and use it
` [PATCH 4/5] mm/gup: return a huge page's full count from follow_page_mask()
` [PATCH 5/5] mm/gup: walk multiple PTEs per follow_page_pte() call

[PATCH RFC 00/14] Remove PG_private by using page/folio->private checks instead
 2026-08-01  2:13 UTC  (15+ messages)
` [PATCH RFC 01/14] mm/zsmalloc: replace PG_private with pointer comparison
` [PATCH RFC 02/14] perf/ring_buffer: stop using PG_private as AUX page high-order marker
` [PATCH RFC 03/14] xen/grant-table: stop setting PG_private on pages for grant mapping
` [PATCH RFC 04/14] fs/crypto: stop setting PG_private on bounce page
` [PATCH RFC 05/14] mm/hugetlb: use direct assignment instead of folio_change_private()
` [PATCH RFC 06/14] fs/f2fs: stop using PG_private
` [PATCH RFC 07/14] fs/erofs: mm/pagemap: add readahead_folio_reverse() to avoid folio->private
` [PATCH RFC 08/14] fs/erofs: use folio_attach/detach_private() instead of direct assignment
` [PATCH RFC 09/14] mm/page-flags: check page/folio->private instead of PG_private
` [PATCH RFC 10/14] mm/page-flags: introduce folio_test_fs_private()
` [PATCH RFC 11/14] treewide: remove folio_set/clear_private()
` [PATCH RFC 12/14] treewide: replace PagePrivate() with page_private()
` [PATCH RFC 13/14] treewide: adjust comments on PagePrivate and PG_private
` [PATCH RFC 14/14] mm/page-flags: remove PG_private

[PATCH v2] tools/mm: add thp_swap_allocator_test to .gitignore
 2026-08-01  1:05 UTC  (2+ messages)

[PATCH v6 0/2] mm/memory_hotplug: optimize zone contiguous check when changing pfn range
 2026-08-01  0:59 UTC  (7+ messages)
` [PATCH v6 2/2] mm/memory_hotplug: improve shrink_zone_span() subsection boundary checks

[PATCH] tools/mm: add hwpoison-panic tool
 2026-08-01  0:58 UTC  (2+ messages)

[PATCH] mm/swap: reject swapon() on filesystem-level encrypted files
 2026-08-01  0:46 UTC  (4+ messages)

[syzbot] [mm?] WARNING in alloc_vmap_area
 2026-08-01  0:36 UTC 

[PATCH v3 1/2] mm/zswap: Fix global shrinker when memory cgroup is disabled
 2026-08-01  0:31 UTC  (4+ messages)
` [PATCH v3 2/2] mm/zswap: Support batch writeback in shrink_memcg()

[syzbot] [mm?] WARNING in va_alloc
 2026-08-01  0:24 UTC 

[PATCH v3] mm/page_reporting: use system_freezable_wq to fix UAF during suspend
 2026-08-01  0:16 UTC  (6+ messages)

[PATCH] mm: zswap: drop list_lru param from zswap_lru_add() and _del()
 2026-08-01  0:07 UTC  (4+ messages)

[syzbot] [mm?] [kasan?] INFO: rcu detected stall in filemap_read
 2026-08-01  0:01 UTC 

[PATCH v3 00/26] mm: Add ALLOC_UNMAPPED and AS_NO_DIRECT_MAP
 2026-07-31 23:59 UTC  (17+ messages)
` [PATCH v3 01/26] set_memory: add folio_{zap,restore}_direct_map helpers
` [PATCH v3 03/26] mm: introduce AS_NO_DIRECT_MAP
` [PATCH v3 04/26] x86/mm: split out preallocate_sub_pgd()
` [PATCH v3 05/26] x86: move PAE PMD preallocation defines to header
` [PATCH v3 15/26] mm/page_alloc: add support for freetypes with no freelist
` [PATCH v3 19/26] mm/page_alloc: rename ALLOC_NON_BLOCK back to _HARDER

[PATCH v7 0/5] block: enable RWF_DONTCACHE for block devices
 2026-07-31 23:55 UTC  (4+ messages)
` [PATCH v7 5/5] "

[RFC PATCH 0/2] Add support for multiple versions to KHO
 2026-07-31 21:56 UTC  (6+ messages)
` [RFC PATCH 1/4] kho: Move subtree blob logic to separate function
` [RFC PATCH 2/4] kho: Add support for multiple versions in subtrees
` [RFC PATCH 3/4] kho: Add support for multiple versions to debugfs
` [RFC PATCH 4/4] kho: Add test cases for versioned subtrees

[PATCH RFC v2 0/3] Demote to lower tier using non-temporal stores
 2026-07-31 21:53 UTC  (3+ messages)
` [PATCH RFC v2 1/3] mm, x86: support copying a folio "

[PATCH v2] alloc_tag: expose profiling and compression states in /proc/allocinfo
 2026-07-31 21:48 UTC  (7+ messages)

[PATCH v11 0/8] mm/hmm: Add mmap lock-drop support for userfaultfd-backed mappings
 2026-07-31 21:37 UTC  (4+ messages)

[PATCH v9 00/41] guest_memfd: In-place conversion support
 2026-07-31 21:04 UTC  (20+ messages)
` [PATCH v9 01/41] KVM: guest_memfd: Introduce per-gmem attributes, use to guard user mappings
` [PATCH v9 07/41] KVM: guest_memfd: Wire up core private/shared attribute interfaces
` [PATCH v9 14/41] mm: swap: Introduce lru_add_drain_progressive()
` [PATCH v9 18/41] KVM: TDX: Make source page optional for KVM_TDX_INIT_MEM_REGION

[PATCH v3 1/1] mm: shmem: reject page-aligned fallocate end overflow
 2026-07-31 20:31 UTC  (2+ messages)

[PATCH] mm/gup: fix always draining LRU caches in collect_longterm_unpinnable_folios()
 2026-07-31 20:27 UTC 

[PATCH v8 00/15] Use generic_file_read_iter() in hugetlbfs
 2026-07-31 20:08 UTC  (16+ messages)
` [PATCH v8 01/15] memory-failure: Fix hardware poison check in unpoison_memory() again
` [PATCH v8 02/15] memory-failure: Prevent hugetlb freeing during unpoisoning
` [PATCH v8 03/15] mm: Rename folio_contain_hwpoison_page() to folio_has_hwpoison_page()
` [PATCH v8 04/15] hugetlb: Mark some function arguments as const
` [PATCH v8 05/15] guest_memfd: Use folio_has_hwpoisoned_page()
` [PATCH v8 06/15] kpageflags: Use is_page_hwpoison() to set KPF_HWPOISON
` [PATCH v8 07/15] hugetlb: Move poison to pages before clearing hugetlb page type
` [PATCH v8 08/15] hugetlb: Use the has_hwpoisoned flag
` [PATCH v8 09/15] mm: Remove locking mf_mutex in is_raw_hwpoison_page_in_hugepage()
` [PATCH v8 10/15] mm: Check individual hugetlb pages for poison
` [PATCH v8 11/15] filemap: Add hwpoison handling to filemap_read()
` [PATCH v8 12/15] filemap: Remove checks in mapping_set_folio_order_range()
` [PATCH v8 13/15] hugetlb: Set mapping folio order
` [PATCH v8 14/15] filemap: Add support for authoritative mappings
` [PATCH v8 15/15] hugetlb: replace hugetlbfs_read_iter() with generic_file_read_iter()

[PATCH v7 00/13] Use generic_file_read_iter() in hugetlbfs
 2026-07-31 20:00 UTC  (9+ messages)
` [PATCH v7 01/13] memory-failure: Fix hardware poison check in unpoison_memory() again

[PATCH v1 0/5] x86/cpu: Refactor identify_cpu()
 2026-07-31 19:13 UTC  (4+ messages)
` [PATCH v1 5/5] x86/cpu: Don't reset boot CPU cpuinfo in identify_cpu()

[akpm-mm:mm-new] BUILD SUCCESS WITH UNVERIFIED WARNING 0c39e2f552f5e16be695cec3a1c77d6a6bf086bb
 2026-07-31 18:40 UTC  (3+ messages)

[GIT PULL] additional hotfixes for 7.2-rc6
 2026-07-31 18:38 UTC  (2+ messages)

[PATCH v3] mm/khugepaged: replace mutex_lock/mutex_unlock usage with guard macro
 2026-07-31 18:38 UTC  (4+ messages)

[PATCH] mm/kmemleak: report RCU-tasks quiescent states during the scan
 2026-07-31 18:19 UTC  (12+ messages)

[PATCH v2] kexec: keep the next kernel off hardware-poisoned pages
 2026-07-31 18:11 UTC  (3+ messages)

[PATCH RFT 0/3] mm, drm: ensure .fault() does not have to be followed by .pfn_mkwrite() for write faults
 2026-07-31 16:43 UTC  (3+ messages)
` [PATCH RFT 2/3] drm/shmem_helper: use vmf_insert_pfn_mkwrite()
` [PATCH RFT 3/3] drm/ttm, drm/vmwgfx: directly create writable PTEs when mkwrite is in use

[PATCH v2 0/5] mm: Unconditional per-VMA locks and cleanups
 2026-07-31 16:40 UTC  (4+ messages)
` [PATCH v2 3/5] mm: Add RCU-based VMA lookup helper that waits for writers

[RFC PATCH 00/16] Page Alloc Hogger
 2026-07-31 17:52 UTC  (9+ messages)

[PATCH 0/4] CRASH_ZEROIZE: Wipe secrets before kdump
 2026-07-31 16:27 UTC  (5+ messages)
` [PATCH 1/4] of/kexec: fix typo in comment (usable-memory-range)
` [PATCH 2/4] kexec: add CRASH_ZEROIZE to wipe secrets before kdump
` [PATCH 3/4] mm/secretmem: zeroize secret pages "
` [PATCH 4/4] security/keys: zeroize key payloads "

[PATCH v8 0/8] mm: Hot page tracking and promotion infrastructure
 2026-07-31 16:27 UTC  (5+ messages)
` [PATCH v8 3/8] mm: Hot page tracking and promotion - pghot
` [PATCH v8 4/8] mm: pghot: Precision mode for pghot

[RFC PATCH 9/9] arm64/debug: Mark debug exception helpers __always_inline
 2026-07-31 16:15 UTC  (2+ messages)

[PATCH] coredump: add filesz truncation and filter
 2026-07-31 17:13 UTC 

[PATCH v3] hugetlb: only adjust reservation during unmapping if mapcount is 0
 2026-07-31 17:22 UTC  (3+ messages)

[syzbot] [mm?] WARNING in mas_nomem
 2026-07-31 16:07 UTC  (3+ messages)

[PATCH] mm: pull writability check to follow_pfnmap_start()
 2026-07-31 16:05 UTC 

KMSAN: use-after-free in sw842_decompress (zswap writeback)
 2026-07-31 15:50 UTC  (2+ messages)

[PATCH] params: fix charp corruption on allocation failure
 2026-07-31 14:21 UTC  (3+ messages)
` [PATCH v2] "

[rppt-memblock:misc] BUILD SUCCESS 78fac571b06490654af45c902c7ab5f651fe7067
 2026-07-31 14:08 UTC 

[rppt-memblock:for-next] BUILD SUCCESS 9dd84d7c630b7c8688bc0e7e42c0e2d634f46830
 2026-07-31 14:07 UTC 

[PATCH v3 00/13] mm/slab, alloc_tag: reduce obj_ext memory waste
 2026-07-31 13:52 UTC  (7+ messages)
` [PATCH v3 01/13] mm/slab: skip kfence objects in allocation profiling
` [PATCH v3 08/13] mm/slab: change struct slabobj_ext to a union

[PATCH RFC 00/11] mm: distinguish PTE table storage from PTE values
 2026-07-31 13:28 UTC  (5+ messages)
` [PATCH RFC 01/11] mm: introduce hw_pte_t for PTE table storage

[PATCH v10 6/6] selftests/mm: add hwpoison-panic destructive test
 2026-07-31 13:19 UTC  (11+ messages)

[PATCH v2 1/2] mm: Use a folio in the softleaf_is_device_private path
 2026-07-31 13:06 UTC  (3+ messages)

[PATCH v2 0/3] mm: kmemleak: default min_unref_scans to 2 for verbose kernels
 2026-07-31 10:13 UTC  (4+ messages)
` [PATCH v2 1/3] mm: kmemleak: default min_unref_scans to 2 for verbose auto-scan
` [PATCH v2 2/3] Documentation: kmemleak: document the conditional min_unref_scans default
` [PATCH v2 3/3] selftests/mm: kmemleak: drop stale min_unref_scans default from comments


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox