Linux-mm Archive on lore.kernel.org
 help / color / mirror / Atom feed
 messages from 2026-09-10 10:21:08 to 2026-09-10 17:16:45 UTC [more...]

[RFC PATCH v2 0/9] mm/damon: hardware-sampled access reports
 2026-09-10 17:16 UTC  (4+ messages)
` [RFC PATCH v2 1/9] mm/damon/vaddr: support page fault access check primitive
` [RFC PATCH v2 2/9] mm/damon/core: read the CPU number with preemption disabled
` [RFC PATCH v2 3/9] mm/damon/paddr: lock the folio for the page fault primitive rmap walk

[RFC PATCH 0/3] liveupdate: Move to feature flags for LUO and memfd ABI compatibility
 2026-09-10 17:12 UTC  (8+ messages)

Path forward for Virtualized Swap?
 2026-09-10 17:03 UTC  (8+ messages)

[PATCH v2 0/5] read proc/pid/smaps_rollup under per-vma lock
 2026-09-10 17:02 UTC  (20+ messages)
` [PATCH v2 1/5] proc/task_mmu: remove unnecessary helpers
` [PATCH v2 2/5] proc/task_mmu: remove unnecessary inlines in function definitions
` [PATCH v2 3/5] proc/task_mmu: remove special-casing of smap_gather_stats() start parameter

[PATCH v6 0/6] sched: Add support for long task name
 2026-09-10 16:49 UTC  (7+ messages)
` [PATCH v6 1/6] treewide: Get rid of get_task_comm()
` [PATCH v6 2/6] treewide: Replace memcpy(..., current->comm) with copy_task_comm()
` [PATCH v6 3/6] lib/string_kunit: Add test for copy_task_comm()
` [PATCH v6 4/6] sched: Extend task command name with TASK_COMM_EXT_LEN
` [PATCH v6 5/6] prctl: Add support for long user thread names
` [PATCH v6 6/6] selftests: prctl: Add test for long "

[PATCH v2 00/26] mm/fbatch: drain lru_add_drain() and _all()
 2026-09-10 16:42 UTC  (4+ messages)
` [PATCH v2 07/26] mm/fbatch: LRU_NEXT_ACTIVATE bit to optimize folio_activate()

[PATCH v2] mm/truncate: fix data loss when truncating straddling large folios
 2026-09-10 16:26 UTC  (2+ messages)

[PATCH 00/39] mm: make VMA flag semantics explicit, eliminate VM_SPECIAL
 2026-09-10 16:15 UTC  (3+ messages)
` [PATCH 12/39] ALSA: pcm: use vm_insert_page() to map PCM status page

[PATCH v4 05/11] KVM: LUO: Support VM preservation across live updates
 2026-09-10 16:03 UTC  (11+ messages)

[akpm-mm:mm-new 358/388] mm/sparse-vmemmap.c:507:48: error: passing argument 2 of 'vmemmap_shared_tail_page' makes pointer from integer without a cast
 2026-09-10 15:42 UTC 

[akpm-mm:mm-new 360/388] arch/powerpc/mm/book3s64/radix_pgtable.c:1274:53: error: implicit declaration of function 'device_zone'; did you mean 'device_move'?
 2026-09-10 15:42 UTC 

[PATCH v8 0/2] mm/memory_hotplug: optimize zone contiguous check when changing pfn range
 2026-09-10 15:39 UTC  (5+ messages)
` [PATCH v8 2/2] "

[PATCH v3 0/2] mm/memory: improve insert_pages() error handling
 2026-09-10 15:33 UTC  (3+ messages)
` [PATCH v3 1/2] mm/memory: simplify error handling in insert_pages()

[PATCH RFC v3 00/21] mm: change behavior of pXdp_get()/pXd_page() in compile-time folded pgtable
 2026-09-10 15:29 UTC  (13+ messages)
` [PATCH RFC v3 12/21] mm/pgtable: redefine PGTABLE_LEVEL enum with ascend order from PGD
` [PATCH RFC v3 13/21] x86: mm: use pgtable_level enum in effective_prot_pXd()
` [PATCH RFC v3 14/21] x86: mm: carve out the generic compile-time folded pgtable case in effective_prot()
` [PATCH RFC v3 15/21] x86: mm: skip collapse_pud_page() when CONFIG_X86_DIRECT_GBPAGES disabled

[akpm-mm:mm-new 358/388] mm/sparse-vmemmap.c:507:48: error: implicit declaration of function 'device_zone'; did you mean 'device_move'?
 2026-09-10 15:22 UTC  (3+ messages)

[rppt-memblock:fixes] BUILD SUCCESS 6e33dc90df108c76899dc544a42d17adcba61668
 2026-09-10 15:05 UTC 

[PATCH v7 0/5] mm: Unconditional per-VMA locks and cleanups
 2026-09-10 15:20 UTC  (5+ messages)
` [PATCH v7 1/5] mm: Make per-VMA locks available universally

[PATCH v2 0/5] of: reserved_mem: several fixes about reserved memory
 2026-09-10 15:20 UTC  (7+ messages)
  ` [PATCH v2 1/5] of: reserved_mem: skip init for regions whose early reservation failed

[PATCH 00/12] mm/sparse: remove SECTION_MARKED_PRESENT and further cleanups
 2026-09-10 15:15 UTC  (42+ messages)
` [PATCH 01/12] mm/sparse: move mem_section init to sparse_extreme_init()
` [PATCH 02/12] mm/sparse: refactor sparse_sections_init()
` [PATCH 03/12] mm/sparse: move initialization of section metadata to sparse_metadata_init()
` [PATCH 04/12] mm/sparse: rename and cleanup sparse_init_nid()
` [PATCH 05/12] mm/sparse: cleanup sparse_init_one_section()
` [PATCH 06/12] mm/sparse: rename __highest_present_section_nr to __highest_used_section_nr
` [PATCH 07/12] mm/sparse: remove pfn_in_present_section()
` [PATCH 08/12] mm/sparse: move __highest_used_section_nr handling
` [PATCH 09/12] mm/sparse: remove SECTION_MARKED_PRESENT
` [PATCH 10/12] mm/sparse: remove flags parameter from sparse_init_one_section()
` [PATCH 11/12] fs/proc/page: clarify comment in get_max_dump_pfn()
` [PATCH 12/12] mm/memory_hotplug: drop CONFIG_HAVE_ARCH_PFN_VALID handling from pfn_to_online_page()

[RFC PATCH 2/5] mm: add a_ops->dirty_folio_range() and use the mkclean dirty harvest
 2026-09-10 14:54 UTC  (3+ messages)

[PATCH 0/5] KVM: guest_memfd: bind backing memory to a NUMA node
 2026-09-10 14:46 UTC  (10+ messages)

[PATCH 0/7] mm/damon: introduce probe_hits_wsum DAMOS core filter
 2026-09-10 14:40 UTC  (9+ messages)
` [PATCH 1/7] mm/damon/api: introduce DAMOS_FILTER_TYPE_PROBE_HITS_WSUM
` [PATCH 2/7] mm/damon/core: extend probe_hits_wsum() for moving sum based calculation
` [PATCH 3/7] mm/damon/core: support probe_hits_wsum damos core filter
` [PATCH 4/7] mm/damon/sysfs-schemes: rename sysfs_filter->sz_range to range_{min,max}
` [PATCH 5/7] mm/damon/sysfs-schemes: support probe_hits_wsum damos core filter
` [PATCH 6/7] Docs/mm/damon/design: update for probe_hits_wsum DAMOS "
` [PATCH 7/7] Docs/admin-guide/mm/damon/usage: update for probe_hits_wsum DAMOS filter

[PATCH] memblock: use for_each_zone() in reset_all_zones_managed_pages()
 2026-09-10 14:35 UTC  (5+ messages)

[PATCH v2] mm/damon/core: reset invalid quota->charge_target_from
 2026-09-10 14:28 UTC 

[PATCH 0/5] mm/damon: introduce pgidle_set probe filter type
 2026-09-10 14:22 UTC  (6+ messages)
` [PATCH 1/5] mm/damon/api: introduce DAMON_FILTER_TYPE_PGIDLE_SET
` [PATCH 2/5] mm/damon/paddr: support DAMON_FILTER_TYPE_PGIDLE_SET
` [PATCH 3/5] mm/damon/vaddr: "
` [PATCH 4/5] mm/damon/sysfs: "
` [PATCH 5/5] Docs/mm/damon/design: update for pgidle_set probe filter

Arrêter l'activité de ROLLIN JEAN PIERRE sans tribunal ni contrôle fiscal
 2026-09-10 14:18 UTC 

[PATCH v3 00/14] Remove PG_private by using page/folio->private checks instead
 2026-09-10 14:15 UTC  (13+ messages)
` [PATCH v3 06/14] f2fs: stop using PG_private

[PATCH] Docs/mm/damon/design: clarify when qt_exceeds increases
 2026-09-10 14:10 UTC  (2+ messages)

[PATCH v3 0/3] mm: zswap: optimize zswap invalidate and store
 2026-09-10 14:09 UTC  (7+ messages)
` [PATCH v3 1/3] mm: zswap: convert zswap_invalidate() to take a range
` [PATCH v3 2/3] mm: zswap: skip xarray walk in zswap_invalidate() when zswap is unused
` [PATCH v3 3/3] mm: zswap: reuse zswap_invalidate() in zswap_store()

[PATCH v2] mm: implement and use vma_anon_tracked(), silence KCSAN
 2026-09-10 14:02 UTC  (3+ messages)

[PATCH v5 0/3] kselftest: mm: fix some failure of split_huge_page_test
 2026-09-10 13:52 UTC  (28+ messages)
` [PATCH v5 2/3] kselftest: mm: replace usage of /proc/self/smaps for check_huge_xxx() helper
` [PATCH v5 3/3] kselftest: mm: introduce alloc_isolated_mem()
                        ` ;, Re: ;, [PATCH v5 3/3] kselftest: ;, mm: introducealloc_isolated_mem;

[RFC PATCH 1/5] mm: let folio_mkclean() report which pages had dirty PTEs
 2026-09-10 13:36 UTC  (3+ messages)

[PATCH v4 0/5] mm/memory-failure: keep hardware-poisoned pages out of the next kexec
 2026-09-10 13:11 UTC  (4+ messages)
` [PATCH v4 2/5] mm/memory-failure: libstub: install the poisoned-memory EFI table

[PATCH v5 00/19] selftests/mm: improve khugepaged coverage
 2026-09-10 13:04 UTC  (18+ messages)
` [PATCH v5 06/19] selftests/mm: stop khugepaged during the MADV_COLLAPSE cases
` [PATCH v5 08/19] selftests/mm: add folio-order check for address ranges
` [PATCH v5 11/19] selftests/mm: add order-parameterized khugepaged collapse cases
` [PATCH v5 12/19] selftests/mm: parameterize the mixed-source collapse case by source order

[PATCH v3 RESEND 0/2] selftests/mm: Validate selections and scope memfd_secret setup
 2026-09-10 12:56 UTC  (3+ messages)
` [PATCH v3 RESEND 1/2] selftests/mm: Reject invalid test selections before running tests
` [PATCH v3 RESEND 2/2] selftests/mm: Only prepare ptrace_scope when memfd_secret is selected

[PATCH v2 0/4] mm/slub: preserve previous object lifetime
 2026-09-10 12:36 UTC  (3+ messages)
` [PATCH v2 1/4] mm/slub: use a track count for user metadata sizing

[PATCH v21 0/6] Hierarchical Percpu Counters for RSS
 2026-09-10 12:24 UTC  (3+ messages)
` [PATCH v21 1/6] lib: introduce hierarchical per-cpu counters

[patch 0/3] lib: add synthetic MM benchmarks
 2026-09-10 12:12 UTC  (5+ messages)

[PATCH v4] selftests/mm: hugetlb_madv_vs_map: add underflow test
 2026-09-10 12:04 UTC  (2+ messages)

[PATCH v2 00/12] mm/collapse: separate a collapse from its callers
 2026-09-10 12:02 UTC  (13+ messages)
` [PATCH v2 01/12] mm/khugepaged: drop redundant mm_struct pin in madvise_collapse()
` [PATCH v2 02/12] mm/khugepaged: count collapses where khugepaged makes them
` [PATCH v2 03/12] mm/khugepaged: rename mthp_present_ptes bitmap to eligible_ptes
` [PATCH v2 04/12] mm/collapse: add collapse.h for the collapse interface
` [PATCH v2 05/12] mm/collapse: state what a collapse may do in the policy
` [PATCH v2 06/12] mm/collapse: drop the collapse_possible() wrapper
` [PATCH v2 07/12] mm/collapse: name the per-table scan reset for what it resets
` [PATCH v2 08/12] mm/collapse: separate scanning a PTE table from collapsing it
` [PATCH v2 09/12] mm/collapse: open-code collapse_single_pmd() in its two callers
` [PATCH v2 10/12] mm/collapse: work out the orders a VMA allows once per VMA
` [PATCH v2 11/12] mm/collapse: declare the collapse interface in collapse.h
` [PATCH v2 12/12] mm/collapse: implement MADV_COLLAPSE in madvise.c

[PATCH 0/4] mm: replace PF_KCOMPACTD/PF_KSWAPD with kthread_func()
 2026-09-10 11:57 UTC  (5+ messages)
` [PATCH 3/4] mm: replace PF_KSWAPD flag with kthread_func() check
` [PATCH 4/4] mm: replace PF_KCOMPACTD "

[PATCH v4] mm/page_alloc: avoid direct compaction for costly __GFP_NORETRY allocations
 2026-09-10 11:46 UTC  (2+ messages)

[PATCH v2 0/4] mm: zswap: misc optimizations
 2026-09-10 11:12 UTC  (11+ messages)
` [PATCH v2 1/4] mm: zswap: pass type and offset to zswap_invalidate() directly
` [PATCH v2 2/4] mm: zswap: reuse zswap_invalidate() in zswap_store() check_old path
` [PATCH v2 3/4] mm: zswap: avoid unnecessary xarray lookup in zswap_store()
` [PATCH v2 4/4] mm: zswap: skip zswap_invalidate() in swap_range_free() when zswap is unused

[PATCH v2 00/13] s390/cio: replace page allocator calls with k[mz]alloc()
 2026-09-10 11:00 UTC  (14+ messages)
` [PATCH v2 01/13] s390/chsc: Use kzalloc() for CUBs
` [PATCH v2 02/13] s390/chsc: Use kzalloc() for the SEI work area
` [PATCH v2 03/13] s390/chsc_sch: Use kzalloc() for CHSC requests
` [PATCH v2 04/13] s390/chsc_sch: Use __free(kfree) for synchronous "
` [PATCH v2 05/13] s390/cio: Use kzalloc() for CHSC work areas
` [PATCH v2 06/13] s390/cmf: Use kmalloc() for the CMB area
` [PATCH v2 07/13] s390/idals: Use kmalloc() for IDAL data buffers
` [PATCH v2 08/13] s390/qdio_main: Use kzalloc() for the IRQ structure
` [PATCH v2 09/13] s390/qdio_main: Use kzalloc() for the QDR
` [PATCH v2 10/13] s390/qdio_setup: Use kzalloc() for QDIO buffers
` [PATCH v2 11/13] s390/qdio_setup: Use kzalloc() for the storage list
` [PATCH v2 12/13] s390/qdio_setup: Use kzalloc() for the SSQD request
` [PATCH v2 13/13] s390/scm: Use kmalloc() for SCM information

[PATCH v6 00/12] dma-buf: heaps: Add support for Tegra VPR
 2026-09-10 10:52 UTC  (4+ messages)
` [PATCH v6 06/12] of: Export of_node_to_nid()

[PATCH RESEND v3 0/2] selftests/mm: Validate selections and scope memfd_secret setup
 2026-09-10 10:30 UTC  (5+ messages)
` [PATCH RESEND v3 1/2] selftests/mm: Reject invalid test selections before running tests


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox