Linux-mm Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: "Zi Yan" <ziy@nvidia.com>
To: "Brendan Jackman" <jackmanb@google.com>,
	"Andrew Morton" <akpm@linux-foundation.org>,
	"Vlastimil Babka" <vbabka@kernel.org>,
	"Suren Baghdasaryan" <surenb@google.com>,
	"Michal Hocko" <mhocko@suse.com>,
	"Johannes Weiner" <hannes@cmpxchg.org>,
	"Muchun Song" <muchun.song@linux.dev>,
	"Oscar Salvador" <osalvador@suse.de>,
	"David Hildenbrand" <david@kernel.org>,
	"Lorenzo Stoakes" <ljs@kernel.org>,
	"Liam R. Howlett" <liam@infradead.org>,
	"Mike Rapoport" <rppt@kernel.org>,
	"Matthew Brost" <matthew.brost@intel.com>,
	"Joshua Hahn" <joshua.hahnjy@gmail.com>,
	"Rakie Kim" <rakie.kim@sk.com>,
	"Byungchul Park" <byungchul@sk.com>,
	"Ying Huang" <ying.huang@linux.alibaba.com>,
	"Alistair Popple" <apopple@nvidia.com>,
	"Hao Li" <hao.li@linux.dev>, "Christoph Lameter" <cl@gentwo.org>,
	"David Rientjes" <rientjes@google.com>,
	"Roman Gushchin" <roman.gushchin@linux.dev>,
	"Sebastian Andrzej Siewior" <bigeasy@linutronix.de>,
	"Clark Williams" <clrkwllms@kernel.org>,
	"Steven Rostedt" <rostedt@goodmis.org>
Cc: "Harry Yoo (Oracle)" <harry@kernel.org>,
	"Gregory Price" <gourry@gourry.net>,
	"Alexei Starovoitov" <ast@kernel.org>,
	"Matthew Wilcox" <willy@infradead.org>,
	"Hao Ge" <hao.ge@linux.dev>, <linux-mm@kvack.org>,
	<linux-kernel@vger.kernel.org>, <linux-rt-devel@lists.linux.dev>,
	<derkling@google.com>, <reijiw@google.com>,
	"Yosry Ahmed" <yosry@kernel.org>,
	"JP Kobryn" <jp.kobryn@linux.dev>
Subject: Re: [PATCH v5 02/18] mm/page_alloc: some renames to clarify alloc_flags scopes
Date: Fri, 03 Jul 2026 10:01:57 -0400	[thread overview]
Message-ID: <DJOZP99PK3WY.27I2E9A25FPJ0@nvidia.com> (raw)
In-Reply-To: <20260703-alloc-trylock-v5-2-c87b714e19d3@google.com>

On Fri Jul 3, 2026 at 8:31 AM EDT, Brendan Jackman wrote:
> It's pretty confusing that:
>
> - The slowpath and fastpath have a totally distinct set of alloc_flags.
>
> - gfp_to_alloc_flags() sounds generic but it only influences the
>   slowpath.
>
> Rename some variables to highlight which alloc_flags are
> fastpath-specific. Rename gfp_to_alloc_flags() to highlight that it's
> slowpath-specific.
>
> gfp_to_alloc_flags_cma() and gfp_to_alloc_flags_nonblocking() currently
> have perfectly harmless names, but to keep the naming consistent also
> rename those to the alloc_flags_*() pattern (which already exists for
> alloc_flags_nofragment()).
>
> Reviewed-by: Vlastimil Babka (SUSE) <vbabka@kernel.org>
> Acked-by: JP Kobryn <jp.kobryn@linux.dev>
> Signed-off-by: Brendan Jackman <jackmanb@google.com>
> ---
>  include/linux/skbuff.h |  2 +-
>  mm/page_alloc.c        | 28 ++++++++++++++--------------
>  2 files changed, 15 insertions(+), 15 deletions(-)
>
LGTM.

Reviewed-by: Zi Yan <ziy@nvidia.com>

-- 
Best Regards,
Yan, Zi



  reply	other threads:[~2026-07-03 14:02 UTC|newest]

Thread overview: 36+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-03 12:31 [PATCH v5 00/18] mm: Some cleanups for page allocator APIs Brendan Jackman
2026-07-03 12:31 ` [PATCH v5 01/18] mm/page_alloc: rename ALLOC_TRYLOCK -> ALLOC_NOLOCK Brendan Jackman
2026-07-03 13:59   ` Zi Yan
2026-07-03 12:31 ` [PATCH v5 02/18] mm/page_alloc: some renames to clarify alloc_flags scopes Brendan Jackman
2026-07-03 14:01   ` Zi Yan [this message]
2026-07-03 12:31 ` [PATCH v5 03/18] mm: name some args in a function declaration Brendan Jackman
2026-07-03 14:02   ` Zi Yan
2026-07-03 12:31 ` [PATCH v5 04/18] mm: Split out internal page_alloc.h Brendan Jackman
2026-07-03 14:07   ` Zi Yan
2026-07-03 12:31 ` [PATCH v5 05/18] mm/page_alloc: unify __alloc_frozen_pages[_nolock]_noprof() Brendan Jackman
2026-07-03 14:42   ` Zi Yan
2026-07-03 12:31 ` [PATCH v5 06/18] mm/page_alloc: relax GFP WARN in nolock allocs Brendan Jackman
2026-07-03 14:44   ` Zi Yan
2026-07-03 12:31 ` [PATCH v5 07/18] mm: move some stuff to mm/page_alloc.h Brendan Jackman
2026-07-03 14:46   ` Zi Yan
2026-07-03 12:31 ` [PATCH v5 08/18] perf/x86/intel: Use higher-level allocator API Brendan Jackman
2026-07-03 14:49   ` Zi Yan
2026-07-03 12:31 ` [PATCH v5 09/18] KVM: VMX: " Brendan Jackman
2026-07-03 14:49   ` Zi Yan
2026-07-03 12:31 ` [PATCH v5 10/18] x86/virt: " Brendan Jackman
2026-07-03 14:50   ` Zi Yan
2026-07-03 12:31 ` [PATCH v5 11/18] sgi-xp: " Brendan Jackman
2026-07-03 14:51   ` Zi Yan
2026-07-03 12:31 ` [PATCH v5 12/18] net/funeth: Switch to " Brendan Jackman
2026-07-03 14:52   ` Zi Yan
2026-07-03 12:31 ` [PATCH v5 13/18] mm: Remove __alloc_pages_node() Brendan Jackman
2026-07-03 14:57   ` Zi Yan
2026-07-03 12:31 ` [PATCH v5 14/18] mm: Move __alloc_pages() to mm/page_alloc.h Brendan Jackman
2026-07-03 15:05   ` Zi Yan
2026-07-03 12:31 ` [PATCH v5 15/18] mm: replace __GFP_NO_CODETAG with ALLOC_NO_CODETAG Brendan Jackman
2026-07-03 12:31 ` [PATCH v5 16/18] mm: remove the __GFP_NO_OBJ_EXT flag Brendan Jackman
2026-07-03 12:31 ` [PATCH v5 17/18] mm/page_alloc: drop alloc_flags arg from alloc_flags_cma() Brendan Jackman
2026-07-03 15:10   ` Zi Yan
2026-07-03 12:31 ` [PATCH v5 18/18] mm: factor out can_spin_trylock() Brendan Jackman
2026-07-03 15:12   ` Zi Yan
2026-07-03 12:47 ` [PATCH v5 00/18] mm: Some cleanups for page allocator APIs Vlastimil Babka (SUSE)

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=DJOZP99PK3WY.27I2E9A25FPJ0@nvidia.com \
    --to=ziy@nvidia.com \
    --cc=akpm@linux-foundation.org \
    --cc=apopple@nvidia.com \
    --cc=ast@kernel.org \
    --cc=bigeasy@linutronix.de \
    --cc=byungchul@sk.com \
    --cc=cl@gentwo.org \
    --cc=clrkwllms@kernel.org \
    --cc=david@kernel.org \
    --cc=derkling@google.com \
    --cc=gourry@gourry.net \
    --cc=hannes@cmpxchg.org \
    --cc=hao.ge@linux.dev \
    --cc=hao.li@linux.dev \
    --cc=harry@kernel.org \
    --cc=jackmanb@google.com \
    --cc=joshua.hahnjy@gmail.com \
    --cc=jp.kobryn@linux.dev \
    --cc=liam@infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-rt-devel@lists.linux.dev \
    --cc=ljs@kernel.org \
    --cc=matthew.brost@intel.com \
    --cc=mhocko@suse.com \
    --cc=muchun.song@linux.dev \
    --cc=osalvador@suse.de \
    --cc=rakie.kim@sk.com \
    --cc=reijiw@google.com \
    --cc=rientjes@google.com \
    --cc=roman.gushchin@linux.dev \
    --cc=rostedt@goodmis.org \
    --cc=rppt@kernel.org \
    --cc=surenb@google.com \
    --cc=vbabka@kernel.org \
    --cc=willy@infradead.org \
    --cc=ying.huang@linux.alibaba.com \
    --cc=yosry@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox