From: Foxie Flakey <foxieflakey@gmail.com>
To: Andrew Morton <akpm@linux-foundation.org>
Cc: Foxie Flakey <foxieflakey@gmail.com>,
rppt@kernel.org, peterx@redhat.com, linux-mm@kvack.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH] userfaultfd: reset err to be 0 when move_pages_ptes succeeded
Date: Tue, 18 Aug 2026 08:13:00 +0700 (WIB) [thread overview]
Message-ID: <ae1cdc48-4293-8b81-d142-3c656f2c2cfa@gmail.com> (raw)
In-Reply-To: <20260817152605.5d2bee3fbf1a2bace4c0eff1@linux-foundation.org>
Hi, Andrew.
On Mon, 17 Aug 2026, Andrew Morton wrote:
> On Sat, 15 Aug 2026 17:42:12 +0700 (WIB) Foxie Flakey <foxieflakey@gmail.com> wrote:
>
> >
> > An fix for edge case can occur if move_pages_ptes return -EAGAIN, later
> > when checked and it is EAGAIN, outer loop would retry again on same page
> > and succeeded but the err isn't reset so the outer loop would think need
> > to retry again so it goes back again and move pages again. On third attempt
> > move_pages_ptes will fail because it already moved and returns an error
> > that is not EAGAIN when outer loop checks again it sees non EAGAIN so it
> > dont retry and break out of loop. When loop is terminated it did not update
> > the "moved" variable from successful 2nd iteration.
> >
> > That behaviour manifested into this at userspace
> >
> > Source: [ .. unmapped .. ][ .. mapped ..]
> > Destination: [ .. mapped .. ][ .. unmapped ..]
> > ^ ^
> > \ Kernel moved this far in actuality
> > What is reported to userspace on struct
> > uffdio_move's move field
> >
> > When the previous behaviour is
> > Source: [ .. unmapped .. ][ .. mapped ..]
> > Destination: [ .. mapped .. ][ .. unmapped ..]
> > ^
> > Reported to user space via uffdio_move's
> > move field
>
> Thanks.
>
> The text is a bit hard to follow. I asked Gemini to redo it and
> perhaps you prefer that? https://share.gemini.google/cOWn3pQadvVw
Yes, thanks. I have already make cleaner text from feedback on other branch
of mails with Suren.
> > Fixes: 50944692052b ("userfaultfd: opportunistic TLB-flush batching for present pages in MOVE")
> > Signed-off-by: Foxie Flakey <foxieflakey@gmail.com>
>
> Yes, the pseudonym is problematic - it is contrary to our written
> rules. But I'm a sucker for fixes, sigh. Perhaps if someone else were
> to send me your patch with their signoff also, the rules would be less
> offended.
I see, I'll post the updated patch and work on signoff issue later (there
has been updates, I haven't posted v2 which updates the patch and
description following a feedback. Why I didn't? mainly I'm not sure with
answer for signoff)
> > --- a/mm/userfaultfd.c
> > +++ b/mm/userfaultfd.c
> > @@ -2069,10 +2069,12 @@ static ssize_t move_pages(struct userfaultfd_ctx *ctx, unsigned long dst_start,
> > ret = move_pages_ptes(mm, dst_pmd, src_pmd,
> > dst_vma, src_vma, dst_addr,
> > src_addr, src_end - src_addr, mode);
> > - if (ret < 0)
> > + if (ret < 0) {
> > err = ret;
> > - else
> > + } else {
> > + err = 0;
> > step_size = ret;
> > + }
> > }
> >
> > cond_resched();
>
> Maintainers, when reviewing this please let me know whether you think
> it should be backported.
>
> Sashiko did what it usually does when we make it look at uffd:
> https://sashiko.dev/#/patchset/9c936a9f-ed27-e510-872f-5b3b8c680975@gmail.com
>
prev parent reply other threads:[~2026-08-18 1:13 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-15 10:42 [PATCH] userfaultfd: reset err to be 0 when move_pages_ptes succeeded Foxie Flakey
2026-08-16 9:15 ` Mike Rapoport
2026-08-16 9:41 ` Foxie Flakey
2026-08-16 11:45 ` Mike Rapoport
2026-08-16 13:58 ` Foxie Flakey
2026-08-16 15:43 ` Suren Baghdasaryan
2026-08-16 15:58 ` Foxie Flakey
2026-08-17 22:26 ` Andrew Morton
2026-08-17 22:35 ` Andrew Morton
2026-08-18 1:29 ` Foxie Flakey
2026-08-18 1:13 ` Foxie Flakey [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ae1cdc48-4293-8b81-d142-3c656f2c2cfa@gmail.com \
--to=foxieflakey@gmail.com \
--cc=akpm@linux-foundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=peterx@redhat.com \
--cc=rppt@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox