From: Kiryl Shutsemau <kas@kernel.org>
To: Usama Arif <usama.arif@linux.dev>
Cc: Andrew Morton <akpm@linux-foundation.org>,
david@kernel.org, chrisl@kernel.org, kasong@tencent.com,
ljs@kernel.org, ziy@nvidia.com, linux-mm@kvack.org,
ying.huang@linux.alibaba.com, Baoquan He <baoquan.he@linux.dev>,
willy@infradead.org, youngjun.park@lge.com, hannes@cmpxchg.org,
riel@surriel.com, shakeel.butt@linux.dev, alex@ghiti.fr,
baohua@kernel.org, dev.jain@arm.com,
baolin.wang@linux.alibaba.com, npache@redhat.com,
"Liam R. Howlett" <liam@infradead.org>,
ryan.roberts@arm.com, Vlastimil Babka <vbabka@kernel.org>,
lance.yang@linux.dev, linux-kernel@vger.kernel.org,
nphamcs@gmail.com, shikemeng@huaweicloud.com,
kernel-team@meta.com
Subject: Re: [PATCH v2 2/6] mm: extract mm_prepare_for_swap_entries() helper
Date: Mon, 6 Jul 2026 13:50:15 +0100 [thread overview]
Message-ID: <akukfKtNVEmdzXPR@thinkstation> (raw)
In-Reply-To: <642efd6d-7366-4641-a999-2d419fd38f8d@linux.dev>
On Mon, Jul 06, 2026 at 01:23:29PM +0100, Usama Arif wrote:
>
>
> On 06/07/2026 13:01, Kiryl Shutsemau wrote:
> > On Mon, Jul 06, 2026 at 04:42:04AM -0700, Usama Arif wrote:
> >> When a swap entry is installed in a page table, the mm must be added
> >> to init_mm.mmlist so that swapoff can find and unuse its swap entries.
> >> This double-checked locking pattern is currently open-coded in
> >> try_to_unmap_one() and copy_nonpresent_pte().
> >>
> >> Move it into mm_prepare_for_swap_entries() in mm/internal.h and convert
> >> both callers so it can be reused by upcoming PMD-level swap entry code
> >> paths that also need to register the mm with swapoff.
> >>
> >> copy_nonpresent_pte() previously inserted into &src_mm->mmlist rather
> >> than &init_mm.mmlist, but the insertion point is irrelevant, mmlist
> >> is a circular list and swapoff walks it entirely from init_mm.mmlist,
> >> so only membership matters, not position.
> >>
> >> Reviewed-by: Dev Jain <dev.jain@arm.com>
> >> Reviewed-by: Zi Yan <ziy@nvidia.com>
> >> Acked-by: David Hildenbrand (Arm) <david@kernel.org>
> >> Signed-off-by: Usama Arif <usama.arif@linux.dev>
> >> ---
> >> mm/internal.h | 10 ++++++++++
> >> mm/memory.c | 9 +--------
> >> mm/rmap.c | 7 +------
> >> 3 files changed, 12 insertions(+), 14 deletions(-)
> >>
> >> diff --git a/mm/internal.h b/mm/internal.h
> >> index 430aa72a4575..0360648e5726 100644
> >> --- a/mm/internal.h
> >> +++ b/mm/internal.h
> >> @@ -1955,4 +1955,14 @@ static inline int get_sysctl_max_map_count(void)
> >> bool may_expand_vm(struct mm_struct *mm, const vma_flags_t *vma_flags,
> >> unsigned long npages);
> >>
> >> +static inline void mm_prepare_for_swap_entries(struct mm_struct *mm)
> >> +{
> >> + if (list_empty(&mm->mmlist)) {
> >> + spin_lock(&mmlist_lock);
> >> + if (list_empty(&mm->mmlist))
> >> + list_add(&mm->mmlist, &init_mm.mmlist);
> >
> > The patch is fine, but the name of the field is awful. Seeing mmlist I
> > assumed it listed all mm_structs. It has to have "swap" somewhere in the
> > field name.
> >
>
> I can send a separate patch once this is replaced to replace mmlist with
> swap_mmlist if that sounds better?
Yep, better.
--
Kiryl Shutsemau / Kirill A. Shutemov
next prev parent reply other threads:[~2026-07-06 12:50 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-06 11:42 [PATCH v2 0/6] mm: preparatory patches for PMD level swap entries Usama Arif
2026-07-06 11:42 ` [PATCH v2 1/6] mm: add softleaf_to_pmd() and convert existing callers Usama Arif
2026-07-06 11:42 ` [PATCH v2 2/6] mm: extract mm_prepare_for_swap_entries() helper Usama Arif
2026-07-06 12:01 ` Kiryl Shutsemau
2026-07-06 12:23 ` Usama Arif
2026-07-06 12:50 ` Kiryl Shutsemau [this message]
2026-07-06 11:42 ` [PATCH v2 3/6] fs/proc: use softleaf_has_pfn() in pagemap PMD walker Usama Arif
2026-07-06 11:42 ` [PATCH v2 4/6] mm/huge_memory: move softleaf_to_folio() inside migration branch Usama Arif
2026-07-06 11:42 ` [PATCH v2 5/6] mm/migrate_device: move softleaf_to_folio() inside device-private branch Usama Arif
2026-07-06 11:42 ` [PATCH v2 6/6] mm: rename ARCH_ENABLE_THP_MIGRATION to ARCH_HAS_PMD_SOFTLEAVES Usama Arif
2026-07-06 18:32 ` David Hildenbrand (Arm)
2026-07-06 17:56 ` [PATCH v2 0/6] mm: preparatory patches for PMD level swap entries Andrew Morton
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=akukfKtNVEmdzXPR@thinkstation \
--to=kas@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=alex@ghiti.fr \
--cc=baohua@kernel.org \
--cc=baolin.wang@linux.alibaba.com \
--cc=baoquan.he@linux.dev \
--cc=chrisl@kernel.org \
--cc=david@kernel.org \
--cc=dev.jain@arm.com \
--cc=hannes@cmpxchg.org \
--cc=kasong@tencent.com \
--cc=kernel-team@meta.com \
--cc=lance.yang@linux.dev \
--cc=liam@infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=ljs@kernel.org \
--cc=npache@redhat.com \
--cc=nphamcs@gmail.com \
--cc=riel@surriel.com \
--cc=ryan.roberts@arm.com \
--cc=shakeel.butt@linux.dev \
--cc=shikemeng@huaweicloud.com \
--cc=usama.arif@linux.dev \
--cc=vbabka@kernel.org \
--cc=willy@infradead.org \
--cc=ying.huang@linux.alibaba.com \
--cc=youngjun.park@lge.com \
--cc=ziy@nvidia.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox