Linux-mm Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Lorenzo Stoakes <ljs@kernel.org>
To: Matthew Wilcox <willy@infradead.org>
Cc: xu.xin16@zte.com.cn, akpm@linux-foundation.org, david@kernel.org,
	 ziy@nvidia.com, baolin.wang@linux.alibaba.com,
	baohua@kernel.org,  lance.yang@linux.dev, usama.arif@linux.dev,
	chengming.zhou@linux.dev,  qi.zheng@linux.dev,
	linux-mm@kvack.org, linux-kernel@vger.kernel.org,
	 npache@redhat.com, ryan.roberts@arm.com, dev.jain@arm.com,
	wang.yaxin@zte.com.cn
Subject: Re: [PATCH] mm/mm_slot.h: add a helper function mm_slot_remove
Date: Sat, 11 Jul 2026 07:37:23 +0100	[thread overview]
Message-ID: <alHkQUJyr9UYlJKS@lucifer> (raw)
In-Reply-To: <alHG8YMmPYZWrKQz@casper.infradead.org>

On Sat, Jul 11, 2026 at 05:30:41AM +0100, Matthew Wilcox wrote:
> On Fri, Jul 10, 2026 at 01:17:37PM +0100, Lorenzo Stoakes wrote:
> > In general it's fine but I want more :) see below.
>
> ... and these functions all need kernel-doc.
> Not sure where to suggest that it be added to the Documentation/
> Thoughts?

Well could just send out to the KSM/THP people? If somebody has some bandwidth
for it.

Or... are you volunteering yourself? ;)

It'd be unfair to ask Xu to also add kdoc I think, perhaps do that as a
follow-up?

Just need to get those nasty pointless (AFAICT) macros gone.

Cheers, Lorenzo


  reply	other threads:[~2026-07-11  6:37 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-10  5:15 [PATCH] mm/mm_slot.h: add a helper function mm_slot_remove xu.xin16
2026-07-10 12:17 ` Lorenzo Stoakes
2026-07-11  4:30   ` Matthew Wilcox
2026-07-11  6:37     ` Lorenzo Stoakes [this message]
2026-07-13  5:44   ` xu.xin16

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alHkQUJyr9UYlJKS@lucifer \
    --to=ljs@kernel.org \
    --cc=akpm@linux-foundation.org \
    --cc=baohua@kernel.org \
    --cc=baolin.wang@linux.alibaba.com \
    --cc=chengming.zhou@linux.dev \
    --cc=david@kernel.org \
    --cc=dev.jain@arm.com \
    --cc=lance.yang@linux.dev \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=npache@redhat.com \
    --cc=qi.zheng@linux.dev \
    --cc=ryan.roberts@arm.com \
    --cc=usama.arif@linux.dev \
    --cc=wang.yaxin@zte.com.cn \
    --cc=willy@infradead.org \
    --cc=xu.xin16@zte.com.cn \
    --cc=ziy@nvidia.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox