Linux-mm Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: "David Hildenbrand (Arm)" <david@kernel.org>
To: Kairui Song <ryncsn@gmail.com>
Cc: linux-mm@kvack.org, linux-kernel@vger.kernel.org,
	Andrew Morton <akpm@linux-foundation.org>,
	Lorenzo Stoakes <ljs@kernel.org>, Zi Yan <ziy@nvidia.com>,
	Baolin Wang <baolin.wang@linux.alibaba.com>,
	"Liam R. Howlett" <liam@infradead.org>,
	Nico Pache <nico.pache@linux.dev>,
	Ryan Roberts <ryan.roberts@arm.com>, Dev Jain <dev.jain@arm.com>,
	Lance Yang <lance.yang@linux.dev>,
	Usama Arif <usama.arif@linux.dev>,
	Vlastimil Babka <vbabka@kernel.org>,
	Mike Rapoport <rppt@kernel.org>,
	Suren Baghdasaryan <surenb@google.com>,
	Michal Hocko <mhocko@suse.com>, Chris Li <chrisl@kernel.org>,
	Kemeng Shi <shikemeng@huaweicloud.com>,
	Nhat Pham <nphamcs@gmail.com>, Baoquan He <baoquan.he@linux.dev>,
	Barry Song <baohua@kernel.org>,
	Youngjun Park <youngjun.park@lge.com>,
	Shivam Kalra <shivamkalra98@zohomail.in>
Subject: Re: [PATCH v3 08/18] mm/huge_memory: move unmap and remap into the split helpers
Date: Thu, 27 Aug 2026 21:09:39 +0200	[thread overview]
Message-ID: <ee4e771a-b8ef-4ffe-9b79-301c22033d5d@kernel.org> (raw)
In-Reply-To: <CAMgjq7Ay3T6BRJ2E1kGD7BNq=4bMMOpw_EKOskM-9im_fjq-MQ@mail.gmail.com>

On 8/27/26 19:35, Kairui Song wrote:
> On Fri, Aug 28, 2026 at 12:32 AM David Hildenbrand (Arm)
> <david@kernel.org> wrote:
>>
>> On 8/20/26 20:55, Kairui Song via B4 Relay wrote:
>>> From: Kairui Song <kasong@tencent.com>
>>>
>>> To prepare for further cleanup, move the unmap/remap handling from
>>> __folio_split() into the split helpers.  Only anon folios need to
>>> be remapped, so remap_page() is now only called for anon splits and
>>> the anon check in remap_page() is redundant and can be removed.
>>
>> I can understand why we would want to move the remap_page().
>>
>> But why the unmap_folio()?
>>
>>>
>>> Reviewed-by: Zi Yan <ziy@nvidia.com>
>>> Signed-off-by: Kairui Song <kasong@tencent.com>
>>> ---
>>>  mm/huge_memory.c | 58 ++++++++++++++++++++++++++++++--------------------------
>>>  1 file changed, 31 insertions(+), 27 deletions(-)
>>>
>>> diff --git a/mm/huge_memory.c b/mm/huge_memory.c
>>> index 01c8cf428595..af9c2edd1fba 100644
>>> --- a/mm/huge_memory.c
>>> +++ b/mm/huge_memory.c
>>> @@ -3589,9 +3589,6 @@ static void remap_page(struct folio *folio, unsigned long nr, int flags)
>>>  {
>>>       int i = 0;
>>>
>>> -     /* If unmap_folio() uses try_to_migrate() on file, remove this check */
>>> -     if (!folio_test_anon(folio))
>>> -             return;
>>>       for (;;) {
>>>               remove_migration_ptes(folio, folio, TTU_RMAP_LOCKED | flags);
>>>               i += folio_nr_pages(folio);
>>
>> I think we should rename that function now to unmap_folio, but likely better
>> unmap_anon_folio().
>>
>>> @@ -3933,19 +3930,23 @@ static unsigned int folio_cache_ref_count(const struct folio *folio)
>>>       return folio_nr_pages(folio);
>>>  }
>>>
>>> -static int __folio_freeze_split_unmapped_anon(struct folio *folio, unsigned int new_order,
>>> -                                           struct page *split_at, bool do_lru,
>>> -                                           struct list_head *list, enum split_type split_type)
>>> +static int __folio_split_unmap_and_freeze_anon(struct folio *folio, unsigned int new_order,
>>> +                                            struct page *split_at, bool do_lru, bool unmap,
>>> +                                            struct list_head *list, enum split_type split_type)
>>>  {
>>>       struct folio *end_folio = folio_next(folio);
>>>       struct swap_cluster_info *ci = NULL;
>>>       struct folio *new_folio, *next;
>>>       int old_order = folio_order(folio);
>>> +     enum ttu_flags ttu_flags = 0;
>>>       struct list_lru_one *lru;
>>>       struct lruvec *lruvec;
>>>       bool dequeue_deferred;
>>>       int ret = 0;
>>>
>>> +     if (unmap)
>>> +             unmap_folio(folio);
>>
>> I really hate that "bool unmap" parameter.
>>
>> folio_split_unmapped() has this VM_WARN_ON_ONCE_FOLIO(folio_mapped(folio), folio);
>>
>> So you can really just do
>>
>> if (folio_mapped())
>>         unmap_folio(folio);
>>
>> Or have an early exit and hide it in unmap_folio().
> 
> The only special case here is device private memory, from folio_split_unmapped.
> 
> Maybe I can just keep the unmap_folfio where it is, but
> __folio_split_unmap_and_freeze_anon need to know if the folio need to
> be remapped.
> 
> Will a "bool remap" parameter look good?

I'd avoid that and rather have something like the following in the function.

if (folio_mapped()) {
	folio_unmapped = true;
	unmap_folio(folio);
}

...

if (folio_unmapped)
	remap_anon_folio(folio)


...

-- 
Cheers,

David


  reply	other threads:[~2026-08-27 19:09 UTC|newest]

Thread overview: 74+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-20 18:55 [PATCH v3 00/18] mm/huge_memory: clean up folio split and lift swapcache split limits Kairui Song via B4 Relay
2026-08-20 18:55 ` [PATCH v3 01/18] mm/swap: fix off-by-one in swap cache replace sanity check Kairui Song via B4 Relay
2026-08-23  8:53   ` Barry Song
2026-08-27 14:13   ` Kiryl Shutsemau
2026-08-27 15:57   ` David Hildenbrand (Arm)
2026-08-20 18:55 ` [PATCH v3 02/18] mm/huge_memory: fix rejection of swap cache folios with a mapping Kairui Song via B4 Relay
2026-08-27  8:46   ` Barry Song
2026-08-27  9:31     ` Kairui Song
2026-08-27 14:33   ` Kiryl Shutsemau
2026-08-27 15:58     ` David Hildenbrand (Arm)
2026-08-27 14:36   ` Kiryl Shutsemau
2026-08-27 16:01     ` David Hildenbrand (Arm)
2026-08-27 16:00   ` David Hildenbrand (Arm)
2026-08-27 17:02     ` Kiryl Shutsemau
2026-08-27 17:11       ` David Hildenbrand (Arm)
2026-08-27 17:07     ` Kairui Song
2026-08-20 18:55 ` [PATCH v3 03/18] mm/huge_memory: invert folio_ref_freeze() check to reduce indentation Kairui Song via B4 Relay
2026-08-27  9:05   ` Barry Song
2026-08-27 14:39   ` Kiryl Shutsemau
2026-08-27 16:02   ` David Hildenbrand (Arm)
2026-08-20 18:55 ` [PATCH v3 04/18] mm/huge_memory: split the routine for splitting anon and file folio Kairui Song via B4 Relay
2026-08-26  1:31   ` Zi Yan
2026-08-27 14:58   ` Kiryl Shutsemau
2026-08-27 17:19     ` Kairui Song
2026-08-27 16:19   ` David Hildenbrand (Arm)
2026-08-27 17:17     ` Kairui Song
2026-08-27 19:05       ` David Hildenbrand (Arm)
2026-08-20 18:55 ` [PATCH v3 05/18] mm/huge_memory: rename __split_unmapped_folio() to __split_frozen_folio() Kairui Song via B4 Relay
2026-08-27 15:06   ` Kiryl Shutsemau
2026-08-27 16:22     ` David Hildenbrand (Arm)
2026-08-27 17:21       ` Kairui Song
2026-08-20 18:55 ` [PATCH v3 06/18] mm/huge_memory: consolidate irq and locking for folio split Kairui Song via B4 Relay
2026-08-27 15:15   ` Kiryl Shutsemau
2026-08-27 16:24   ` David Hildenbrand (Arm)
2026-08-20 18:55 ` [PATCH v3 07/18] mm/huge_memory: move EOF trimming into the file split helper Kairui Song via B4 Relay
2026-08-27 16:25   ` David Hildenbrand (Arm)
2026-08-20 18:55 ` [PATCH v3 08/18] mm/huge_memory: move unmap and remap into the split helpers Kairui Song via B4 Relay
2026-08-27 16:32   ` David Hildenbrand (Arm)
2026-08-27 17:35     ` Kairui Song
2026-08-27 19:09       ` David Hildenbrand (Arm) [this message]
2026-08-20 18:55 ` [PATCH v3 09/18] mm/huge_memory: move anon_vma and filemap management into " Kairui Song via B4 Relay
2026-08-27 16:36   ` David Hildenbrand (Arm)
2026-08-27 17:37     ` Kairui Song
2026-08-20 18:55 ` [PATCH v3 10/18] mm/huge_memory: move memcg switch into the file split helper Kairui Song via B4 Relay
2026-08-27 16:37   ` David Hildenbrand (Arm)
2026-08-20 18:55 ` [PATCH v3 11/18] mm/huge_memory: allow splitting mappingless swap cache folios Kairui Song via B4 Relay
2026-08-26  1:55   ` Zi Yan
2026-08-27 16:41   ` David Hildenbrand (Arm)
2026-08-27 17:41     ` Kairui Song
2026-08-27 19:16       ` David Hildenbrand (Arm)
2026-08-27 19:29         ` David Hildenbrand (Arm)
2026-08-20 18:55 ` [PATCH v3 12/18] mm/huge_memory: add kerneldoc for the split helpers Kairui Song via B4 Relay
2026-08-26  1:57   ` Zi Yan
2026-08-27 16:45   ` David Hildenbrand (Arm)
2026-08-27 17:43     ` Kairui Song
2026-08-20 18:55 ` [PATCH v3 13/18] mm/huge_memory: drop the unused do_lru argument of the file split helper Kairui Song via B4 Relay
2026-08-26  1:57   ` Zi Yan
2026-08-27 16:45   ` David Hildenbrand (Arm)
2026-08-20 18:55 ` [PATCH v3 14/18] mm/huge_memory: clean up after-split folio freeing in __folio_split Kairui Song via B4 Relay
2026-08-27 16:48   ` David Hildenbrand (Arm)
2026-08-27 17:47     ` Kairui Song
2026-08-27 19:33       ` David Hildenbrand (Arm)
2026-08-20 18:55 ` [PATCH v3 15/18] mm/huge_memory: lift order-0 restriction for swapcache split Kairui Song via B4 Relay
2026-08-27 16:51   ` David Hildenbrand (Arm)
2026-08-27 17:48     ` Kairui Song
2026-08-27 20:22       ` David Hildenbrand (Arm)
2026-08-20 18:55 ` [PATCH v3 16/18] mm/huge_memory: clarify supported split orders in comment Kairui Song via B4 Relay
2026-08-26  2:02   ` Zi Yan
2026-08-27 17:48     ` Kairui Song
2026-08-27 16:54   ` David Hildenbrand (Arm)
2026-08-20 18:55 ` [PATCH v3 17/18] mm/huge_memory: count only swap cache refs in anon folio split Kairui Song via B4 Relay
2026-08-20 18:55 ` [PATCH v3 18/18] mm/huge_memory: drop the redundant mapping argument of __split_frozen_folio Kairui Song via B4 Relay
2026-08-26  2:06   ` Zi Yan
2026-08-27 12:19 ` [PATCH v3 00/18] mm/huge_memory: clean up folio split and lift swapcache split limits Yeoreum Yun

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ee4e771a-b8ef-4ffe-9b79-301c22033d5d@kernel.org \
    --to=david@kernel.org \
    --cc=akpm@linux-foundation.org \
    --cc=baohua@kernel.org \
    --cc=baolin.wang@linux.alibaba.com \
    --cc=baoquan.he@linux.dev \
    --cc=chrisl@kernel.org \
    --cc=dev.jain@arm.com \
    --cc=lance.yang@linux.dev \
    --cc=liam@infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=ljs@kernel.org \
    --cc=mhocko@suse.com \
    --cc=nico.pache@linux.dev \
    --cc=nphamcs@gmail.com \
    --cc=rppt@kernel.org \
    --cc=ryan.roberts@arm.com \
    --cc=ryncsn@gmail.com \
    --cc=shikemeng@huaweicloud.com \
    --cc=shivamkalra98@zohomail.in \
    --cc=surenb@google.com \
    --cc=usama.arif@linux.dev \
    --cc=vbabka@kernel.org \
    --cc=youngjun.park@lge.com \
    --cc=ziy@nvidia.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox