Linux Modules
 help / color / mirror / Atom feed
From: sashiko-bot@kernel.org
To: "Aaron Tomlin" <atomlin@atomlin.com>
Cc: linux-modules@vger.kernel.org, ojeda@kernel.org
Subject: Re: [PATCH v9 2/2] module: Rename module_blacklist to module_denylist
Date: Fri, 07 Aug 2026 01:37:29 +0000	[thread overview]
Message-ID: <20260807013730.3A2BF1F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260807012601.360452-3-atomlin@atomlin.com>

Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Low] The comment preceding the module_is_denylisted() call was not updated to reflect the new terminology.
--

--- Patch [2]: [PATCH v9 2/2] module: Rename module_blacklist to module_denylist ---
commit ac79bb8334a6a0d6e2353ff853444d535ab50178
Author: Aaron Tomlin <atomlin@atomlin.com>

module: Rename module_blacklist to module_denylist

This commit renames the kernel parameter and internal symbols from "blacklist"
to "denylist" while keeping the old parameter as a deprecated alias. Log
messages and documentation are also updated to reflect the new terminology.

[ ... ]

> diff --git a/kernel/module/main.c b/kernel/module/main.c
> index a9fd6aaedc69c..1a58313649d94 100644
> --- a/kernel/module/main.c
> +++ b/kernel/module/main.c
> @@ -3381,8 +3381,8 @@ static int early_mod_check(struct load_info *info, int flags)
>  	 * Now that we know we have the correct module name, check
>  	 * if it's blacklisted.

[Severity: Low]
This isn't a bug, but should this comment also be updated to say "denylisted"
to match the rest of the terminology changes in this patch?

>  	 */
> -	if (module_is_blacklisted(info->name)) {
> -		pr_err("Module %s is blacklisted\n", info->name);
> +	if (module_is_denylisted(info->name)) {
> +		pr_err("Module %s is denylisted\n", info->name);
>  		return -EPERM;
>  	}

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/20260807012601.360452-1-atomlin@atomlin.com?part=2

      reply	other threads:[~2026-08-07  1:37 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-07  1:25 [PATCH v9 0/2] module: Extend module_blacklist parameter to built-in modules Aaron Tomlin
2026-08-07  1:26 ` [PATCH v9 1/2] " Aaron Tomlin
2026-08-07  1:26 ` [PATCH v9 2/2] module: Rename module_blacklist to module_denylist Aaron Tomlin
2026-08-07  1:37   ` sashiko-bot [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260807013730.3A2BF1F000E9@smtp.kernel.org \
    --to=sashiko-bot@kernel.org \
    --cc=atomlin@atomlin.com \
    --cc=linux-modules@vger.kernel.org \
    --cc=ojeda@kernel.org \
    --cc=sashiko-reviews@lists.linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox