messages from 2026-07-09 08:45:53 to 2026-07-20 13:28:49 UTC [more...]
[PATCH 0/5] module/dups: Fix a use-after-free and improve the code
2026-07-20 13:28 UTC (12+ messages)
` [PATCH 1/5] module/dups: Fix use-after-free in kmod_dup_req lifetime handling
` [PATCH 2/5] module/dups: Inform duplicate requests about the result directly
` [PATCH 3/5] module/dups: Use scoped guards for kmod_dup_mutex
` [PATCH 4/5] module/dups: Use strcmp() to compare module names
` [PATCH 5/5] module/dups: Clean up includes
[PATCH v6 0/2] module: Extend blacklist parameter to support built-in modules
2026-07-18 19:11 UTC (4+ messages)
` [PATCH v6 1/2] module: Extend module_blacklist parameter to "
` [PATCH v6 2/2] module: Rename module_blacklist to module_denylist
[PATCH v5 0/2] module: Extend blacklist parameter to support built-in modules
2026-07-18 14:26 UTC (6+ messages)
` [PATCH v5 1/2] module: Extend module_blacklist parameter to "
` [PATCH v5 2/2] module: Rename module_blacklist to module_denylist
[PATCH v4] module: Extend module_blacklist parameter to built-in modules
2026-07-18 4:03 UTC (11+ messages)
[PATCH v8 00/10] Fix missing fops.owner in Rust DRM/misc abstractions
2026-07-17 13:07 UTC (20+ messages)
` [PATCH v8 01/10] rust: module: move module types into `module.rs`
` [PATCH v8 02/10] rust: module: add `THIS_MODULE` const to `ModuleMetadata` trait
` [PATCH v8 03/10] rust: doctest: add LocalModule fallback for #[vtable] ThisModule
` [PATCH v8 04/10] rust: macros: auto-insert OwnerModule in #[vtable]
` [PATCH v8 05/10] rust: drm: set fops.owner from driver module pointer
` [PATCH v8 06/10] rust: miscdevice: "
` [PATCH v8 07/10] rust: configfs: use `LocalModule` for `THIS_MODULE`
` [PATCH v8 08/10] rust: binder: "
` [PATCH v8 09/10] rust: macros: remove `THIS_MODULE` static from `module!`
` [PATCH v8 10/10] rust: module: update MAINTAINERS to cover module.rs
[PATCH] module: fix UAF and GPF in idempotent_init_module via heap allocation
2026-07-17 8:40 UTC (2+ messages)
[PATCH v7 0/4] kallsyms: embed source file:line info in kernel stack traces
2026-07-16 11:32 UTC (10+ messages)
` [PATCH v7 1/4] "
` [PATCH v7 2/4] kallsyms: extend lineinfo to loadable modules
` [PATCH v7 3/4] kallsyms: delta-compress lineinfo tables for ~2.7x size reduction
` [PATCH v7 4/4] kallsyms: add KUnit tests for lineinfo feature
[PATCH net v2] ppp: defer channel free to an RCU grace period to fix pppol2tp RX UAF
2026-07-15 16:26 UTC (11+ messages)
[PATCH] module: validate string table section types
2026-07-14 11:33 UTC (9+ messages)
[PATCH] kbuild: Use --force-group-allocation when linking modules
2026-07-13 12:32 UTC (2+ messages)
[PATCH v19 00/40] DEPT(DEPendency Tracker)
2026-07-13 3:36 UTC (34+ messages)
` [PATCH v19 04/40] dept: tie to lockdep and IRQ tracing
` [PATCH v19 07/40] dept: distinguish each work from another
` [PATCH v19 13/40] dept: apply sdt_might_sleep_{start,end}() to hashed-waitqueue wait
` [PATCH v19 13/40] dept: apply sdt_might_sleep_{start, end}() "
` [PATCH v19 19/40] dept: apply timeout consideration "
` [PATCH v19 28/40] dept: assign unique dept_key to each distinct dma fence caller
` [PATCH v19 29/40] dept: make dept aware of lockdep_set_lock_cmp_fn() annotation
` [PATCH v19 31/40] dept: assign unique dept_key to each distinct wait_for_completion() caller
` [PATCH v19 32/40] completion, dept: introduce init_completion_dmap() API
` [PATCH v19 34/40] rcu/update: fix same dept key collision between various types of RCU
` [PATCH v19 38/40] mm: percpu: increase PERCPU_DYNAMIC_SIZE_SHIFT on DEPT and large PAGE_SIZE
` [PATCH v19 39/40] rust: completion: Add __rust_helper to rust_helper_wait_for_completion()
[PATCH v2] rust: module_param: return value by copy from `value`
2026-07-10 17:33 UTC (9+ messages)
[PATCH 0/1] rust: module_param: support bool parameters
2026-07-10 14:10 UTC (3+ messages)
` [PATCH 1/1] "
[PATCH 0/2] Bring includes in linux/kmod.h up to date
2026-07-10 13:57 UTC (6+ messages)
` [PATCH 1/2] umh, treewide: Explicitly include linux/umh.h where needed
` [PATCH 2/2] module: Bring includes in linux/kmod.h up to date
[PATCH 0/4] module: Limit ELF includes in linux/module.h to uapi/linux/elf.h
2026-07-10 13:56 UTC (3+ messages)
` [PATCH 4/4] "
[PATCH v2 1/2] module/kallsyms: fix nextval for data symbol lookup
2026-07-10 12:36 UTC (2+ messages)
[PATCH v2] module: procfs: fix signed integer overflow in module_total_size()
2026-07-10 7:36 UTC (4+ messages)
About THIS_MODULE
2026-07-09 14:31 UTC (2+ messages)
[PATCH 0/2] module: Remove unnecessary module::args
2026-07-09 9:02 UTC (2+ messages)
[PATCH] module: Remove unused DISCARD_EH_FRAME definition from module.lds.S
2026-07-09 8:49 UTC (3+ messages)
page: | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox