From: "Gary Guo" <gary@garyguo.net>
To: "Arnd Bergmann" <arnd@arndb.de>,
"Andrew Morton" <akpm@linux-foundation.org>,
"Aaron Tomlin" <atomlin@atomlin.com>
Cc: "Luis Chamberlain" <mcgrof@kernel.org>,
"Petr Pavlu" <petr.pavlu@suse.com>, <da.gomez@kernel.org>,
"Sami Tolvanen" <samitolvanen@google.com>,
"Peter Zijlstra" <peterz@infradead.org>,
"Miguel Ojeda" <ojeda@kernel.org>,
"Masami Hiramatsu" <mhiramat@kernel.org>,
"Boqun Feng" <boqun@kernel.org>, <neelx@suse.com>,
<da.anzani@gmail.com>, <sean@ashe.io>, <chjohnst@mail.com>,
<steve@abita.co>, <mproche@mail.com>, <nick.lane@mail.com>,
<rishil1999@outlook.com>,
"Linux-Arch" <linux-arch@vger.kernel.org>,
<linux-modules@vger.kernel.org>, <rust-for-linux@vger.kernel.org>,
<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v10 0/2] module: Extend module_blacklist parameter to built-in modules
Date: Sun, 06 Sep 2026 13:33:50 +0100 [thread overview]
Message-ID: <DL88J7DRO10E.1QCYWPWBLE7QP@garyguo.net> (raw)
In-Reply-To: <3cee4548-0ae7-46a7-b437-bf84e5c155ad@app.fastmail.com>
On Sun Sep 6, 2026 at 10:56 AM BST, Arnd Bergmann wrote:
> On Sun, Sep 6, 2026, at 02:28, Andrew Morton wrote:
>> On Fri, 4 Sep 2026 10:59:38 -0400 Aaron Tomlin <atomlin@atomlin.com> wrote:
>>>
>>> In summary, this patch brings parity between modular and built-in drivers,
>>> removes a pain point in boot-time disaster recovery, and provides users
>>> with a predictable, consistent interface.
>>
>> Really helpful, thanks. Please add this to the [0/N] and maintain it.
>>
>> I don't really know who are the potential audience for this change, nor
>> how to attract their attention. Greg might have some insights but he
>> wasn't cc'ed.
>>
>> Let's leave it a week to see if there's feedback then resend with these
>> adjustments?
>
> FWIW, I previously asked the same question on this series
> and still don't find the explanation lacking. Obviously,
> consistency is good, but the added complexity doesn't feel
> worth it here, given that this still has most of the same
> problems as the existing "initcall_blacklist=" option [1].
Yeah, I like the better consistency, which is why I propose unifying handling
for both built-in modules and loadable ones in
https://lore.kernel.org/all/DKNWEO3BOUOL.9COZBXZIGS6A@garyguo.net/.
IMO if we can unify them, then we get something that is both consistent and
*less* complexity.
The current solution makes thing more complex with only apparent consistency
(i.e. user observe the consistency from kernel parameter, but the internal
handling are two separate mechanisms), which should require a very strong reason
to pursue.
Best,
Gary
>
> I think patch 2/2 would be fine on its own, but for 1/2
> I have yet to see a single example of a real-world problem
> that could have been solved by this but not using
> initcall_blacklist. In distro kernels, almost everything
> is already a loadable module, while users with custom
> kernels could easily turn off the drivers they don't want
> or disable the initcall by name.
>
> Arnd
>
> [1] https://lore.kernel.org/all/78ec1da5-11ae-4c35-a08e-cc88a5d083f4@app.fastmail.com/
next prev parent reply other threads:[~2026-09-06 12:33 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-03 18:55 [PATCH v10 0/2] module: Extend module_blacklist parameter to built-in modules Aaron Tomlin
2026-09-03 18:55 ` [PATCH v10 1/2] " Aaron Tomlin
2026-09-03 19:13 ` sashiko-bot
2026-09-04 14:34 ` Aaron Tomlin
2026-09-06 13:39 ` Gary Guo
2026-09-06 15:07 ` Aaron Tomlin
2026-09-03 20:23 ` Aaron Tomlin
2026-09-03 18:55 ` [PATCH v10 2/2] module: Rename module_blacklist to module_denylist Aaron Tomlin
2026-09-03 19:07 ` sashiko-bot
2026-09-04 15:13 ` Aaron Tomlin
2026-09-03 20:29 ` [PATCH v10 0/2] module: Extend module_blacklist parameter to built-in modules Andrew Morton
2026-09-04 14:59 ` Aaron Tomlin
2026-09-06 0:28 ` Andrew Morton
2026-09-06 9:56 ` Arnd Bergmann
2026-09-06 12:33 ` Gary Guo [this message]
2026-09-06 14:08 ` Aaron Tomlin
2026-09-06 13:15 ` Aaron Tomlin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=DL88J7DRO10E.1QCYWPWBLE7QP@garyguo.net \
--to=gary@garyguo.net \
--cc=akpm@linux-foundation.org \
--cc=arnd@arndb.de \
--cc=atomlin@atomlin.com \
--cc=boqun@kernel.org \
--cc=chjohnst@mail.com \
--cc=da.anzani@gmail.com \
--cc=da.gomez@kernel.org \
--cc=linux-arch@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-modules@vger.kernel.org \
--cc=mcgrof@kernel.org \
--cc=mhiramat@kernel.org \
--cc=mproche@mail.com \
--cc=neelx@suse.com \
--cc=nick.lane@mail.com \
--cc=ojeda@kernel.org \
--cc=peterz@infradead.org \
--cc=petr.pavlu@suse.com \
--cc=rishil1999@outlook.com \
--cc=rust-for-linux@vger.kernel.org \
--cc=samitolvanen@google.com \
--cc=sean@ashe.io \
--cc=steve@abita.co \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox