From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-6.0 required=3.0 tests=BAYES_00,DKIMWL_WL_HIGH, DKIM_SIGNED,DKIM_VALID,DKIM_VALID_AU,MAILING_LIST_MULTI,SPF_HELO_NONE, SPF_PASS,URIBL_BLOCKED autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 07443C4361B for ; Mon, 14 Dec 2020 23:38:42 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id BB80E22507 for ; Mon, 14 Dec 2020 23:38:41 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1726847AbgLNXik (ORCPT ); Mon, 14 Dec 2020 18:38:40 -0500 Received: from mail.kernel.org ([198.145.29.99]:49938 "EHLO mail.kernel.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1728198AbgLNXij (ORCPT ); Mon, 14 Dec 2020 18:38:39 -0500 Date: Mon, 14 Dec 2020 17:37:57 -0600 DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=kernel.org; s=k20201202; t=1607989078; bh=fnAS6MkH1ixn2rQeMGUq7HxFriFYnNoItGMTUmcfAig=; h=From:To:Cc:Subject:In-Reply-To:From; b=NHw1acSvYZ19g8mfuNopLwS2bQt5oSFyC46FGYyUO3UAvqfbu51zueYVR7bamJaYH 6q/4ZPZeEX3gvTgOP2DRJ8sTQveOxjhnubSEDtK4vtyr52jbHLyjdZahO/J2md7iXG JfDrQ6flgqlfYEsgV4OwXIrHEg8p9uWc5U5LOTwuF2wQFx0UJrir4NtER0mcJCEWJM qgSrF4VoMOSvXUcQWFkdMsbLjy5MEkvKlMzJBGeAdpcP6WUfQdawbxZ6RZ8XKILD/Y Z1s5Sw/vOYFMiRXslqhaIHYBDOtmgxVFPcBKbYCzVyeGKrtVO3kmeVZ/65vNZ+RY9w f4i8b3jL803Qw== From: Bjorn Helgaas To: Alex Deucher Cc: Stephen Rothwell , Bjorn Helgaas , Alex Deucher , Jay Vosburgh , Kuppuswamy Sathyanarayanan , Linux Kernel Mailing List , Linux Next Mailing List , Sean V Kelley Subject: Re: linux-next: manual merge of the amdgpu tree with the pci tree Message-ID: <20201214233757.GA276422@bjorn-Precision-5520> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: Precedence: bulk List-ID: X-Mailing-List: linux-next@vger.kernel.org On Mon, Dec 14, 2020 at 06:18:54PM -0500, Alex Deucher wrote: > On Mon, Dec 14, 2020 at 6:16 PM Bjorn Helgaas wrote: > > On Tue, Dec 15, 2020 at 07:34:31AM +1100, Stephen Rothwell wrote: > > > Hi all, > > > > > > On Tue, 8 Dec 2020 13:56:20 +1100 Stephen Rothwell wrote: > > > > > > > > Today's linux-next merge of the amdgpu tree got a conflict in: > > > > > > > > drivers/pci/pcie/err.c > > > > > > > > between commits: > > > > > > > > 8f1bbfbc3596 ("PCI/ERR: Rename reset_link() to reset_subordinates()") > > > > 0791721d8007 ("PCI/ERR: Use "bridge" for clarity in pcie_do_recovery()") > > > > 05e9ae19ab83 ("PCI/ERR: Add pci_walk_bridge() to pcie_do_recovery()") > > > > > > > > from the pci tree and commit: > > > > > > > > 36a8901e900a ("PCI/ERR: Fix reset logic in pcie_do_recovery() call") > > > > > > > > from the amdgpu tree. > > > > > > > > I fixed it up (I think - see below) and can carry the fix as > > > > necessary. This is now fixed as far as linux-next is concerned, but any > > > > non trivial conflicts should be mentioned to your upstream maintainer > > > > when your tree is submitted for merging. You may also want to consider > > > > cooperating with the maintainer of the conflicting tree to minimise any > > > > particularly complex conflicts. > > > > Huh. It's sub-optimal to change this core code via both the PCI and > > the amdgpu tree, with no heads-up to me. > > > > 400b308d388a ("PCI/ERR: Fix reset logic in pcie_do_recovery() call") > > (apparently in the amdgpu tree) doesn't have a Link: tag to the > > posting of the patch, where there was quite a lot of useful discussion > > that should be connected somehow. > > > > I think the posting was > > https://lore.kernel.org/r/cbba08a5e9ca62778c8937f44eda2192a2045da7.1595617529.git.sathyanarayanan.kuppuswamy@linux.intel.com > > > > I had deferred merging this patch so I could merge Sean's RCEC work > > first, and then resolve the conflict when merging *this* patch. > > I don't plan to merge this upstream via my tree. I was just carrying > it in my drm-next branch because we have a number of users that depend > on it for working DPC and a number of people use this branch for > testing. OK, thanks. FWIW, it's currently marked "Changes Requested" in patchwork, so it isn't really going anywhere right now: https://patchwork.kernel.org/project/linux-pci/patch/cbba08a5e9ca62778c8937f44eda2192a2045da7.1595617529.git.sathyanarayanan.kuppuswamy@linux.intel.com/ I have merged Sean's series, so this would be a good time to try to move this one forward.