Linux NFS development
 help / color / mirror / Atom feed
From: Jeff Layton <jlayton@kernel.org>
To: Chuck Lever <cel@kernel.org>, linux-nfs@vger.kernel.org
Cc: Chuck Lever <chuck.lever@oracle.com>
Subject: Re: [PATCH v1 1/6] NFSD: Refactor nfsd_reply_cache_free_locked()
Date: Mon, 10 Jul 2023 09:09:41 -0400	[thread overview]
Message-ID: <0ad01b423530a0aaef70a847dd82e9fca88daed5.camel@kernel.org> (raw)
In-Reply-To: <168891751661.3964.5239269567232450425.stgit@manet.1015granger.net>

On Sun, 2023-07-09 at 11:45 -0400, Chuck Lever wrote:
> From: Chuck Lever <chuck.lever@oracle.com>
> 
> To reduce contention on the bucket locks, we must avoid calling
> kfree() while each bucket lock is held.
> 
> Start by refactoring nfsd_reply_cache_free_locked() into a helper
> that removes an entry from the bucket (and must therefore run under
> the lock) and a second helper that frees the entry (which does not
> need to hold the lock).
> 
> For readability, rename the helpers nfsd_cacherep_<verb>.
> 
> Signed-off-by: Chuck Lever <chuck.lever@oracle.com>
> ---
>  fs/nfsd/nfscache.c |   26 +++++++++++++++++++-------
>  1 file changed, 19 insertions(+), 7 deletions(-)
> 
> diff --git a/fs/nfsd/nfscache.c b/fs/nfsd/nfscache.c
> index a8eda1c85829..601298b7f75f 100644
> --- a/fs/nfsd/nfscache.c
> +++ b/fs/nfsd/nfscache.c
> @@ -110,21 +110,32 @@ nfsd_reply_cache_alloc(struct svc_rqst *rqstp, __wsum csum,
>  	return rp;
>  }
>  
> +static void nfsd_cacherep_free(struct svc_cacherep *rp)
> +{
> +	kfree(rp->c_replvec.iov_base);
> +	kmem_cache_free(drc_slab, rp);
> +}
> +
>  static void
> -nfsd_reply_cache_free_locked(struct nfsd_drc_bucket *b, struct svc_cacherep *rp,
> -				struct nfsd_net *nn)
> +nfsd_cacherep_unlink_locked(struct nfsd_net *nn, struct nfsd_drc_bucket *b,
> +			    struct svc_cacherep *rp)
>  {
> -	if (rp->c_type == RC_REPLBUFF && rp->c_replvec.iov_base) {
> +	if (rp->c_type == RC_REPLBUFF && rp->c_replvec.iov_base)
>  		nfsd_stats_drc_mem_usage_sub(nn, rp->c_replvec.iov_len);
> -		kfree(rp->c_replvec.iov_base);
> -	}
>  	if (rp->c_state != RC_UNUSED) {
>  		rb_erase(&rp->c_node, &b->rb_head);
>  		list_del(&rp->c_lru);
>  		atomic_dec(&nn->num_drc_entries);
>  		nfsd_stats_drc_mem_usage_sub(nn, sizeof(*rp));
>  	}
> -	kmem_cache_free(drc_slab, rp);
> +}
> +
> +static void
> +nfsd_reply_cache_free_locked(struct nfsd_drc_bucket *b, struct svc_cacherep *rp,
> +				struct nfsd_net *nn)
> +{
> +	nfsd_cacherep_unlink_locked(nn, b, rp);
> +	nfsd_cacherep_free(rp);
>  }
>  
>  static void
> @@ -132,8 +143,9 @@ nfsd_reply_cache_free(struct nfsd_drc_bucket *b, struct svc_cacherep *rp,
>  			struct nfsd_net *nn)
>  {
>  	spin_lock(&b->cache_lock);
> -	nfsd_reply_cache_free_locked(b, rp, nn);
> +	nfsd_cacherep_unlink_locked(nn, b, rp);
>  	spin_unlock(&b->cache_lock);
> +	nfsd_cacherep_free(rp);
>  }
>  
>  int nfsd_drc_slab_create(void)
> 
> 

Seems straightforward. I do question whether this will make any
different for performance, but it's unlikely to hurt anything, and it's
nice to separate the "unlink" and "free" functions.

Reviewed-by: Jeff Layton <jlayton@kernel.org>

  reply	other threads:[~2023-07-10 13:10 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-07-09 15:45 [PATCH v1 0/6] Fix some lock contention in the NFS server's DRC Chuck Lever
2023-07-09 15:45 ` [PATCH v1 1/6] NFSD: Refactor nfsd_reply_cache_free_locked() Chuck Lever
2023-07-10 13:09   ` Jeff Layton [this message]
2023-07-09 15:45 ` [PATCH v1 2/6] NFSD: Rename nfsd_reply_cache_alloc() Chuck Lever
2023-07-09 15:45 ` [PATCH v1 3/6] NFSD: Replace nfsd_prune_bucket() Chuck Lever
2023-07-09 15:45 ` [PATCH v1 4/6] NFSD: Refactor the duplicate reply cache shrinker Chuck Lever
2023-07-09 15:45 ` [PATCH v1 5/6] NFSD: Remove svc_rqst::rq_cacherep Chuck Lever
2023-07-10 13:17   ` Jeff Layton
2023-07-09 15:45 ` [PATCH v1 6/6] NFSD: Rename struct svc_cacherep Chuck Lever
2023-07-10 13:03 ` [PATCH v1 0/6] Fix some lock contention in the NFS server's DRC Jeff Layton
2023-07-10 13:47   ` Chuck Lever III
2023-07-10 13:19 ` Jeff Layton

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=0ad01b423530a0aaef70a847dd82e9fca88daed5.camel@kernel.org \
    --to=jlayton@kernel.org \
    --cc=cel@kernel.org \
    --cc=chuck.lever@oracle.com \
    --cc=linux-nfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox