Linux NFS development
 help / color / mirror / Atom feed
From: Jeff Layton <jlayton@kernel.org>
To: NeilBrown <neil@brown.name>, Chuck Lever <chuck.lever@oracle.com>
Cc: Olga Kornievskaia <okorniev@redhat.com>,
	Dai Ngo <Dai.Ngo@oracle.com>,  Tom Talpey <tom@talpey.com>,
	linux-nfs@vger.kernel.org
Subject: Re: [PATCH v5 00/18] nfsd: refactor nfs4_create_file()
Date: Fri, 17 Jul 2026 07:29:29 -0400	[thread overview]
Message-ID: <1a8a163c9ad06d83b2be9d0083303bc28596bf1a.camel@kernel.org> (raw)
In-Reply-To: <20260717093001.1972119-1-neilb@ownmail.net>

On Fri, 2026-07-17 at 19:27 +1000, NeilBrown wrote:
> For for another version so soon - I hadn't noticed Jeff's LLM results.
> Most of the issue raised there were already addressed I think, but the
> using  nfserr_noent instead of NFSERR_NOENT, and adding a condition on
> the call to mnt_want_write() in the final patch were still needed.
> 
> Thanks,
> NeilBrown
> 
> 
>  [PATCH v5 01/18] nfsd: honour client-provided attributes for
>  [PATCH v5 02/18] nfsd: move check_nfsd_access() call into
>  [PATCH v5 03/18] nfsd: correctly handle CREATE of mounted-on files
>  [PATCH v5 04/18] nfsd: replace fh_fill_both_attrs() with
>  [PATCH v5 05/18] nfsd: move fh_want_write() after preamble in
>  [PATCH v5 06/18] nfsd: move more nfs-specific code into preamble of
>  [PATCH v5 07/18] nfsd: remove subtlety from nfsd4_create_file()
>  [PATCH v5 08/18] nfsd: in nfsd4_create_file() let VFS report if file
>  [PATCH v5 09/18] nfsd: nfsd4_create_file(): Move NFSD_MAY_CREATE
>  [PATCH v5 10/18] nfsd: fh_want_write) failure need not be immediately
>  [PATCH v5 11/18] nfsd: (almost) always open file in
>  [PATCH v5 12/18] nfsd: reduce range of directory lock in
>  [PATCH v5 13/18] nfsd: open-code nfsd4_vfs_create() into
>  [PATCH v5 14/18] nfsd: move some code out of the
>  [PATCH v5 15/18] nfsd: reduce want-write range in nfsd4_create_file()
>  [PATCH v5 16/18] nfsd: move v0 checking out of nfsd_check_obj_isreg()
>  [PATCH v5 17/18] nfsd: separate out VFS-specific code from
>  [PATCH v5 18/18] nfsd: use do_lookup_open() for non-creating open

Nice work, Neil. You can add this to any that don't already have it:

Reviewed-by: Jeff Layton <jlayton@kernel.org>

  parent reply	other threads:[~2026-07-17 11:29 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-17  9:27 [PATCH v5 00/18] nfsd: refactor nfs4_create_file() NeilBrown
2026-07-17  9:27 ` [PATCH v5 01/18] nfsd: honour client-provided attributes for NFS4_CREATE_EXCLUSIVE4_1 NeilBrown
2026-07-17  9:27 ` [PATCH v5 02/18] nfsd: move check_nfsd_access() call into nfsd_cross_mnt() NeilBrown
2026-07-17  9:27 ` [PATCH v5 03/18] nfsd: correctly handle CREATE of mounted-on files NeilBrown
2026-07-17  9:27 ` [PATCH v5 04/18] nfsd: replace fh_fill_both_attrs() with fh_fill_post_noop() NeilBrown
2026-07-17  9:27 ` [PATCH v5 05/18] nfsd: move fh_want_write() after preamble in nfsd4_create_file() NeilBrown
2026-07-17  9:27 ` [PATCH v5 06/18] nfsd: move more nfs-specific code into preamble of nfsd4_create_file() NeilBrown
2026-07-17  9:27 ` [PATCH v5 07/18] nfsd: remove subtlety from nfsd4_create_file() NeilBrown
2026-07-17  9:27 ` [PATCH v5 08/18] nfsd: in nfsd4_create_file() let VFS report if file was created NeilBrown
2026-07-17  9:27 ` [PATCH v5 09/18] nfsd: nfsd4_create_file(): Move NFSD_MAY_CREATE check earlier NeilBrown
2026-07-17  9:27 ` [PATCH v5 10/18] nfsd: fh_want_write) failure need not be immediately fatal for nfsd4_create_file() NeilBrown
2026-07-17  9:27 ` [PATCH v5 11/18] nfsd: (almost) always open file in nfsd4_create_file() NeilBrown
2026-07-17  9:28 ` [PATCH v5 12/18] nfsd: reduce range of directory lock " NeilBrown
2026-07-17  9:28 ` [PATCH v5 13/18] nfsd: open-code nfsd4_vfs_create() into nfsd4_create_file() NeilBrown
2026-07-17  9:28 ` [PATCH v5 14/18] nfsd: move some code out of the d_really_is_negative() branch in nfsd4_create_file() NeilBrown
2026-07-17  9:28 ` [PATCH v5 15/18] nfsd: reduce want-write range " NeilBrown
2026-07-17  9:28 ` [PATCH v5 16/18] nfsd: move v0 checking out of nfsd_check_obj_isreg() NeilBrown
2026-07-17  9:28 ` [PATCH v5 17/18] nfsd: separate out VFS-specific code from nfsd4_create_file() NeilBrown
2026-07-17  9:28 ` [PATCH v5 18/18] nfsd: use do_lookup_open() for non-creating open requests too NeilBrown
2026-08-12 17:12   ` Jeff Layton
2026-07-17 11:29 ` Jeff Layton [this message]
2026-07-17 13:30 ` [PATCH v5 00/18] nfsd: refactor nfs4_create_file() Chuck Lever

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1a8a163c9ad06d83b2be9d0083303bc28596bf1a.camel@kernel.org \
    --to=jlayton@kernel.org \
    --cc=Dai.Ngo@oracle.com \
    --cc=chuck.lever@oracle.com \
    --cc=linux-nfs@vger.kernel.org \
    --cc=neil@brown.name \
    --cc=okorniev@redhat.com \
    --cc=tom@talpey.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox