linux-nfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2022-02-23 21:32:45 to 2022-03-01 15:35:16 UTC [more...]

[BUG] FS-Cache write but no read when using sync
 2022-03-01 15:34 UTC  (2+ messages)

[PATCH v2 0/2] nfsuuid and udev examples
 2022-03-01 15:16 UTC  (21+ messages)
` [PATCH v2 1/2] nfsuuid: a tool to create and persist nfs4 client uniquifiers
                                  ` [PATCH] nfs.man: document requirements for NFS mounts in a container

[PATCH 00/11] Remove remaining parts of congestion tracking code
 2022-03-01 13:27 UTC  (9+ messages)
` [PATCH 03/11] MM: improve cleanup when ->readpages doesn't process all pages
` [PATCH 06/11] ceph: remove reliance on bdi congestion
` [PATCH 04/11] fuse: "

[PATCH RFC v14 0/10] NFSD: Initial implementation of NFSv4 Courteous Server
 2022-02-28 21:11 UTC  (12+ messages)
` [PATCH RFC v14 02/10] NFSD: Add lm_lock_expired call out
` [PATCH RFC v14 04/10] NFSD: Update nfs4_get_vfs_file() to handle courtesy clients
` [PATCH RFC v14 05/10] NFSD: Update find_clp_in_name_tree() "
` [PATCH RFC v14 09/10] NFSD: Update laundromat "

[PATCH] NFSv4: Tune the race to set and use the client id uniquifier
 2022-02-28 21:11 UTC  (9+ messages)

[RFC PATCH 0/3] approach to deal with changes in trunking membership
 2022-02-28 20:38 UTC  (4+ messages)
` [RFC PATCH 1/3] SUNRPC provide accessible functions for offline remote xprt functionality
` [RFC PATCH 2/3] SUNRPC add function to offline remote trunkable transports
` [RFC PATCH 3/3] NFSv4.1 destroy trunkable transport when destroying the session

managing trunking
 2022-02-28 20:37 UTC  (3+ messages)

exportfs recursively processes backslash escapes in exports file
 2022-02-28 19:32 UTC 

[PATCH] mountd: Fix potential data corrupter
 2022-02-28 20:26 UTC  (2+ messages)

[PATCH] systemd: Fix format-overflow warning
 2022-02-28 20:25 UTC  (2+ messages)

[PATCH] NFSv4: use unique client identifiers in network namespaces
 2022-02-28 15:33 UTC  (7+ messages)

[PATCH v6 00/16] Optimize list lru memory consumption
 2022-02-28 12:21 UTC  (17+ messages)
` [PATCH v6 01/16] mm: list_lru: transpose the array of per-node per-memcg lru lists
` [PATCH v6 02/16] mm: introduce kmem_cache_alloc_lru
` [PATCH v6 03/16] fs: introduce alloc_inode_sb() to allocate filesystems specific inode
` [PATCH v6 04/16] fs: allocate inode by using alloc_inode_sb()
` [PATCH v6 05/16] f2fs: "
` [PATCH v6 06/16] nfs42: use a specific kmem_cache to allocate nfs4_xattr_entry
` [PATCH v6 07/16] mm: dcache: use kmem_cache_alloc_lru() to allocate dentry
` [PATCH v6 08/16] xarray: use kmem_cache_alloc_lru to allocate xa_node
` [PATCH v6 09/16] mm: memcontrol: move memcg_online_kmem() to mem_cgroup_css_online()
` [PATCH v6 10/16] mm: list_lru: allocate list_lru_one only when needed
` [PATCH v6 11/16] mm: list_lru: rename memcg_drain_all_list_lrus to memcg_reparent_list_lrus
` [PATCH v6 12/16] mm: list_lru: replace linear array with xarray
` [PATCH v6 13/16] mm: memcontrol: reuse memory cgroup ID for kmem ID
` [PATCH v6 14/16] mm: memcontrol: fix cannot alloc the maximum memcg ID
` [PATCH v6 15/16] mm: list_lru: rename list_lru_per_memcg to list_lru_memcg
` [PATCH v6 16/16] mm: memcontrol: rename memcg_cache_id to memcg_kmem_id

[PATCH 00/11] Remove remaining parts of congestion tracking code
 2022-02-28  5:19 UTC  (10+ messages)
` [PATCH 02/11] MM: document and polish read-ahead code
` [PATCH 08/11] Remove bdi_congested() and wb_congested() and related functions

[PATCH v10 00/13] create sysfs files for changing IP address
 2022-02-28  3:00 UTC  (3+ messages)
` [PATCH v10 10/13] sunrpc: add dst_attr attributes to the sysfs xprt directory

[PATCH 1/2] Convert NFS from readpages to readahead
 2022-02-28  1:29 UTC  (6+ messages)

[PATCH/RFC] VFS: support parallel updates in the one directory
 2022-02-28  0:55 UTC  (12+ messages)

[PATCH v9 00/27] Readdir improvements
 2022-02-27 23:12 UTC  (28+ messages)
` [PATCH v9 01/27] NFS: Return valid errors from nfs2/3_decode_dirent()
  ` [PATCH v9 02/27] NFS: constify nfs_server_capable() and nfs_have_writebacks()
    ` [PATCH v9 03/27] NFS: Trace lookup revalidation failure
      ` [PATCH v9 04/27] NFS: Initialise the readdir verifier as best we can in nfs_opendir()
        ` [PATCH v9 05/27] NFS: Use kzalloc() to avoid initialising the nfs_open_dir_context
          ` [PATCH v9 06/27] NFS: Calculate page offsets algorithmically
            ` [PATCH v9 07/27] NFS: Store the change attribute in the directory page cache
              ` [PATCH v9 08/27] NFS: Don't re-read the entire page cache to find the next cookie
                ` [PATCH v9 09/27] NFS: Don't advance the page pointer unless the page is full
                  ` [PATCH v9 10/27] NFS: Adjust the amount of readahead performed by NFS readdir
                    ` [PATCH v9 11/27] NFS: If the cookie verifier changes, we must invalidate the page cache
                      ` [PATCH v9 12/27] NFS: Simplify nfs_readdir_xdr_to_array()
                        ` [PATCH v9 13/27] NFS: Reduce use of uncached readdir
                          ` [PATCH v9 14/27] NFS: Improve heuristic for readdirplus
                            ` [PATCH v9 15/27] NFS: Don't ask for readdirplus unless it can help nfs_getattr()
                              ` [PATCH v9 16/27] NFSv4: Ask for a full XDR buffer of readdir goodness
                                ` [PATCH v9 17/27] NFS: Readdirplus can't help lookup for case insensitive filesystems
                                  ` [PATCH v9 18/27] NFS: Don't request readdirplus when revalidation was forced
                                    ` [PATCH v9 19/27] NFS: Add basic readdir tracing
                                      ` [PATCH v9 20/27] NFS: Trace effects of readdirplus on the dcache
                                        ` [PATCH v9 21/27] NFS: Trace effects of the readdirplus heuristic
                                          ` [PATCH v9 22/27] NFS: Clean up page array initialisation/free
                                            ` [PATCH v9 23/27] NFS: Convert readdir page cache to use a cookie based index
                                              ` [PATCH v9 24/27] NFS: Fix up forced readdirplus
                                                ` [PATCH v9 25/27] NFS: Remove unnecessary cache invalidations for directories
                                                  ` [PATCH v9 26/27] NFS: Optimise away the previous cookie field
                                                    ` [PATCH v9 27/27] NFS: Cache all entries in the readdirplus reply

[PATCH v2] nfsd: more robust allocation failure handling in nfsd_file_cache_init
 2022-02-26 20:00 UTC  (8+ messages)

[PATCH v1] NFSv4.1 provide mount option to toggle trunking discovery
 2022-02-25 22:48 UTC  (9+ messages)

[PATCH v7 00/21] Readdir improvements
 2022-02-25 22:29 UTC  (55+ messages)
` [PATCH v7 01/21] NFS: constify nfs_server_capable() and nfs_have_writebacks()
  ` [PATCH v7 02/21] NFS: Trace lookup revalidation failure
    ` [PATCH v7 03/21] NFS: Use kzalloc() to avoid initialising the nfs_open_dir_context
      ` [PATCH v7 04/21] NFS: Calculate page offsets algorithmically
        ` [PATCH v7 05/21] NFS: Store the change attribute in the directory page cache
          ` [PATCH v7 06/21] NFS: If the cookie verifier changes, we must invalidate the "
            ` [PATCH v7 07/21] NFS: Don't re-read the entire page cache to find the next cookie
              ` [PATCH v7 08/21] NFS: Adjust the amount of readahead performed by NFS readdir
                ` [PATCH v7 09/21] NFS: Simplify nfs_readdir_xdr_to_array()
                  ` [PATCH v7 10/21] NFS: Reduce use of uncached readdir
                    ` [PATCH v7 11/21] NFS: Improve heuristic for readdirplus
                      ` [PATCH v7 12/21] NFS: Don't ask for readdirplus unless it can help nfs_getattr()
                        ` [PATCH v7 13/21] NFSv4: Ask for a full XDR buffer of readdir goodness
                          ` [PATCH v7 14/21] NFS: Readdirplus can't help lookup for case insensitive filesystems
                            ` [PATCH v7 15/21] NFS: Don't request readdirplus when revalidation was forced
                              ` [PATCH v7 16/21] NFS: Add basic readdir tracing
                                ` [PATCH v7 17/21] NFS: Trace effects of readdirplus on the dcache
                                  ` [PATCH v7 18/21] NFS: Trace effects of the readdirplus heuristic
                                    ` [PATCH v7 19/21] NFS: Convert readdir page cache to use a cookie based index

[PATCH v8 00/24] Readdir improvements
 2022-02-25 18:28 UTC  (25+ messages)
` [PATCH v8 01/24] NFS: Return valid errors from nfs2/3_decode_dirent()
  ` [PATCH v8 02/24] NFS: constify nfs_server_capable() and nfs_have_writebacks()
    ` [PATCH v8 03/24] NFS: Trace lookup revalidation failure
      ` [PATCH v8 04/24] NFS: Initialise the readdir verifier as best we can in nfs_opendir()
        ` [PATCH v8 05/24] NFS: Use kzalloc() to avoid initialising the nfs_open_dir_context
          ` [PATCH v8 06/24] NFS: Calculate page offsets algorithmically
            ` [PATCH v8 07/24] NFS: Store the change attribute in the directory page cache
              ` [PATCH v8 08/24] NFS: If the cookie verifier changes, we must invalidate the "
                ` [PATCH v8 09/24] NFS: Don't re-read the entire page cache to find the next cookie
                  ` [PATCH v8 10/24] NFS: Adjust the amount of readahead performed by NFS readdir
                    ` [PATCH v8 11/24] NFS: Simplify nfs_readdir_xdr_to_array()
                      ` [PATCH v8 12/24] NFS: Reduce use of uncached readdir
                        ` [PATCH v8 13/24] NFS: Improve heuristic for readdirplus
                          ` [PATCH v8 14/24] NFS: Don't ask for readdirplus unless it can help nfs_getattr()
                            ` [PATCH v8 15/24] NFSv4: Ask for a full XDR buffer of readdir goodness
                              ` [PATCH v8 16/24] NFS: Readdirplus can't help lookup for case insensitive filesystems
                                ` [PATCH v8 17/24] NFS: Don't request readdirplus when revalidation was forced
                                  ` [PATCH v8 18/24] NFS: Add basic readdir tracing
                                    ` [PATCH v8 19/24] NFS: Trace effects of readdirplus on the dcache
                                      ` [PATCH v8 20/24] NFS: Trace effects of the readdirplus heuristic
                                        ` [PATCH v8 21/24] NFS: Convert readdir page cache to use a cookie based index
                                          ` [PATCH v8 22/24] NFS: Fix up forced readdirplus
                                            ` [PATCH v8 23/24] NFS: Remove unnecessary cache invalidations for directories
                                              ` [PATCH v8 24/24] NFS: Cache all entries in the readdirplus reply

Wycena paneli fotowoltaicznych
 2022-02-25  7:45 UTC 

[PATCH] nfsd: more robust allocation failure handling in nfsd_file_cache_init
 2022-02-24 16:10 UTC  (3+ messages)

linux-next: Tree for Feb 22 (NFSD_V2_ACL)
 2022-02-24 16:45 UTC  (6+ messages)

nfsd: unable to allocate nfsd_file_hashtbl
 2022-02-24 16:08 UTC  (5+ messages)

Ruch z pierwszej pozycji w Google
 2022-02-24  9:05 UTC 

[bug?] nfs setgid inheritance
 2022-02-24  9:06 UTC  (8+ messages)

6f283634 / 1976b2b3 breaks NFS (QNAP/Linux kNFSD)
 2022-02-24  8:17 UTC  (16+ messages)

[PATCH 0/4] Improvements for NFS
 2022-02-24  4:15 UTC  (9+ messages)
` [PATCH 2/4] generic/531: Move test from 'quick' group to 'stress'
` [PATCH 3/4] generic/578: Test that filefrag is supported before running

[PATCH v6 00/13] Readdir improvements
 2022-02-23 21:31 UTC  (18+ messages)
` [PATCH v6 01/13] NFS: constify nfs_server_capable() and nfs_have_writebacks()
  ` [PATCH v6 02/13] NFS: Trace lookup revalidation failure
    ` [PATCH v6 03/13] NFS: Adjust the amount of readahead performed by NFS readdir
      ` [PATCH v6 04/13] NFS: Simplify nfs_readdir_xdr_to_array()
        ` [PATCH v6 05/13] NFS: Improve algorithm for falling back to uncached readdir


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).