messages from 2024-08-12 22:37:54 to 2024-08-21 17:34:57 UTC [more...]
[RFC PATCH 0/2] xdrgen - machine-generated XDR functions
2024-08-21 17:34 UTC (12+ messages)
` [RFC PATCH 1/2] tools: Add xdrgen
` [RFC PATCH 2/2] NFSD: Create an initial nfs4_1.x file
[PATCH -next] nfsd: use LIST_HEAD() to simplify code
2024-08-21 17:20 UTC (2+ messages)
ANNOUNCE: nfs-utils-2.7.1 released
2024-08-21 17:02 UTC
[PATCH] nfs: fix the fetch of FATTR4_OPEN_ARGUMENTS
2024-08-21 16:18 UTC (5+ messages)
[PATCH] nfs: fix bitmap decoder to handle a 3rd word
2024-08-21 15:53 UTC (5+ messages)
[PATCH v2] nfs: fix bitmap decoder to handle a 3rd word
2024-08-21 15:44 UTC (2+ messages)
[PATCH 5.15.y 00/18] Backport "make svc_stat per-net instead of global"
2024-08-21 14:55 UTC (19+ messages)
` [PATCH 5.15.y 01/18] nfsd: move reply cache initialization into nfsd startup
` [PATCH 5.15.y 02/18] nfsd: move init of percpu reply_cache_stats counters back to nfsd_init_net
` [PATCH 5.15.y 03/18] NFSD: Refactor nfsd_reply_cache_free_locked()
` [PATCH 5.15.y 04/18] NFSD: Rename nfsd_reply_cache_alloc()
` [PATCH 5.15.y 05/18] NFSD: Replace nfsd_prune_bucket()
` [PATCH 5.15.y 06/18] NFSD: Refactor the duplicate reply cache shrinker
` [PATCH 5.15.y 07/18] NFSD: Rewrite synopsis of nfsd_percpu_counters_init()
` [PATCH 5.15.y 08/18] NFSD: Fix frame size warning in svc_export_parse()
` [PATCH 5.15.y 09/18] sunrpc: don't change ->sv_stats if it doesn't exist
` [PATCH 5.15.y 10/18] nfsd: stop setting ->pg_stats for unused stats
` [PATCH 5.15.y 11/18] sunrpc: pass in the sv_stats struct through svc_create_pooled
` [PATCH 5.15.y 12/18] sunrpc: remove ->pg_stats from svc_program
` [PATCH 5.15.y 13/18] sunrpc: use the struct net as the svc proc private
` [PATCH 5.15.y 14/18] nfsd: rename NFSD_NET_* to NFSD_STATS_*
` [PATCH 5.15.y 15/18] nfsd: expose /proc/net/sunrpc/nfsd in net namespaces
` [PATCH 5.15.y 16/18] nfsd: make all of the nfsd stats per-network namespace
` [PATCH 5.15.y 17/18] nfsd: remove nfsd_stats, make th_cnt a global counter
` [PATCH 5.15.y 18/18] nfsd: make svc_stat per-network namespace instead of global
[PATCH v2] fs/exfat: add NFS export support
2024-08-21 14:08 UTC (2+ messages)
[PATCH] nfsd: call cache_put if xdr_reserve_space returns NULL
2024-08-21 14:03 UTC
[PATCH net-next v13 04/14] mm: page_frag: add '_va' suffix to page_frag API
2024-08-21 12:30 UTC (9+ messages)
[PATCH 0/4] mm, netfs, afs: Truncation fixes
2024-08-20 23:20 UTC (5+ messages)
` [PATCH 1/4] mm: Fix missing folio invalidation calls during truncation
` [PATCH 2/4] afs: Fix post-setattr file edit to do truncation correctly
` [PATCH 3/4] netfs: Fix netfs_release_folio() to say no if folio dirty
` [PATCH 4/4] netfs: Fix trimming of streaming-write folios in netfs_inval_folio()
[PATCH] MAINTAINERS: Update Olga Kornievskaia's email address
2024-08-20 20:09 UTC
[linus:master] [9p] e3786b29c5: xfstests.generic.465.fail
2024-08-20 13:03 UTC (2+ messages)
[PATCH 0/3] nfsd: implement OPEN_XOR_DELEGATION part of delstid draft
2024-08-20 12:18 UTC (17+ messages)
` [PATCH 1/3] nfsd: bring in support for delstid draft XDR encoding
` [PATCH 2/3] nfsd: add support for FATTR4_OPEN_ARGUMENTS
` [PATCH 3/3] nfsd: implement OPEN_ARGS_SHARE_ACCESS_WANT_OPEN_XOR_DELEGATION
[PATCH] fs/exfat: add NFS export support
2024-08-19 23:41 UTC (5+ messages)
[PATCH v12 00/24] nfs/nfsd: add support for localio
2024-08-19 18:43 UTC (27+ messages)
` [PATCH v12 01/24] nfs_common: factor out nfs_errtbl and nfs_stat_to_errno
` [PATCH v12 02/24] nfs_common: factor out nfs4_errtbl and nfs4_stat_to_errno
` [PATCH v12 03/24] nfs: factor out {encode,decode}_opaque_fixed to nfs_xdr.h
` [PATCH v12 04/24] nfsd: factor out __fh_verify to allow NULL rqstp to be passed
` [PATCH v12 05/24] nfsd: fix nfsfh tracepoints to properly handle NULL rqstp
` [PATCH v12 06/24] nfsd: add nfsd_file_acquire_local()
` [PATCH v12 07/24] SUNRPC: remove call_allocate() BUG_ONs
` [PATCH v12 08/24] SUNRPC: add rpcauth_map_clnt_to_svc_cred_local
` [PATCH v12 09/24] nfs_common: add NFS LOCALIO auxiliary protocol enablement
` [PATCH v12 10/24] nfsd: add localio support
` [PATCH v12 11/24] nfsd: implement server support for NFS_LOCALIO_PROGRAM
` [PATCH v12 12/24] SUNRPC: replace program list with program array
` [PATCH v12 13/24] nfs: pass struct file to nfs_init_pgio and nfs_init_commit
` [PATCH v12 14/24] nfs: add localio support
` [PATCH v12 15/24] nfs: enable localio for non-pNFS IO
` [PATCH v12 16/24] pnfs/flexfiles: enable localio support
` [PATCH v12 17/24] nfs/localio: use dedicated workqueues for filesystem read and write
` [PATCH v12 18/24] nfs: implement client support for NFS_LOCALIO_PROGRAM
` [PATCH v12 19/24] nfs: add Documentation/filesystems/nfs/localio.rst
` [PATCH v12 20/24] nfsd: use GC for nfsd_file returned by nfsd_file_acquire_local
` [PATCH v12 21/24] nfs_common: expose localio's required nfsd symbols to nfs client
` [PATCH v12 22/24] nfs: push localio nfsd_file_put call out to client
` [PATCH v12 23/24] nfs: switch client to use nfsd_file for localio
` [PATCH v12 24/24] nfs: add FAQ section to Documentation/filesystems/nfs/localio.rst
[PATCH v2] SUNRPC: convert RPC_TASK_* constants to enum
2024-08-19 15:58 UTC
[PATCH] nfs: add 'noalignwrite' option for lock-less 'lost writes' prevention
2024-08-19 11:18 UTC (2+ messages)
[PATCH] NFS/flexfiles: Replace one-element array with flexible-array member
2024-08-17 21:17 UTC (3+ messages)
[PATCH] nfsd: map the EBADMSG to nfserr_io to avoid warning
2024-08-17 15:47 UTC (3+ messages)
`rcu: INFO: rcu_sched self-detected stall on CPU` and spinning kworker `rpciod`
2024-08-17 14:52 UTC (7+ messages)
[PATCH 0/1] SUNRPC: convert RPC_TASK_* constants to enum
2024-08-16 23:12 UTC (4+ messages)
` [PATCH 1/1] "
[PATCH] SUNRPC: Fix -Wformat-truncation warning
2024-08-16 23:07 UTC (7+ messages)
[PATCH 1/1] rpcdebug: fix memory allocation size
2024-08-16 13:49 UTC (2+ messages)
[PATCH v2 00/25] netfs: Read/write improvements
2024-08-16 11:12 UTC (28+ messages)
` [PATCH v2 01/25] netfs, ceph: Partially revert "netfs: Replace PG_fscache by setting folio->private and marking dirty"
` [PATCH v2 02/25] cachefiles: Fix non-taking of sb_writers around set/removexattr
` [PATCH v2 03/25] netfs: Adjust labels in /proc/fs/netfs/stats
` [PATCH v2 04/25] netfs: Record contention stats for writeback lock
` [PATCH v2 05/25] netfs: Reduce number of conditional branches in netfs_perform_write()
` [PATCH v2 06/25] netfs, cifs: Move CIFS_INO_MODIFIED_ATTR to netfs_inode
` [PATCH v2 07/25] netfs: Move max_len/max_nr_segs from netfs_io_subrequest to netfs_io_stream
` [PATCH v2 08/25] netfs: Reserve netfs_sreq_source 0 as unset/unknown
` [PATCH v2 09/25] netfs: Remove NETFS_COPY_TO_CACHE
` [PATCH v2 10/25] netfs: Set the request work function upon allocation
` [PATCH v2 11/25] netfs: Use bh-disabling spinlocks for rreq->lock
` [PATCH v2 12/25] mm: Define struct folio_queue and ITER_FOLIOQ to handle a sequence of folios
` [PATCH v2 13/25] iov_iter: Provide copy_folio_from_iter()
` [PATCH v2 14/25] cifs: Provide the capability to extract from ITER_FOLIOQ to RDMA SGEs
` [PATCH v2 15/25] netfs: Use new folio_queue data type and iterator instead of xarray iter
` [PATCH v2 16/25] netfs: Provide an iterator-reset function
` [PATCH v2 17/25] netfs: Simplify the writeback code
` [PATCH v2 18/25] afs: Make read subreqs async
` [PATCH v2 19/25] netfs: Speed up buffered reading
` [PATCH v2 20/25] netfs: Remove fs/netfs/io.c
` [PATCH v2 21/25] cachefiles, netfs: Fix write to partial block at EOF
` [PATCH v2 22/25] netfs: Cancel dirty folios that have no storage destination
` [PATCH v2 23/25] cifs: Use iterate_and_advance*() routines directly for hashing
` [PATCH v2 24/25] cifs: Switch crypto buffer to use a folio_queue rather than an xarray
` [PATCH v2 25/25] cifs: Don't support ITER_XARRAY
[linus:master] [nfs] 49b29a573d: filebench.sum_operations/s -85.6% regression
2024-08-16 2:11 UTC (7+ messages)
[PATCH v2] SUNRPC: Fix -Wformat-truncation warning
2024-08-16 2:07 UTC
nfs4 delegation - couple of questions - 6.10.3-custom kernel
2024-08-15 10:04 UTC (4+ messages)
[PATCH 6.1.y 00/18] Backport "make svc_stat per-net instead of global"
2024-08-15 8:27 UTC (2+ messages)
[PATCH 6.6.y 00/12] Backport "make svc_stat per-net instead of global"
2024-08-15 8:25 UTC (10+ messages)
` [PATCH 6.6.y 10/12] nfsd: make all of the nfsd stats per-network namespace
` [PATCH 6.6.y 11/12] nfsd: remove nfsd_stats, make th_cnt a global counter
` [PATCH 6.6.y 12/12] nfsd: make svc_stat per-network namespace instead of global
[LTP] [PATCH 1/1] nfsstat01: Update client RPC calls for kernel 6.9
2024-08-15 6:53 UTC (5+ messages)
[PATCH] NFSD: remove redundant assignment operation
2024-08-14 13:35 UTC (3+ messages)
[PATCH v2] SQUASH: nfsd: move error choice for incorrect object types to version-specific code
2024-08-14 13:31 UTC (3+ messages)
[PATCH v2 1/1] nfsstat01: Update client RPC calls for kernel 6.9
2024-08-14 13:13 UTC (2+ messages)
[PATCH] nfs: Annotate struct nfs_cache_array with __counted_by()
2024-08-14 10:01 UTC
[PATCH RESEND v2 1/1] nfsstat01: Update client RPC calls for kernel 6.9
2024-08-14 9:30 UTC
[PATCH] SQUASH: nfsd: move error choice for incorrect object types to version-specific code
2024-08-14 5:01 UTC (3+ messages)
[Bug report] NFS patch breaks TLS device-offloaded TX zerocopy
2024-08-12 23:23 UTC (8+ messages)
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox