From mboxrd@z Thu Jan 1 00:00:00 1970 From: Jiro SEKIBA Subject: [PATCH 0/3] v2: write_super clean up Date: Sun, 19 Jul 2009 14:26:19 +0900 Message-ID: <1247981182-14831-1-git-send-email-jir@unicus.jp> Reply-To: NILFS Users mailing list Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: users-bounces-JrjvKiOkagjYtjvyW6yDsg@public.gmane.org Errors-To: users-bounces-JrjvKiOkagjYtjvyW6yDsg@public.gmane.org To: users-JrjvKiOkagjYtjvyW6yDsg@public.gmane.org Cc: Jiro SEKIBA Hi, this is revised version of write_super clean up patch. It reflects most of Konishi-san's comment, except the nilfs_discontined() inline functions to be renamed. That inline funcion is one of inline functions defined by single macro. So as Konishi-san said, I'd rather like to rename it as separate patch. Any comments and suggestions are appreciate. Thanks, regards, fs/nilfs2/segment.c | 12 +++++++++++- fs/nilfs2/super.c | 16 +++++++--------- fs/nilfs2/the_nilfs.h | 12 ++++++++++++ 3 files changed, 30 insertions(+), 10 deletions(-) -- Jiro SEKIBA