Linux-NVDIMM Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Joe Perches <joe@perches.com>
To: Christoph Hellwig <hch@lst.de>,
	Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
	Amir Goldstein <amir73il@gmail.com>,
	linux-fsdevel@vger.kernel.org
Cc: linux-xfs@vger.kernel.org, linux-raid@vger.kernel.org,
	linux-nvdimm@lists.01.org, Shaohua Li <shli@kernel.org>,
	linux-kernel@vger.kernel.org, David Howells <dhowells@redhat.com>,
	Mimi Zohar <zohar@linux.vnet.ibm.com>,
	Steven Whitehouse <swhiteho@redhat.com>
Subject: Re: [PATCH 03/23] uuid: remove uuid_be defintions from the uapi header
Date: Thu, 18 May 2017 00:12:45 -0700	[thread overview]
Message-ID: <1495091565.31562.28.camel@perches.com> (raw)
In-Reply-To: <20170518062705.25902-4-hch@lst.de>

On Thu, 2017-05-18 at 08:26 +0200, Christoph Hellwig wrote:
> We don't use uuid_be and the UUID_BE constants in any uapi headers, so make
> them private to the kernel.

On the assumption that no user program uses them?
Is that a safe assumption?

> diff --git a/include/uapi/linux/uuid.h b/include/uapi/linux/uuid.h
> index 3738e5fb6a4d..0099756c4bac 100644
> --- a/include/uapi/linux/uuid.h
> +++ b/include/uapi/linux/uuid.h
> @@ -24,10 +24,6 @@ typedef struct {
>  	__u8 b[16];
>  } uuid_le;
>  
> -typedef struct {
> -	__u8 b[16];
> -} uuid_be;
> -
>  #define UUID_LE(a, b, c, d0, d1, d2, d3, d4, d5, d6, d7)		\
>  ((uuid_le)								\
>  {{ (a) & 0xff, ((a) >> 8) & 0xff, ((a) >> 16) & 0xff, ((a) >> 24) & 0xff, \
> @@ -35,20 +31,8 @@ typedef struct {
>     (c) & 0xff, ((c) >> 8) & 0xff,					\
>     (d0), (d1), (d2), (d3), (d4), (d5), (d6), (d7) }})
>  
> -#define UUID_BE(a, b, c, d0, d1, d2, d3, d4, d5, d6, d7)		\
> -((uuid_be)								\
> -{{ ((a) >> 24) & 0xff, ((a) >> 16) & 0xff, ((a) >> 8) & 0xff, (a) & 0xff, \
> -   ((b) >> 8) & 0xff, (b) & 0xff,					\
> -   ((c) >> 8) & 0xff, (c) & 0xff,					\
> -   (d0), (d1), (d2), (d3), (d4), (d5), (d6), (d7) }})
> -
>  #define NULL_UUID_LE							\
>  	UUID_LE(0x00000000, 0x0000, 0x0000, 0x00, 0x00, 0x00, 0x00,	\
>  		0x00, 0x00, 0x00, 0x00)
>  
> -#define NULL_UUID_BE							\
> -	UUID_BE(0x00000000, 0x0000, 0x0000, 0x00, 0x00, 0x00, 0x00,	\
> -		0x00, 0x00, 0x00, 0x00)
> -
> -
>  #endif /* _UAPI_LINUX_UUID_H_ */
_______________________________________________
Linux-nvdimm mailing list
Linux-nvdimm@lists.01.org
https://lists.01.org/mailman/listinfo/linux-nvdimm

  reply	other threads:[~2017-05-18  7:13 UTC|newest]

Thread overview: 50+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-05-18  6:26 cleanup UUID types V3 Christoph Hellwig
2017-05-18  6:26 ` [PATCH 01/23] xfs: use uuid_copy() helper to abstract uuid_t Christoph Hellwig
2017-05-18 13:27   ` Brian Foster
     [not found]   ` <20170518062705.25902-2-hch-jcswGhMUV9g@public.gmane.org>
2017-05-18 23:32     ` Darrick J. Wong
2017-05-18  6:26 ` [PATCH 02/23] xfs: use uuid_be to implement the uuid_t type Christoph Hellwig
2017-05-18 13:27   ` Brian Foster
     [not found]   ` <20170518062705.25902-3-hch-jcswGhMUV9g@public.gmane.org>
2017-05-18 23:34     ` Darrick J. Wong
2017-05-18  6:26 ` [PATCH 03/23] uuid: remove uuid_be defintions from the uapi header Christoph Hellwig
2017-05-18  7:12   ` Joe Perches [this message]
2017-05-18  7:13     ` Christoph Hellwig
2017-05-19 10:58       ` David Howells
2017-05-21  6:55         ` Christoph Hellwig
2017-05-18  6:26 ` [PATCH 04/23] uuid: rename uuid types Christoph Hellwig
     [not found]   ` <20170518062705.25902-5-hch-jcswGhMUV9g@public.gmane.org>
2017-05-18 17:42     ` Darrick J. Wong
2017-05-18  6:26 ` [PATCH 05/23] uuid: don't export guid_index and uuid_index Christoph Hellwig
2017-05-18  6:26 ` [PATCH 06/23] uuid: add the v1 layout to uuid_t Christoph Hellwig
2017-05-18  6:26 ` [PATCH 07/23] uuid: hoist helpers uuid_equal() and uuid_copy() from xfs Christoph Hellwig
2017-05-18  6:26 ` [PATCH 08/23] uuid: hoist uuid_is_null() helper from libnvdimm Christoph Hellwig
2017-05-18  6:26 ` [PATCH 09/23] S390/sysinfo: use uuid_is_null instead of opencoding it Christoph Hellwig
2017-05-18  6:26 ` [PATCH 10/23] afs: switch to use uuid_t and uuid_gen Christoph Hellwig
2017-05-22 18:49   ` Andy Shevchenko
2017-05-23  8:49     ` Christoph Hellwig
2017-05-23 13:11       ` Andy Shevchenko
2017-05-25 13:00         ` Christoph Hellwig
2017-05-25 13:29           ` Andy Shevchenko
2017-05-18  6:26 ` [PATCH 11/23] uuid: remove struct uuid_v1 Christoph Hellwig
2017-05-18  6:26 ` [PATCH 12/23] xfs: remove uuid_getnodeuniq and xfs_uu_t Christoph Hellwig
2017-05-18 13:27   ` Brian Foster
     [not found]   ` <20170518062705.25902-13-hch-jcswGhMUV9g@public.gmane.org>
2017-05-18 23:35     ` Darrick J. Wong
2017-05-18  6:26 ` [PATCH 13/23] md: namespace private helper names Christoph Hellwig
2017-05-18 18:32   ` Shaohua Li
2017-05-22 18:52   ` Andy Shevchenko
2017-05-23  8:41     ` Christoph Hellwig
2017-05-18  6:26 ` [PATCH 14/23] xfs: use the common helper uuid_is_null() Christoph Hellwig
2017-05-18 13:27   ` Brian Foster
2017-05-18  6:26 ` [PATCH 15/23] block: remove blk_part_pack_uuid Christoph Hellwig
2017-05-18 23:15   ` Mimi Zohar
2017-05-18  6:26 ` [PATCH 16/23] ima/policy: switch to use uuid_t Christoph Hellwig
2017-05-18 23:16   ` Mimi Zohar
2017-05-18  6:26 ` [PATCH 17/23] fs: switch ->s_uuid to uuid_t Christoph Hellwig
2017-05-18 23:17   ` Mimi Zohar
2017-05-18  6:27 ` [PATCH 18/23] overlayfs: use uuid_t instead of uuid_be Christoph Hellwig
2017-05-18  6:27 ` [PATCH 19/23] partitions/ldm: switch to use uuid_t Christoph Hellwig
2017-05-18  6:27 ` [PATCH 20/23] sysctl: " Christoph Hellwig
2017-05-18  6:27 ` [PATCH 21/23] nvme: switch to uuid_t Christoph Hellwig
2017-05-18  6:27 ` [PATCH 22/23] scsi_debug: " Christoph Hellwig
2017-05-18  6:27 ` [PATCH 23/23] uuid: remove uuid_be Christoph Hellwig
2017-05-18  7:57   ` Amir Goldstein
2017-05-18  8:56     ` Christoph Hellwig
2017-05-22 18:59       ` Andy Shevchenko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1495091565.31562.28.camel@perches.com \
    --to=joe@perches.com \
    --cc=amir73il@gmail.com \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=dhowells@redhat.com \
    --cc=hch@lst.de \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-nvdimm@lists.01.org \
    --cc=linux-raid@vger.kernel.org \
    --cc=linux-xfs@vger.kernel.org \
    --cc=shli@kernel.org \
    --cc=swhiteho@redhat.com \
    --cc=zohar@linux.vnet.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox