From: hch@lst.de (Christoph Hellwig)
Subject: [PATCH v3 for-4.13 2/6] mlx5: move affinity hints assignments to generic code
Date: Wed, 7 Jun 2017 10:31:56 +0200 [thread overview]
Message-ID: <20170607083156.GB24876@lst.de> (raw)
In-Reply-To: <CALzJLG-SQj2OsOOjhHsMaD8gKC0JKD068L=ZjYRPBG=iwf9r8Q@mail.gmail.com>
On Wed, Jun 07, 2017@09:16:47AM +0300, Saeed Mahameed wrote:
> On Mon, Jun 5, 2017@9:35 AM, Sagi Grimberg <sagi@grimberg.me> wrote:
> > generic api takes care of spreading affinity similar to
> > what mlx5 open coded (and even handles better asymmetric
> > configurations). Ask the generic API to spread affinity
> > for us, and feed him pre_vectors that do not participate
> > in affinity settings (which is an improvement to what we
> > had before).
> >
> > The affinity assignments should match what mlx5 tried to
> > do earlier but now we do not set affinity to async, cmd
> > and pages dedicated vectors.
> >
>
> I am not sure the new assignment will match what we tried to do before
> this patch, and i would like to preserve that behavior
> from before we simply spread comp vectors to the close numa cpus first
> then to other cores uniformly.
> i.e prefer first IRQs to go to close numa cores.
>
> for example if you have 2 numa nodes each have 4 cpus, and the device
> is on 2nd numa,
> Numa 1 cpus: 0 1 2 3
> Numa 2 cpus: 4 5 6 7
>
> this should be the affinity:
>
> IRQ[0] -> cpu[4] (Numa 2)
> IRQ[1] -> cpu[5]
> IRQ[2] -> cpu[6]
> IRQ[3] -> cpu[7]
>
> IRQ[4] -> cpu[0] (Numa 1)
> IRQ[5] -> cpu[1]
> IRQ[6] -> cpu[2]
> IRQ[7] -> cpu[3]
>
> looking at irq_create_affinity_masks, and it seems not to be the case !
> "nodemask_t nodemsk = NODE_MASK_NONE;" it doesn't seem to prefer any numa node.
nodemsk is set up by get_nodes_in_cpumask. The mask you should
get with the new code is:
IRQ[0] -> cpu[0] (Numa 1)
IRQ[1] -> cpu[1]
IRQ[2] -> cpu[2]
IRQ[3] -> cpu[3]
IRQ[4] -> cpu[4] (Numa 2)
IRQ[5] -> cpu[5]
IRQ[6] -> cpu[6]
IRQ[7] -> cpu[7]
is there any reason you want to start assining vectors on the local
node? This is doable, but would complicate the code quite a bit
so it needs a good argument.
> I am sure that there is a way to force our mlx5 affinity strategy and
> override the default one with the new API.
No, there is not. The whole point is that we want to come up with
a common policy instead of each driver doing their own weird little
thing.
> > -static int mlx5e_get_cpu(struct mlx5e_priv *priv, int ix)
> > -{
> > - return cpumask_first(priv->mdev->priv.irq_info[ix].mask);
> > -}
> >
>
> let's keep this abstraction, even let's consider moving this to a
> helper function in the mlx5_core dirver main.c,
> it is not right when mlx5_ib and mlx5e netdev know about internal mdev
> structures and implementations of stuff.
>
> I suggest to move mlx5_ib_get_vector_affinity from patch #4 into
> drivers/net/ethernet/../mlx5/core/main.c
> and rename it to mlx5_get_vector_affinity and use it from both rdma
> and netdevice
>
> and change the above function to:
>
> static int mlx5e_get_cpu(struct mlx5e_priv *priv, int ix)
> {
> return cpumask_first(mlx5_get_vector_affinity(priv->mdev, ix));
> }
Take a look at my comment to Sagi's repost. The driver never
actually cares about this weird cpu value - it cares about a node
for the vectors and PCI layer provides the pci_irq_get_node helper
for that. We could wrap this with a mlx5e helper, but that's not
really the normal style in the kernel.
> > int err;
> >
> > - c = kzalloc_node(sizeof(*c), GFP_KERNEL, cpu_to_node(cpu));
> > + c = kzalloc_node(sizeof(*c), GFP_KERNEL,
> > + pci_irq_get_node(priv->mdev->pdev, MLX5_EQ_VEC_COMP_BASE + ix));
>
> this might yield different behavior of what originally intended we
> want to get the node of the CPU and not of the IRQ's, maybe there is
> no difference but
> let's keep mlx5e_get_cpu abstraction as above.
It's a completely bogus abstraction.
next prev parent reply other threads:[~2017-06-07 8:31 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-06-05 6:35 [PATCH v3 for-4.13 0/6] Automatic affinity settings for nvme over rdma Sagi Grimberg
2017-06-05 6:35 ` [PATCH v3 for-4.13 1/6] mlx5: convert to generic pci_alloc_irq_vectors Sagi Grimberg
2017-06-07 5:26 ` Saeed Mahameed
2017-06-07 5:46 ` Sagi Grimberg
2017-06-05 6:35 ` [PATCH v3 for-4.13 2/6] mlx5: move affinity hints assignments to generic code Sagi Grimberg
2017-06-07 6:16 ` Saeed Mahameed
2017-06-07 8:31 ` Christoph Hellwig [this message]
2017-06-07 9:48 ` Sagi Grimberg
2017-06-08 9:28 ` Saeed Mahameed
2017-06-08 10:16 ` Sagi Grimberg
2017-06-08 11:42 ` Saeed Mahameed
2017-06-08 12:29 ` Sagi Grimberg
2017-06-11 9:32 ` Saeed Mahameed
2017-06-05 6:35 ` [PATCH v3 for-4.13 3/6] RDMA/core: expose affinity mappings per completion vector Sagi Grimberg
2017-06-05 6:35 ` [PATCH v3 for-4.13 4/6] mlx5: support ->get_vector_affinity Sagi Grimberg
2017-06-05 6:35 ` [PATCH v3 for-4.13 5/6] block: Add rdma affinity based queue mapping helper Sagi Grimberg
2017-06-05 6:36 ` [PATCH v3 for-4.13 6/6] nvme-rdma: use intelligent affinity based queue mappings Sagi Grimberg
2017-06-06 9:31 ` [PATCH v3 for-4.13 0/6] Automatic affinity settings for nvme over rdma Christoph Hellwig
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20170607083156.GB24876@lst.de \
--to=hch@lst.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox