Linux-NVME Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: hch@lst.de (Christoph Hellwig)
Subject: [PATCH 8/9] nvme: track shared namespaces
Date: Sun, 24 Sep 2017 17:25:31 +0200	[thread overview]
Message-ID: <20170924152531.GA16753@lst.de> (raw)
In-Reply-To: <20170921151631.GA10713@localhost.localdomain>

On Thu, Sep 21, 2017@11:16:31AM -0400, Keith Busch wrote:
> If there weren't resistence to renaming structs, it would be more
> aligned to how the specification calls these if we rename nvme_ns to
> nvme_ns_path, and what you're calling nvme_ns_head is should just be
> the nvme_ns.

Then we'd still need a good name for what's now nvme_ns :)

But seriously speaking - I'm a little worried because Linus is really
pissed at me for doing major refactoring in block land (by proxy of
Jens who gets all the heat).  I just don't feel comfortable with a
rename at the moment, even if it's the right thing.

  reply	other threads:[~2017-09-24 15:25 UTC|newest]

Thread overview: 33+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-09-18 23:14 nvme multipath support V2 Christoph Hellwig
2017-09-18 23:14 ` [PATCH 1/9] nvme: allow timed-out ios to retry Christoph Hellwig
2017-09-18 23:14 ` [PATCH 2/9] block: move REQ_NOWAIT Christoph Hellwig
2017-09-18 23:14 ` [PATCH 3/9] block: add REQ_DRV bit Christoph Hellwig
2017-09-18 23:14 ` [PATCH 4/9] block: provide a direct_make_request helper Christoph Hellwig
2017-09-18 23:14 ` [PATCH 5/9] block: add a blk_steal_bios helper Christoph Hellwig
2017-09-18 23:14 ` [PATCH 6/9] nvme: track subsystems Christoph Hellwig
2017-09-21 22:52   ` Keith Busch
2017-09-18 23:14 ` [PATCH 7/9] nvme: introduce a nvme_ns_ids structure Christoph Hellwig
2017-09-20  8:27   ` Johannes Thumshirn
2017-09-18 23:14 ` [PATCH 8/9] nvme: track shared namespaces Christoph Hellwig
2017-09-20  8:36   ` Johannes Thumshirn
2017-09-20 14:54     ` Christoph Hellwig
2017-09-21  5:22       ` Johannes Thumshirn
2017-09-21 14:37         ` Christoph Hellwig
2017-09-21 15:16           ` Keith Busch
2017-09-24 15:25             ` Christoph Hellwig [this message]
2017-09-18 23:14 ` [PATCH 9/9] nvme: implement multipath access to nvme subsystems Christoph Hellwig
2017-09-20  0:18   ` Tony Yang
2017-09-20  8:15     ` Johannes Thumshirn
2017-09-20  9:42   ` Johannes Thumshirn
2017-09-20 22:58   ` Keith Busch
2017-09-20 23:52     ` Christoph Hellwig
2017-09-21 21:12       ` Keith Busch
2017-09-24 14:42         ` Christoph Hellwig
2017-09-22 15:09   ` Keith Busch
2017-09-24 14:48     ` Christoph Hellwig
2017-09-20 11:09 ` nvme multipath support V2 Johannes Thumshirn
2017-09-20 14:55   ` Christoph Hellwig
2017-09-21  5:23     ` Johannes Thumshirn
2017-09-21 14:50       ` Christoph Hellwig
2017-09-22  0:21         ` Tony Yang
2017-09-24 14:41           ` Christoph Hellwig

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20170924152531.GA16753@lst.de \
    --to=hch@lst.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox