From mboxrd@z Thu Jan 1 00:00:00 1970 From: axboe@kernel.dk (Jens Axboe) Date: Mon, 26 Jun 2017 08:16:21 -0600 Subject: [PATCH 7/9] xfs: add support for passing in write hints for buffered writes In-Reply-To: <20170626095617.GF14057@infradead.org> References: <1498004526-4543-1-git-send-email-axboe@kernel.dk> <1498004526-4543-8-git-send-email-axboe@kernel.dk> <20170626095617.GF14057@infradead.org> Message-ID: On 06/26/2017 03:56 AM, Christoph Hellwig wrote: >> + ioend->io_bio->bi_opf |= write_hint_to_opf(inode_write_hint(ioend->io_inode)); > > Too long line again. > > I think simply adding an inode_hint_to_opf() flag would make the various > opencoded versions of the above call a little easier to read. Sure, I'll do that. -- Jens Axboe