From: Lyude Paul <lyude@redhat.com>
To: Sui Jingfeng <15330273260@189.cn>,
Alex Deucher <alexander.deucher@amd.com>,
Christian Konig <christian.koenig@amd.com>,
Pan Xinhui <Xinhui.Pan@amd.com>, David Airlie <airlied@gmail.com>,
Daniel Vetter <daniel@ffwll.ch>,
Jani Nikula <jani.nikula@linux.intel.com>,
Joonas Lahtinen <joonas.lahtinen@linux.intel.com>,
Rodrigo Vivi <rodrigo.vivi@intel.com>,
Tvrtko Ursulin <tvrtko.ursulin@linux.intel.com>,
Ben Skeggs <bskeggs@redhat.com>,
Karol Herbst <kherbst@redhat.com>,
Bjorn Helgaas <bhelgaas@google.com>,
Alex Williamson <alex.williamson@redhat.com>,
Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
Maxime Ripard <mripard@kernel.org>,
Thomas Zimmermann <tzimmermann@suse.de>,
Hawking Zhang <Hawking.Zhang@amd.com>,
Mario Limonciello <mario.limonciello@amd.com>,
Lijo Lazar <lijo.lazar@amd.com>,
YiPeng Chai <YiPeng.Chai@amd.com>,
Andrey Grodzovsky <andrey.grodzovsky@amd.com>,
Somalapuram Amaranath <Amaranath.Somalapuram@amd.com>,
Bokun Zhang <Bokun.Zhang@amd.com>,
Ville Syrjala <ville.syrjala@linux.intel.com>,
Li Yi <liyi@loongson.cn>, Sui Jingfeng <suijingfeng@loongson.cn>,
Jason Gunthorpe <jgg@ziepe.ca>, Kevin Tian <kevin.tian@intel.com>,
Cornelia Huck <cohuck@redhat.com>,
Yishai Hadas <yishaih@nvidia.com>,
Abhishek Sahu <abhsahu@nvidia.com>, Yi Liu <yi.l.liu@intel.com>
Cc: amd-gfx@lists.freedesktop.org, dri-devel@lists.freedesktop.org,
linux-kernel@vger.kernel.org, intel-gfx@lists.freedesktop.org,
nouveau@lists.freedesktop.org, linux-pci@vger.kernel.org,
kvm@vger.kernel.org, loongson-kernel@lists.loongnix.cn
Subject: Re: [PATCH v6 0/8] PCI/VGA: introduce is_boot_device function callback to vga_client_register
Date: Wed, 21 Jun 2023 18:11:59 -0400 [thread overview]
Message-ID: <0afadc69f99a36bc9d03ecf54ff25859dbc10e28.camel@redhat.com> (raw)
In-Reply-To: <20230612192550.197053-1-15330273260@189.cn>
For the nouveau bits:
Reviewed-by: Lyude Paul <lyude@redhat.com>
On Tue, 2023-06-13 at 03:25 +0800, Sui Jingfeng wrote:
> From: Sui Jingfeng <suijingfeng@loongson.cn>
>
> The vga_is_firmware_default() function is arch-dependent, it's probably
> wrong if we simply remove the arch guard. As the VRAM BAR which contains
> firmware framebuffer may move, while the lfb_base and lfb_size members of
> the screen_info does not change accordingly. In short, it should take the
> re-allocation of the PCI BAR into consideration.
>
> With the observation that device drivers or video aperture helpers may
> have better knowledge about which PCI bar contains the firmware fb,
> which could avoid the need to iterate all of the PCI BARs. But as a PCI
> function at pci/vgaarb.c, vga_is_firmware_default() is not suitable to
> make such an optimization since it is loaded too early.
>
> There are PCI display controllers that don't have a dedicated VRAM bar,
> this function will lose its effectiveness in such a case. Luckily, the
> device driver can provide an accurate workaround.
>
> Therefore, this patch introduces a callback that allows the device driver
> to tell the VGAARB if the device is the default boot device. Also honor
> the comment: "Clients have two callback mechanisms they can use"
>
> Sui Jingfeng (8):
> PCI/VGA: Use unsigned type for the io_state variable
> PCI/VGA: Deal only with VGA class devices
> PCI/VGA: Tidy up the code and comment format
> PCI/VGA: Replace full MIT license text with SPDX identifier
> video/aperture: Add a helper to detect if an aperture contains
> firmware FB
> PCI/VGA: Introduce is_boot_device function callback to
> vga_client_register
> drm/amdgpu: Implement the is_boot_device callback function
> drm/radeon: Implement the is_boot_device callback function
>
> drivers/gpu/drm/amd/amdgpu/amdgpu_device.c | 12 +-
> drivers/gpu/drm/drm_aperture.c | 16 +++
> drivers/gpu/drm/i915/display/intel_vga.c | 3 +-
> drivers/gpu/drm/nouveau/nouveau_vga.c | 2 +-
> drivers/gpu/drm/radeon/radeon_device.c | 12 +-
> drivers/pci/vgaarb.c | 153 +++++++++++++--------
> drivers/vfio/pci/vfio_pci_core.c | 2 +-
> drivers/video/aperture.c | 29 ++++
> include/drm/drm_aperture.h | 2 +
> include/linux/aperture.h | 7 +
> include/linux/vgaarb.h | 35 ++---
> 11 files changed, 184 insertions(+), 89 deletions(-)
>
--
Cheers,
Lyude Paul (she/her)
Software Engineer at Red Hat
next prev parent reply other threads:[~2023-06-21 22:13 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-06-12 19:25 [PATCH v6 0/8] PCI/VGA: introduce is_boot_device function callback to vga_client_register Sui Jingfeng
2023-06-12 19:25 ` [PATCH v6 1/8] PCI/VGA: Use unsigned type for the io_state variable Sui Jingfeng
2023-06-12 19:25 ` [PATCH v6 2/8] PCI/VGA: Deal only with VGA class devices Sui Jingfeng
2023-06-19 18:12 ` Limonciello, Mario
2023-06-20 2:35 ` Sui Jingfeng
2023-06-20 3:13 ` Sui Jingfeng
2023-06-12 19:25 ` [PATCH v6 3/8] PCI/VGA: Tidy up the code and comment format Sui Jingfeng
2023-06-12 19:25 ` [PATCH v6 4/8] PCI/VGA: Replace full MIT license text with SPDX identifier Sui Jingfeng
2023-06-21 22:11 ` Lyude Paul [this message]
2023-06-22 4:46 ` [PATCH v6 0/8] PCI/VGA: introduce is_boot_device function callback to vga_client_register Sui Jingfeng
-- strict thread matches above, loose matches on Subject: below --
2023-06-12 19:33 Sui Jingfeng
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=0afadc69f99a36bc9d03ecf54ff25859dbc10e28.camel@redhat.com \
--to=lyude@redhat.com \
--cc=15330273260@189.cn \
--cc=Amaranath.Somalapuram@amd.com \
--cc=Bokun.Zhang@amd.com \
--cc=Hawking.Zhang@amd.com \
--cc=Xinhui.Pan@amd.com \
--cc=YiPeng.Chai@amd.com \
--cc=abhsahu@nvidia.com \
--cc=airlied@gmail.com \
--cc=alex.williamson@redhat.com \
--cc=alexander.deucher@amd.com \
--cc=amd-gfx@lists.freedesktop.org \
--cc=andrey.grodzovsky@amd.com \
--cc=bhelgaas@google.com \
--cc=bskeggs@redhat.com \
--cc=christian.koenig@amd.com \
--cc=cohuck@redhat.com \
--cc=daniel@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
--cc=intel-gfx@lists.freedesktop.org \
--cc=jani.nikula@linux.intel.com \
--cc=jgg@ziepe.ca \
--cc=joonas.lahtinen@linux.intel.com \
--cc=kevin.tian@intel.com \
--cc=kherbst@redhat.com \
--cc=kvm@vger.kernel.org \
--cc=lijo.lazar@amd.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=liyi@loongson.cn \
--cc=loongson-kernel@lists.loongnix.cn \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mario.limonciello@amd.com \
--cc=mripard@kernel.org \
--cc=nouveau@lists.freedesktop.org \
--cc=rodrigo.vivi@intel.com \
--cc=suijingfeng@loongson.cn \
--cc=tvrtko.ursulin@linux.intel.com \
--cc=tzimmermann@suse.de \
--cc=ville.syrjala@linux.intel.com \
--cc=yi.l.liu@intel.com \
--cc=yishaih@nvidia.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox