From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from ch1ehsobe006.messaging.microsoft.com ([216.32.181.186]:1607 "EHLO ch1outboundpool.messaging.microsoft.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755789Ab3JHWrf (ORCPT ); Tue, 8 Oct 2013 18:47:35 -0400 Message-ID: <1381272382.7979.292.camel@snotra.buserror.net> Subject: Re: [PATCH 1/2][v2] pci: fsl: derive the common PCI driver to drivers/pci/host From: Scott Wood To: Bjorn Helgaas CC: Minghuan Lian , linuxppc-dev , Zang Roy-R61911 , Kumar Gala , "linux-pci@vger.kernel.org" , Benjamin Herrenschmidt , Paul Mackerras Date: Tue, 8 Oct 2013 17:46:22 -0500 In-Reply-To: References: <1380531175-14836-1-git-send-email-Minghuan.Lian@freescale.com> Content-Type: text/plain; charset="UTF-8" MIME-Version: 1.0 Sender: linux-pci-owner@vger.kernel.org List-ID: On Tue, 2013-10-08 at 13:13 -0600, Bjorn Helgaas wrote: > [+cc Ben, Paul, linuxppc-dev] > > On Mon, Sep 30, 2013 at 04:52:54PM +0800, Minghuan Lian wrote: > > The Freescale's Layerscape series processors will use ARM cores. > > The LS1's PCIe controllers is the same as T4240's. So it's better > > the PCIe controller driver can support PowerPC and ARM > > simultaneously. This patch is for this purpose. It derives > > the common functions from arch/powerpc/sysdev/fsl_pci.c to > > drivers/pci/host/pci-fsl-common.c and leaves the architecture > > specific functions which should be implemented in arch related files. > > > > Signed-off-by: Minghuan Lian > > I cc'd the powerpc maintainers so we can work out which tree this > should go through. > > > --- > > change log: > > v1-v2: > > 1. rename pci.h to pci-common.h > > 2. rename pci-fsl.c to pci-fsl-common.c > > > > Based on upstream master. > > Based on the discussion of RFC version here > > http://patchwork.ozlabs.org/patch/274487/ > > > > arch/powerpc/sysdev/fsl_pci.c | 521 +----------------- > > arch/powerpc/sysdev/fsl_pci.h | 89 ---- > > .../fsl_pci.c => drivers/pci/host/pci-fsl-common.c | 591 +-------------------- > > .../fsl_pci.h => include/linux/fsl/pci-common.h | 45 +- > > Is there any way to avoid putting this file in include/linux? I know > you want to share it beyond PowerPC, and I know there are similar > examples there already, but this is all arch-specific or > chipset-specific stuff that seems like it should be in some > not-so-public place. It doesn't seem scalable to add an include/linux > subdirectory for every chipset that might be shared across > architectures. What specifically is the problem with it, as long as it's properly namespaced? -Scott