From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from mail.kernel.org ([198.145.29.99]:34842 "EHLO mail.kernel.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1725787AbeIREGh (ORCPT ); Tue, 18 Sep 2018 00:06:37 -0400 Date: Mon, 17 Sep 2018 17:37:14 -0500 From: Bjorn Helgaas To: Lukas Wunner Cc: Sinan Kaya , linux-pci@vger.kernel.org, Mika Westerberg , Keith Busch Subject: Re: [PATCH 4/9] PCI: pciehp: Unify controller and slot structs Message-ID: <20180917223714.GC54859@bhelgaas-glaptop.roam.corp.google.com> References: <2d4b1ed51a1c90fb6e1ef6282ab0c28f6c62cab1.1534686485.git.lukas@wunner.de> <20180820090953.sbvgxc2ednxaq73s@wunner.de> <05c7fadf-82ef-5ee0-601d-850583eefb0f@kernel.org> <20180905223016.GA214747@bhelgaas-glaptop.roam.corp.google.com> <20180906073826.43xonlbyoahji7hr@wunner.de> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii In-Reply-To: <20180906073826.43xonlbyoahji7hr@wunner.de> Sender: linux-pci-owner@vger.kernel.org List-ID: On Thu, Sep 06, 2018 at 09:38:26AM +0200, Lukas Wunner wrote: > On Wed, Sep 05, 2018 at 05:30:16PM -0500, Bjorn Helgaas wrote: > > > > > On 8/19/2018 10:29 AM, Lukas Wunner wrote: > > > > > > Simplify the driver by merging struct slot into struct controller. > > > > > > Merge the slot constructor pcie_init_slot() and the destructor > > > > > > pcie_cleanup_slot() into the controller counterparts. > > > > > > Rename the slot struct's "lock" member to "state_lock" and rename > > > > > > "work" to "button_work" for clarity. > > > > Could the rename be done in a separate patch before the unification? > > If so, that would be nice. > > Okay, I've already reworked my internal development branch to do the > unification first, then the rename, but can easily turn the order around, > no problem at all. > > The preceding patches 1 to 3 of this series could be merged independently, > or would you prefer me to resend them? The first one is also included in > Keith's error handling rework series (posted yesterday): > > [1/9] PCI: Simplify disconnected marking > https://patchwork.ozlabs.org/patch/959373/ > [2/9] PCI: pciehp: Drop unnecessary includes > https://patchwork.ozlabs.org/patch/959376/ > [3/9] [3/9] PCI: pciehp: Drop hotplug_slot_ops wrappers > https://patchwork.ozlabs.org/patch/959377/ > > Important side note: Keith's series includes a pciehp fix which should > probably go into 4.19: > > [PATCHv2,15/20] PCI/pciehp: Fix powerfault detection order > https://patchwork.ozlabs.org/patch/966678/ > > Now, if that patch goes into, say, 4.19-rc3, the pci/hotplug branch would > have to be rebased on top of 4.19-rc3 to avoid conflicts during the 4.20 > merge window. OK, I rebased pci/hotplug to v4.19-rc4. Any chance you could update this series to apply on top of that? Bjorn