From: "Pali Rohár" <pali@kernel.org>
To: Dmitry Torokhov <dmitry.torokhov@gmail.com>
Cc: "Shawn Guo" <shawn.guo@linaro.org>,
"Lorenzo Pieralisi" <lpieralisi@kernel.org>,
"Thomas Petazzoni" <thomas.petazzoni@bootlin.com>,
"Bjorn Helgaas" <bhelgaas@google.com>,
"Rob Herring" <robh@kernel.org>,
"Krzysztof Wilczyński" <kw@linux.com>,
"Linus Walleij" <linus.walleij@linaro.org>,
"Bartosz Golaszewski" <brgl@bgdev.pl>,
linux-pci@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/2] PCI: histb: switch to using gpiod API
Date: Tue, 6 Sep 2022 23:46:09 +0200 [thread overview]
Message-ID: <20220906214609.pp5rp7ixor6koku2@pali> (raw)
In-Reply-To: <Yxe+gPl5qeqJuC4Z@google.com>
On Tuesday 06 September 2022 14:41:20 Dmitry Torokhov wrote:
> On Tue, Sep 06, 2022 at 11:08:11PM +0200, Pali Rohár wrote:
> > On Tuesday 06 September 2022 13:43:00 Dmitry Torokhov wrote:
> > > + ret = gpiod_set_consumer_name(hipcie->reset_gpio,
> > > + "PCIe device power control");
> >
> > Just unrelated thing, I know it was there before, but I saw it just now
> > and have to comment it: This is absolute nonsense name. "reset-gpios"
> > device tree property specifies PERST# signal pin (PciE ReSeT) as defined
> > in PCIe CEM (Card ElectroMagnetic) specification and it has absolute
> > nothing with PCIe power control.
> >
> > My suggestion for maintainers would be to remove this critic name at
> > all as it would just mislead other people reading that code.
>
> I can respin the patch is you suggest a more sensible label...
Lets do renaming in different/separate patch. It is better to split API
change patch (which should have any visible functional changes) and
fixups (which will have some visible changes) in separate patches.
Lorenzo, Bjorn, Krzysztof: This is something for you... Do you have any
ideas or suggestions in unifying or fixing these names? I guess more
drivers have misleading names and it is better to do any such changes
globally and not just in one driver.
> >
> > > + if (ret) {
> > > + dev_err(dev, "unable to set reset gpio name: %d\n", ret);
> > > + return ret;
> > > }
>
> Thanks.
>
> --
> Dmitry
next prev parent reply other threads:[~2022-09-06 21:46 UTC|newest]
Thread overview: 31+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-09-06 20:43 [PATCH 1/2] PCI: histb: switch to using gpiod API Dmitry Torokhov
2022-09-06 20:43 ` [PATCH 2/2] PCI: mvebu: " Dmitry Torokhov
2022-09-06 21:16 ` Pali Rohár
2022-09-06 21:26 ` Dmitry Torokhov
2022-09-06 21:40 ` Dmitry Torokhov
2022-09-06 21:42 ` Pali Rohár
2022-09-06 21:41 ` Pali Rohár
2022-09-06 21:52 ` Dmitry Torokhov
2022-09-06 22:09 ` Pali Rohár
2022-09-06 22:41 ` Dmitry Torokhov
2022-09-11 12:58 ` Pali Rohár
2022-09-14 10:35 ` Linus Walleij
2022-09-14 12:10 ` Bartosz Golaszewski
2022-09-14 12:48 ` Linus Walleij
2022-09-14 13:00 ` Kent Gibson
2022-09-14 13:36 ` Linus Walleij
2022-09-15 2:23 ` Kent Gibson
2022-09-15 8:51 ` Linus Walleij
2022-09-15 9:30 ` Kent Gibson
2022-09-16 7:22 ` Bartosz Golaszewski
2022-09-18 14:37 ` Linus Walleij
2022-09-18 23:58 ` Kent Gibson
2022-09-08 8:42 ` Linus Walleij
2022-09-07 4:11 ` kernel test robot
2022-09-06 21:08 ` [PATCH 1/2] PCI: histb: " Pali Rohár
2022-09-06 21:41 ` Dmitry Torokhov
2022-09-06 21:46 ` Pali Rohár [this message]
2022-09-08 8:37 ` Linus Walleij
2022-11-11 15:01 ` Lorenzo Pieralisi
2022-11-11 15:20 ` Dmitry Torokhov
2022-11-14 10:58 ` (subset) " Lorenzo Pieralisi
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20220906214609.pp5rp7ixor6koku2@pali \
--to=pali@kernel.org \
--cc=bhelgaas@google.com \
--cc=brgl@bgdev.pl \
--cc=dmitry.torokhov@gmail.com \
--cc=kw@linux.com \
--cc=linus.walleij@linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=lpieralisi@kernel.org \
--cc=robh@kernel.org \
--cc=shawn.guo@linaro.org \
--cc=thomas.petazzoni@bootlin.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox