From: Alex Williamson <alex@shazbot.org>
To: fengchengwen <fengchengwen@huawei.com>
Cc: <jgg@ziepe.ca>, <helgaas@kernel.org>,
<wathsala.vithanage@arm.com>, <wei.huang2@amd.com>,
<zhipingz@meta.com>, <wangzhou1@hisilicon.com>,
<wangyushan12@huawei.com>, <liuyonglong@huawei.com>,
<kvm@vger.kernel.org>, <linux-pci@vger.kernel.org>,
alex@shazbot.org
Subject: Re: [PATCH v19 12/18] vfio/pci: Add dmabuf TPH metadata storage and fd query helper
Date: Thu, 9 Jul 2026 12:50:12 -0600 [thread overview]
Message-ID: <20260709125012.21784d0a@shazbot.org> (raw)
In-Reply-To: <bb0e583e-501f-4356-b554-784482b35331@huawei.com>
On Thu, 9 Jul 2026 19:49:24 +0800
fengchengwen <fengchengwen@huawei.com> wrote:
> Hi Alex,
>
> On 7/9/2026 7:31 AM, Alex Williamson wrote:
> > On Thu, 2 Jul 2026 20:42:18 +0800
> > Chengwen Feng <fengchengwen@huawei.com> wrote:
> >>
> >> Signed-off-by: Zhiping Zhang <zhipingz@meta.com>
> >> Signed-off-by: Chengwen Feng <fengchengwen@huawei.com>
> >> ---
> >> drivers/vfio/pci/vfio_pci_dmabuf.c | 49 +++++++++++++++++++++++++++++-
> >> drivers/vfio/pci/vfio_pci_priv.h | 6 ++++
> >> 2 files changed, 54 insertions(+), 1 deletion(-)
> >
> > Please don't send competing patches, just indicate the series is based
> > on Zhiping's series v#. This makes all the naming changes that Zhiping
> > declined yet you still included their sign-off. Thanks,
>
> Thanks for the feedback on overlapping dmabuf TPH patches with Zhiping’s series.
> There are code conflicts between the two series on PCI TPH and VFIO dmabuf logic,
> and I also have concerns that Sashiko may not properly parse and track cross-series
> Depends-on tags for reliable automated review.
>
> My current design idea is to retain this foundational metadata patch in my
> series. This patch only implements basic storage and query helpers for TPH tags
> on dma_buf objects, providing the underlying infrastructure. Zhiping can then
> build the corresponding VFIO device feature ioctl layer on top of these commits
> in his follow-up series. I will fully sync all his latest code revisions into
> this patch to align implementation details and minimize future merge conflicts
If your concern is sashiko being able to apply and review your series
on top of another, then I would suggest leading the series with the
unmodified patches clearly noted in the cover letter and commit logs.
As provided here, this patch initially appears as excerpts of Zhiping
series, again including sign-off without permission, but it introduces
this massive gap that was previously overlooked as a result:
> >>
> >> +int vfio_pci_dma_buf_get_tph_by_fd(int fd, bool extended, u16 *tag, u8 *ph)
> >> +{
> >> + struct dma_buf *dmabuf;
> >> + int ret = 0;
> >> +
> >> + dmabuf = dma_buf_get(fd);
> >> + if (IS_ERR(dmabuf))
> >> + return PTR_ERR(dmabuf);
> >> +
> >> + if (dmabuf->ops != &vfio_pci_dmabuf_ops) {
> >> + ret = -EINVAL;
> >> + goto out;
> >> + }
> >> +
> >> + ret = vfio_pci_dma_buf_get_pci_tph(dmabuf, extended, tag, ph);
> >> +out:
> >> + dma_buf_put(dmabuf);
> >> + return ret;
> >> +}
.get_pci_tph() is proposed as a generic feature of dmabufs. We cannot
require that only vfio-pci provided dmabufs are supported, nor can we
bypass the default interfaces and lifecycles. This needs to use
dma_buf_get_pci_tph(), rather than punch through to the vfio-pci
implementation of .get_pci_tph(), and it needs to honor the calling
conventions of that interface. That's what makes this series dependent
on Zhiping's implementation of TPH as a vfio-pci completer feature.
Already, within this patch, the caller violates the lockdep assertion
that the dma reservation lock is held.
Additionally, dma_buf_get_pci_tph() defines that the provided values
are only valid until invalidate_mappings, but this series has no
plumbing to honor that requirement.
This needs significant work if we need to track the lifecycle of every
dmabuf related TPH value. Thanks,
Alex
next prev parent reply other threads:[~2026-07-09 18:50 UTC|newest]
Thread overview: 71+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-02 12:42 [PATCH v19 00/18] vfio/pci: Add PCIe TPH support Chengwen Feng
2026-07-02 12:42 ` [PATCH v19 01/18] PCI/TPH: Fix pcie_tph_get_st_table_loc() field extraction Chengwen Feng
2026-07-02 12:51 ` sashiko-bot
2026-07-02 12:42 ` [PATCH v19 02/18] PCI/TPH: Fix tph_enabled concurrent update race by bitfield packing Chengwen Feng
2026-07-02 12:51 ` sashiko-bot
2026-07-02 12:42 ` [PATCH v19 03/18] PCI/TPH: Cache TPH requester capability at probe time Chengwen Feng
2026-07-02 12:55 ` sashiko-bot
2026-07-02 12:42 ` [PATCH v19 04/18] PCI/TPH: Refactor pcie_enable_tph & add explicit requester variant Chengwen Feng
2026-07-02 12:50 ` sashiko-bot
2026-07-08 23:33 ` Alex Williamson
2026-07-09 9:22 ` fengchengwen
2026-07-02 12:42 ` [PATCH v19 05/18] PCI/TPH: Refactor pcie_tph_get_cpu_st & add explicit variant Chengwen Feng
2026-07-02 12:56 ` sashiko-bot
2026-07-02 12:42 ` [PATCH v19 06/18] PCI/TPH: Expose the enabled TPH requester type Chengwen Feng
2026-07-02 12:49 ` sashiko-bot
2026-07-08 23:33 ` Alex Williamson
2026-07-09 9:30 ` fengchengwen
2026-07-02 12:42 ` [PATCH v19 07/18] PCI/TPH: Add pcie_tph_supported() helper to check TPH capability attributes Chengwen Feng
2026-07-02 12:53 ` sashiko-bot
2026-07-03 0:39 ` fengchengwen
2026-07-08 23:32 ` Alex Williamson
2026-07-09 9:36 ` fengchengwen
2026-07-02 12:42 ` [PATCH v19 08/18] PCI/TPH: Add pci_tph_dsm_supported() helper to detect device TPH ST _DSM Chengwen Feng
2026-07-02 12:55 ` sashiko-bot
2026-07-02 12:42 ` [PATCH v19 09/18] vfio/pci: Hide TPH capability when TPH is unsupported Chengwen Feng
2026-07-02 13:00 ` sashiko-bot
2026-07-03 0:36 ` fengchengwen
2026-07-08 23:32 ` Alex Williamson
2026-07-09 11:00 ` fengchengwen
2026-07-02 12:42 ` [PATCH v19 10/18] vfio/pci: Introduce tph policy parameter for staged TPH feature enablement Chengwen Feng
2026-07-02 12:50 ` sashiko-bot
2026-07-08 23:31 ` Alex Williamson
2026-07-09 11:29 ` fengchengwen
2026-07-02 12:42 ` [PATCH v19 11/18] vfio/pci: Virtualize PCIe TPH capability registers Chengwen Feng
2026-07-02 13:04 ` sashiko-bot
2026-07-03 0:51 ` fengchengwen
2026-07-08 23:31 ` Alex Williamson
2026-07-09 11:40 ` fengchengwen
2026-07-02 12:42 ` [PATCH v19 12/18] vfio/pci: Add dmabuf TPH metadata storage and fd query helper Chengwen Feng
2026-07-02 12:56 ` sashiko-bot
2026-07-03 0:53 ` fengchengwen
2026-07-08 23:31 ` Alex Williamson
2026-07-09 11:49 ` fengchengwen
2026-07-09 18:50 ` Alex Williamson [this message]
2026-07-02 12:42 ` [PATCH v19 13/18] vfio/pci: Introduce VFIO_DEVICE_FEATURE_TPH family uapi for PCI TPH control Chengwen Feng
2026-07-02 13:01 ` sashiko-bot
2026-07-03 0:57 ` fengchengwen
2026-07-08 23:31 ` Alex Williamson
2026-07-09 11:56 ` fengchengwen
2026-07-02 12:42 ` [PATCH v19 14/18] vfio/pci: Implement VFIO_DEVICE_FEATURE_TPH and valid TPH config write support Chengwen Feng
2026-07-02 13:04 ` sashiko-bot
2026-07-03 1:16 ` fengchengwen
2026-07-08 23:30 ` Alex Williamson
2026-07-09 12:16 ` fengchengwen
2026-07-02 12:42 ` [PATCH v19 15/18] vfio/pci: Implement TPH_RESOLVE feature for DMABUF and CPU source resolving Chengwen Feng
2026-07-02 13:00 ` sashiko-bot
2026-07-03 1:26 ` fengchengwen
2026-07-08 23:31 ` Alex Williamson
2026-07-09 12:20 ` fengchengwen
2026-07-02 12:42 ` [PATCH v19 16/18] vfio/pci: Implement TPH_ST feature for batch ST table programming Chengwen Feng
2026-07-02 13:04 ` sashiko-bot
2026-07-03 1:42 ` fengchengwen
2026-07-08 23:29 ` Alex Williamson
2026-07-09 12:36 ` fengchengwen
2026-07-09 13:49 ` Alex Williamson
2026-07-02 12:42 ` [PATCH v19 17/18] vfio/pci: Reset hardware TPH state on device enable/disable Chengwen Feng
2026-07-02 13:00 ` sashiko-bot
2026-07-08 23:29 ` Alex Williamson
2026-07-09 12:39 ` fengchengwen
2026-07-02 12:42 ` [PATCH v19 18/18] vfio/pci: Expose tph_policy via debugfs Chengwen Feng
2026-07-02 12:59 ` sashiko-bot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260709125012.21784d0a@shazbot.org \
--to=alex@shazbot.org \
--cc=fengchengwen@huawei.com \
--cc=helgaas@kernel.org \
--cc=jgg@ziepe.ca \
--cc=kvm@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=liuyonglong@huawei.com \
--cc=wangyushan12@huawei.com \
--cc=wangzhou1@hisilicon.com \
--cc=wathsala.vithanage@arm.com \
--cc=wei.huang2@amd.com \
--cc=zhipingz@meta.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox