Linux PCI subsystem development
 help / color / mirror / Atom feed
 messages from 2015-12-11 05:06:15 to 2015-12-16 15:18:14 UTC [more...]

[PATCH V2 00/23] MMCONFIG refactoring and support for ARM64 PCI hostbridge init based on ACPI
 2015-12-16 15:16 UTC  (24+ messages)
` [PATCH V2 01/23] x86, pci: Reorder logic of pci_mmconfig_insert() function
` [PATCH V2 02/23] x86, pci, acpi: Move arch-agnostic MMCONFIG (aka ECAM) and ACPI code out of arch/x86/ directory
` [PATCH V2 03/23] pci, acpi, mcfg: Provide generic implementation of MCFG code initialization
` [PATCH V2 04/23] x86, pci: mmconfig_{32,64}.c code refactoring - remove code duplication
` [PATCH V2 05/23] x86, pci, ecam: mmconfig_64.c becomes default implementation for ECAM driver
` [PATCH V2 06/23] XEN / PCI: Remove the dependence on arch x86 when PCI_MMCONFIG=y
` [PATCH V2 07/23] pci, acpi, mcfg: Provide default RAW ACPI PCI config space accessors
` [PATCH V2 08/23] arm64, acpi: Use empty PCI config space accessors from mcfg.c file
` [PATCH V2 09/23] pci, acpi, ecam: Add flag to indicate whether ECAM region was hot added or not
` [PATCH V2 10/23] x86, pci: Cleanup platform specific MCFG data using previously added ECAM hot_added flag
` [PATCH V2 11/23] arm64, pci: Remove useless boot time IRQ assignment when booting with DT
` [PATCH V2 12/23] pci, acpi: Move ACPI host bridge device companion assignment to core code
` [PATCH V2 13/23] x86, ia64, pci: Remove ACPI companion device from platform specific data
` [PATCH V2 14/23] pci, acpi: Provide generic way to assign bus domain number
` [PATCH V2 15/23] x86, ia64, pci: Convert arches to use PCI_DOMAINS_GENERIC
` [PATCH V2 16/23] x86, ia64: Include acpi_pci_{add|remove}_bus to the default pcibios_{add|remove}_bus implementation
` [PATCH V2 17/23] acpi, mcfg: Implement two calls that might be used to inject/remove MCFG region
` [PATCH V2 18/23] x86, acpi, pci: Use equivalent function introduced in previous patch
` [PATCH V2 19/23] acpi, mcfg: Add default PCI config accessors implementation and initial support for related quirks
` [PATCH V2 20/23] ACPI, PCI: Refine the way to handle translation_offset for ACPI resources
` [PATCH V2 21/23] pci, acpi: Support for ACPI based PCI hostbridge init
` [PATCH V2 22/23] pci, acpi: Match PCI config space accessors against platfrom specific quirks
` [PATCH V2 23/23] arm64, pci, acpi: Start using ACPI based PCI host bridge driver for ARM64

[RFC PATCH v3 0/5] Simple ACPI based PCI support for arm64
 2015-12-16 14:24 UTC  (7+ messages)
` [RFC PATCH v3 1/5] ACPI: MCFG: Move mmcfg_list management to drivers/acpi
` [RFC PATCH v3 2/5] arm64: pci: Add ACPI support
` [RFC PATCH v3 3/5] PCI: Handle NULL parent in pci_bus_assign_domain_nr
` [RFC PATCH v3 4/5] ACPI: PCI: Support platforms that need pci_remap_iospace
` [RFC PATCH v3 5/5] PCI: ACPI: Add a generic ACPI based host controller

[PATCH v2 0/2] adding PCI support to AXS10x
 2015-12-16 14:14 UTC  (3+ messages)
` [PATCH v2 1/2] PCI support added to ARC
` [PATCH v2 2/2] add new platform driver for PCI RC

[PATCH V1 00/11] MMCONFIG refactoring and ARM64 PCI hostbridge init based on ACPI
 2015-12-16 14:05 UTC  (4+ messages)

[PATCHv2] pci: Update VPD size with correct length
 2015-12-16 10:49 UTC 

[PATCH] pci: Update VPD size with correct length
 2015-12-16 10:41 UTC  (2+ messages)

Adding support for new amplifier on ACPI platform
 2015-12-15 22:29 UTC  (2+ messages)

[PATCH v3] Add lspci support for Enhanced Allocation Capability
 2015-12-15 22:15 UTC 

[PATCH v9 0/7] PCI: hv: New paravirtual PCI front-end for Hyper-V VMs
 2015-12-15 17:36 UTC  (2+ messages)

[PATCH v2 0/2] Minor _OSC error handling improvements
 2015-12-15 16:37 UTC  (3+ messages)
` [PATCH v2 1/2] acpi: Tidy up _OSC error spacing
` [PATCH v2 2/2] acpi: Show _OSC UUID when _OSC fails

[PATCH 0/2] Minor _OSC error handling improvements
 2015-12-15 16:10 UTC  (4+ messages)

[PATCH v3 0/9] phy: use syscon framework APIs to set ctrl mod reg
 2015-12-15 15:26 UTC  (15+ messages)
` [PATCH v3 1/9] phy: ti-pipe3: introduce local struct device* in probe
` [PATCH v3 2/9] phy: ti-pipe3: move clk initialization to a separate function
` [PATCH v3 3/9] phy: ti-pipe3: move sysctrl "
` [PATCH v3 4/9] phy: ti-pipe3: move mem resource "
` [PATCH v3 5/9] phy: ti-pipe3: use ti_pipe3_power_off to power off the PHY during probe
` [PATCH v3 6/9] phy: ti-pipe3: use *syscon* framework API to power on/off the PHY
` [PATCH v3 7/9] phy: ti-pipe3: use *syscon* framework API to set PCS value of "
` [PATCH v3 8/9] phy: omap-usb2: use omap_usb_power_off to power off the PHY during probe
` [PATCH v3 9/9] phy: omap-usb2: use *syscon* framework API to power on/off the PHY

[PATCH 00/10] drivers/pci: avoid module_init in non-modular host/pci*
 2015-12-15 15:16 UTC  (30+ messages)
` [PATCH 01/10] drivers/pci: make host/pci-imx6.c driver explicitly non-modular
` [PATCH 02/10] drivers/pci: make host/pcie-spear13xx.c "
` [PATCH 03/10] drivers/pci: make host/pci-mvebu.c "
` [PATCH 04/10] drivers/pci: make host/pci-dra7xx.c "
` [PATCH 05/10] drivers/pci: make host/pci-rcar-gen2.c "
` [PATCH 06/10] drivers/pci: make host/pci-tegra.c "
` [PATCH 07/10] drivers/pci: make host/pcie-rcar.c "
` [PATCH 08/10] drivers/pci: make host/pcie-xilinx.c "
` [PATCH 09/10] drivers/pci: make host/pci-keystone.c "
` [PATCH 10/10] drivers/pci: make host/pcie-altera.c "

[PATCH v3 0/4] ARM: dts: use syscon property instead of ctrl-module
 2015-12-15 13:22 UTC  (6+ messages)
` [PATCH v3 1/4] ARM: dts: dra7: Add dt node for the sycon pcie
` [PATCH v3 2/4] ARM: dts: dra7: Use "syscon-phy-power" and "syscon-pcs" in PCIe PHY node
` [PATCH v3 3/4] ARM: dts: dra7: Use "ti,dra7x-usb2-phy2" compatible string for USB2 PHY2
` [PATCH v3 4/4] ARM: dts: <am4372/dra7/omap5>: Use "syscon-phy-power" instead of "ctrl-module"

[PATCH v7 0/4] gicv2m: acpi: Add ACPI support for GICv2m MSI
 2015-12-15  9:52 UTC  (5+ messages)
` [PATCH v7 1/4] acpi: pci: Setup MSI domain for ACPI based pci devices

[PATCH v4 0/5] Qualcomm PCIe driver and designware fixes
 2015-12-15  8:24 UTC  (9+ messages)
` [PATCH v4 1/5] PCI: designware: add memory barrier after enabling region
` [PATCH v4 3/5] PCI: qcom: Add Qualcomm PCIe controller driver

[PATCH] kobject: Ensure child's resources get released before parent's resources
 2015-12-14 23:10 UTC  (2+ messages)

[RFC PATCH 0/3] x86: Add support for guest DMA dirty page tracking
 2015-12-14 22:32 UTC  (16+ messages)
` [RFC PATCH 1/3] swiotlb: Fold static unmap and sync calls into calling functions
` [RFC PATCH 2/3] xen/swiotlb: "
` [RFC PATCH 3/3] x86: Create dma_mark_dirty to dirty pages used for DMA by VM guest

[PATCH] Add lspci support for Enhanced Allocation Capability
 2015-12-14 19:07 UTC  (5+ messages)

[PATCH] kobject: Ensure child's resources get released before parent's resources
 2015-12-14 19:04 UTC 

[PATCH v2] PCI/AER: enable SERR# forwarding for bridges and switches
 2015-12-14 18:22 UTC  (6+ messages)

[PATCHv6 0/7] Driver for new "VMD" device
 2015-12-12 23:00 UTC  (3+ messages)
` [PATCHv5 7/7] pciutils: Allow 32-bit domains

[PATCH] PCI: hotplug: use list_for_each_entry*
 2015-12-12 13:36 UTC 

[PATCH] drivers:pci Fix small spacing warnings
 2015-12-12 13:33 UTC 

[PATCH] drivers:pci:host Fix missing line after declarations
 2015-12-12 13:03 UTC  (3+ messages)

[PATCH v2] Add lspci support for Enhanced Allocation Capability
 2015-12-12  1:15 UTC 

[PATCH 1/1] drivers:pci:hotplug Fix all whitespace issues
 2015-12-11 16:03 UTC 

[PATCH v2 0/4] PCI: rcar, rcar-gen2: More Gen2 compatibility strings
 2015-12-11 15:58 UTC  (5+ messages)

[RFC PATCH 0/2] PCI/ACPI: HiSi: Add ACPI support for Hip05 PCIe Host Bridge Controller
 2015-12-11 14:17 UTC  (6+ messages)
` [RFC PATCH 1/2] PCI/ACPI: Add ACPI support for non ECAM Host Bridge Controllers

[PATCH v11] PCI: Xilinx-NWL-PCIe: Added support for Xilinx NWL PCIe Host Controller
 2015-12-11  9:33 UTC  (9+ messages)

[PATCH v9 00/60] PCI: Resource allocation cleanup for v4.5
 2015-12-11  5:06 UTC  (57+ messages)
` [PATCH v9 01/60] PCI: Add pci_find_root_bus_resource()
` [PATCH v9 02/60] sparc/PCI: Use correct bus address to resource offset
` [PATCH v9 04/60] sparc/PCI: Add IORESOURCE_MEM_64 for 64-bit resource in OF parsing
` [PATCH v9 05/60] sparc/PCI: Keep resource idx order with bridge register number
` [PATCH v9 06/60] PCI: Kill wrong quirk about M7101
` [PATCH v9 07/60] PCI: Ignore BAR for ALi M1533 PCI-ISA bridge
` [PATCH v9 09/60] powerpc/PCI: Add IORESOURCE_MEM_64 for 64-bit resource in OF parsing
` [PATCH v9 10/60] OF/PCI: Add IORESOURCE_MEM_64 for 64-bit resource
` [PATCH v9 11/60] PCI: Check pref compatible bit for mem64 resource of PCIe device
` [PATCH v9 13/60] PCI: Add has_mem64 for struct host_bridge
` [PATCH v9 14/60] PCI: Only treat non-pref mmio64 as pref if host bridge has mmio64
` [PATCH v9 15/60] PCI: Restore pref MMIO allocation logic for host bridge without mmio64
` [PATCH v9 17/60] PCI: Claim fixed resource during remove/rescan path
` [PATCH v9 18/60] PCI: Set resource to FIXED for LSI devices
` [PATCH v9 19/60] PCI: Separate realloc list checking after allocation
` [PATCH v9 20/60] PCI: Treat optional as required in first try for bridge rescan
` [PATCH v9 21/60] PCI: Get new realloc size for bridge for last try
` [PATCH v9 22/60] PCI: Don't release sibling bridge resources during hotplug
` [PATCH v9 23/60] PCI: Cleanup res_to_dev_res() printout
` [PATCH v9 24/60] PCI: Reuse res_to_dev_res() in reassign_resources_sorted()
` [PATCH v9 25/60] PCI: Use correct align for optional only resources during sorting
` [PATCH v9 26/60] PCI: Optimize bus min_align/size calculation during sizing
` [PATCH v9 27/60] PCI: Optimize bus align/size calculation for optional "
` [PATCH v9 28/60] PCI: Don't add too much optional size for hotplug bridge MMIO
` [PATCH v9 29/60] PCI: Reorder resources list for required/optional resources
` [PATCH v9 30/60] PCI: Remove duplicated code for resource sorting
` [PATCH v9 31/60] PCI: Rename pdev_sort_resources() to pdev_assign_resources_prepare()
` [PATCH v9 32/60] PCI: Treat ROM resource as optional during realloc
` [PATCH v9 33/60] PCI: Add debug printout during releasing partial assigned resources
` [PATCH v9 34/60] PCI: Simplify res reference using in __assign_resources_sorted()
` [PATCH v9 35/60] PCI: Add __add_to_list()
` [PATCH v9 36/60] PCI: Cache window alignment value during bus sizing
` [PATCH v9 37/60] PCI: Check if resource is allocated before trying to assign one
` [PATCH v9 38/60] PCI: Separate out save_resources()/restore_resources()
` [PATCH v9 39/60] PCI: Move comment to pci_need_to_release()
` [PATCH v9 40/60] PCI: Separate required+optional assigning to another function
` [PATCH v9 41/60] PCI: Skip required+optional if there is no optional
` [PATCH v9 42/60] PCI: Move saved required resource list out of required+optional assigning
` [PATCH v9 43/60] PCI: Add alt_size ressource allocation support
` [PATCH v9 44/60] PCI: Add support for more than two alt_size entries under same bridge
` [PATCH v9 45/60] PCI: Fix size calculation with old_size on rescan path
` [PATCH v9 46/60] PCI: Don't add too much optional size for hotplug bridge io
` [PATCH v9 47/60] PCI: Move ISA io port align out of calculate_iosize()
` [PATCH v9 48/60] PCI: Don't add too much io port for hotplug bridge with old size
` [PATCH v9 49/60] PCI: Unify calculate_size() for io port and MMIO
` [PATCH v9 50/60] PCI: Allow bridge optional only io port resource required size to be 0
` [PATCH v9 51/60] PCI: Unify skip_ioresource_align()
` [PATCH v9 52/60] PCI: Kill macro checking for bus io port sizing
` [PATCH v9 53/60] resources: Split out __allocate_resource()
` [PATCH v9 54/60] resources: Make allocate_resource() return best fit resource
` [PATCH v9 55/60] PCI, x86: Allocate from high in available window for MMIO
` [PATCH v9 56/60] PCI: Add debug print out for min_align and alt_size
` [PATCH v9 57/60] PCI, x86: Add pci=assign_pref_bars to reallocate pref BARs
` [PATCH v9 58/60] PCI: Introduce resource_disabled()
` [PATCH v9 59/60] PCI: Don't set flags to 0 when assign resource fail
` [PATCH v9 60/60] PCI: Only try to assign io port only for root bus that support it


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox