Linux PCI subsystem development
 help / color / mirror / Atom feed
From: Dave Jiang <dave.jiang@intel.com>
To: "Pawel Zalewski (The Capable Hub)"
	<pzalewski@thegoodpenguin.co.uk>,
	"Rafael J. Wysocki" <rafael@kernel.org>,
	Len Brown <lenb@kernel.org>, Bjorn Helgaas <bhelgaas@google.com>,
	Zhang Rui <rui.zhang@intel.com>,
	Kai-Heng Feng <kaihengf@nvidia.com>,
	Tony Luck <tony.luck@intel.com>, Borislav Petkov <bp@alien8.de>,
	Hanjun Guo <guohanjun@huawei.com>,
	Mauro Carvalho Chehab <mchehab@kernel.org>,
	Shuai Xue <xueshuai@linux.alibaba.com>,
	Lorenzo Pieralisi <lpieralisi@kernel.org>,
	Sudeep Holla <sudeep.holla@kernel.org>,
	Catalin Marinas <catalin.marinas@arm.com>,
	Will Deacon <will@kernel.org>, Dan Williams <djbw@kernel.org>,
	Vishal Verma <vishal.l.verma@intel.com>,
	Alison Schofield <alison.schofield@intel.com>,
	Ira Weiny <iweiny@kernel.org>
Cc: linux-acpi@vger.kernel.org, linux-kernel@vger.kernel.org,
	linux-pci@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
	nvdimm@lists.linux.dev
Subject: Re: [PATCH 7/9] ACPI: nfit: core: drop unused assignment of acpi_device_id::driver_data
Date: Mon, 27 Jul 2026 10:25:21 -0700	[thread overview]
Message-ID: <ce2fc791-e84b-49e7-8d9b-f864ee82aa25@intel.com> (raw)
In-Reply-To: <20260727-acpi-refactor-v1-7-ff900aa326ee@thegoodpenguin.co.uk>



On 7/27/26 5:10 AM, Pawel Zalewski (The Capable Hub) wrote:
> This module sets the acpi_device_id::driver_data to 0 but
> the field is not actually used within the module, we can
> just drop it from the table.
> 
> While we are at it - used a named initializer for the
> acpi_device_id::id field to increase readability and
> drop explicitly setting the list terminator fields.
> 
> Signed-off-by: Pawel Zalewski (The Capable Hub) <pzalewski@thegoodpenguin.co.uk>

Reviewed-by: Dave Jiang <dave.jiang@intel.com>

> ---
>  drivers/acpi/nfit/core.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/acpi/nfit/core.c b/drivers/acpi/nfit/core.c
> index cb771d9cadb2..5732df5d53f0 100644
> --- a/drivers/acpi/nfit/core.c
> +++ b/drivers/acpi/nfit/core.c
> @@ -3515,8 +3515,8 @@ void __acpi_nfit_notify(struct device *dev, acpi_handle handle, u32 event)
>  EXPORT_SYMBOL_GPL(__acpi_nfit_notify);
>  
>  static const struct acpi_device_id acpi_nfit_ids[] = {
> -	{ "ACPI0012", 0 },
> -	{ "", 0 },
> +	{ .id = "ACPI0012" },
> +	{ }
>  };
>  MODULE_DEVICE_TABLE(acpi, acpi_nfit_ids);
>  
> 


  parent reply	other threads:[~2026-07-27 17:25 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-27 12:10 [PATCH 0/9] ACPI: use named initializers for acpi_device_id Pawel Zalewski (The Capable Hub)
2026-07-27 12:10 ` [PATCH 1/9] ACPI: use a named initializer " Pawel Zalewski (The Capable Hub)
2026-07-27 12:17   ` sashiko-bot
2026-07-27 12:10 ` [PATCH 2/9] ACPI: drop unused assignment of acpi_device_id::driver_data Pawel Zalewski (The Capable Hub)
2026-07-27 12:17   ` sashiko-bot
2026-07-27 12:10 ` [PATCH 3/9] ACPI: pci: " Pawel Zalewski (The Capable Hub)
2026-07-27 12:16   ` sashiko-bot
2026-07-27 12:10 ` [PATCH 4/9] ACPI: ghes-nvidia: use a named initializer for acpi_device_id::id Pawel Zalewski (The Capable Hub)
2026-07-27 12:14   ` sashiko-bot
2026-07-27 12:10 ` [PATCH 5/9] ACPI: amba: drop unused assignment of acpi_device_id::driver_data Pawel Zalewski (The Capable Hub)
2026-07-27 12:16   ` sashiko-bot
2026-07-27 12:10 ` [PATCH 6/9] ACPI: dptf: " Pawel Zalewski (The Capable Hub)
2026-07-27 12:14   ` sashiko-bot
2026-07-27 12:10 ` [PATCH 7/9] ACPI: nfit: core: " Pawel Zalewski (The Capable Hub)
2026-07-27 12:15   ` sashiko-bot
2026-07-27 17:25   ` Dave Jiang [this message]
2026-07-27 12:10 ` [PATCH 8/9] ACPI: x86: use a named initializer for acpi_device_id::id Pawel Zalewski (The Capable Hub)
2026-07-27 12:15   ` sashiko-bot
2026-07-27 12:10 ` [PATCH 9/9] ACPI: " Pawel Zalewski (The Capable Hub)
2026-07-27 12:17   ` sashiko-bot
2026-07-27 12:15 ` [PATCH 0/9] ACPI: use named initializers for acpi_device_id Rafael J. Wysocki (Intel)

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ce2fc791-e84b-49e7-8d9b-f864ee82aa25@intel.com \
    --to=dave.jiang@intel.com \
    --cc=alison.schofield@intel.com \
    --cc=bhelgaas@google.com \
    --cc=bp@alien8.de \
    --cc=catalin.marinas@arm.com \
    --cc=djbw@kernel.org \
    --cc=guohanjun@huawei.com \
    --cc=iweiny@kernel.org \
    --cc=kaihengf@nvidia.com \
    --cc=lenb@kernel.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=lpieralisi@kernel.org \
    --cc=mchehab@kernel.org \
    --cc=nvdimm@lists.linux.dev \
    --cc=pzalewski@thegoodpenguin.co.uk \
    --cc=rafael@kernel.org \
    --cc=rui.zhang@intel.com \
    --cc=sudeep.holla@kernel.org \
    --cc=tony.luck@intel.com \
    --cc=vishal.l.verma@intel.com \
    --cc=will@kernel.org \
    --cc=xueshuai@linux.alibaba.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox