Linux PCI subsystem development
 help / color / mirror / Atom feed
From: Matt Evans <matt@ozlabs.org>
To: "Logan Gunthorpe" <logang@deltatee.com>,
	"Alex Williamson" <alex@shazbot.org>,
	"Leon Romanovsky" <leon@kernel.org>,
	"Jason Gunthorpe" <jgg@nvidia.com>,
	"Alex Mastro" <amastro@fb.com>,
	"Christian König" <christian.koenig@amd.com>,
	"Bjorn Helgaas" <bhelgaas@google.com>,
	"Kevin Tian" <kevin.tian@intel.com>,
	"Pranjal Shrivastava" <praan@google.com>
Cc: "Mahmoud Adam" <mngyadam@amazon.de>,
	"David Matlack" <dmatlack@google.com>,
	"Björn Töpel" <bjorn@kernel.org>,
	"Sumit Semwal" <sumit.semwal@linaro.org>,
	"Ankit Agrawal" <ankita@nvidia.com>,
	"Alistair Popple" <apopple@nvidia.com>,
	"Vivek Kasireddy" <vivek.kasireddy@intel.com>,
	linux-kernel@vger.kernel.org, linux-media@vger.kernel.org,
	dri-devel@lists.freedesktop.org, linaro-mm-sig@lists.linaro.org,
	kvm@vger.kernel.org, linux-pci@vger.kernel.org
Subject: Re: [PATCH v4 02/10] PCI/P2PDMA: Add CONFIG_PCI_P2PDMA_CORE
Date: Thu, 9 Jul 2026 17:17:53 +0100	[thread overview]
Message-ID: <e0ccdfd7-2379-44ae-b579-a0da045d7f1b@ozlabs.org> (raw)
In-Reply-To: <1cd1b832-082c-4f9c-ab68-706110ddcb25@deltatee.com>

Hi Logan,

On 02/07/2026 21:34, Logan Gunthorpe wrote:
> 
> 
> On 2026-07-02 10:44 a.m., Matt Evans wrote:
>>> So maybe at this point it's fine to enable this on 32bit systems and we
>>> can remove this requirement. However, I think we should do that
>>> explicitly in its own patch, not hide it in this refactoring patch.
>>
>> Your question does prove it's too stealthy as-is. :)  PCI_P2PDMA still
>> can't be enabled on 32-bit systems because of its ZONE_DEVICE -> 
>> MEMORY_HOTPLUG -> 64BIT dependency.  So we're not enabling 32-bit 
>> support for PCI_P2PDMA here, but it's not obvious and so I'll re-add the 
>> `depends on 64BIT`.  At least then it won't be enabled without intention 
>> if someone enables ZONE_DEVICE on 32-bit systems...
> 
> Ok, that all makes sense to me. I would be good with removing the 64BIT
> dependency (as it is is a bit confusing as is) but I think adding
> another patch would be appropriate with some of the commit message notes
> you mentioned in your emails.
> 
> Besides that, I think you can add to this patch:
> 
> Reviewed-by: Logan Gunthorpe <logang@deltatee.com>

Thanks for that.  On second reading, just want to check with you:

I'm intending to repost _retaining_ the 64BIT dependency (i.e. revert
its removal) for simplicity's sake.  Then we can follow up separatey
(outside this series) with a cleanup patch to remove 64BIT, explain,
examine other dependencies etc. as you suggest.  Works for you?

(I want to reduce the diff in this series, and revert since this isn't
truly necessary && wasn't entirely obvious.)

Cheers,


Matt


  reply	other threads:[~2026-07-09 16:18 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-01 17:12 [PATCH v4 00/10] vfio/pci: Add mmap() for DMABUFs Matt Evans
2026-07-01 17:12 ` [PATCH v4 01/10] PCI/P2PDMA: Split pool-related cleanup out of pci_p2pdma_release() Matt Evans
2026-07-01 21:15   ` Bjorn Helgaas
2026-07-02 15:13   ` Logan Gunthorpe
2026-07-01 17:12 ` [PATCH v4 02/10] PCI/P2PDMA: Add CONFIG_PCI_P2PDMA_CORE Matt Evans
2026-07-01 21:16   ` Bjorn Helgaas
2026-07-02 15:45   ` Logan Gunthorpe
2026-07-02 16:44     ` Matt Evans
2026-07-02 20:34       ` Logan Gunthorpe
2026-07-09 16:17         ` Matt Evans [this message]
2026-07-09 16:25           ` Logan Gunthorpe
2026-07-01 17:12 ` [PATCH v4 03/10] vfio/pci: Add a helper to look up PFNs for DMABUFs Matt Evans
2026-07-01 17:12 ` [PATCH v4 04/10] vfio/pci: Add a helper to create a DMABUF for a BAR-map VMA Matt Evans
2026-07-01 17:12 ` [PATCH v4 05/10] vfio/pci: Convert BAR mmap() to use a DMABUF Matt Evans
2026-07-01 17:12 ` [PATCH v4 06/10] vfio/pci: Provide a user-facing name for BAR mappings Matt Evans
2026-07-01 17:12 ` [PATCH v4 07/10] vfio/pci: Clean up BAR zap and revocation Matt Evans
2026-07-01 17:12 ` [PATCH v4 08/10] vfio/pci: Support mmap() of a VFIO DMABUF Matt Evans
2026-07-01 17:12 ` [PATCH v4 09/10] vfio/pci: Permanently revoke a DMABUF on request Matt Evans
2026-07-01 17:12 ` [PATCH v4 10/10] vfio/pci: Add mmap() attributes to DMABUF feature Matt Evans
2026-07-07 21:16 ` [PATCH v4 00/10] vfio/pci: Add mmap() for DMABUFs Alex Williamson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=e0ccdfd7-2379-44ae-b579-a0da045d7f1b@ozlabs.org \
    --to=matt@ozlabs.org \
    --cc=alex@shazbot.org \
    --cc=amastro@fb.com \
    --cc=ankita@nvidia.com \
    --cc=apopple@nvidia.com \
    --cc=bhelgaas@google.com \
    --cc=bjorn@kernel.org \
    --cc=christian.koenig@amd.com \
    --cc=dmatlack@google.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=jgg@nvidia.com \
    --cc=kevin.tian@intel.com \
    --cc=kvm@vger.kernel.org \
    --cc=leon@kernel.org \
    --cc=linaro-mm-sig@lists.linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=logang@deltatee.com \
    --cc=mngyadam@amazon.de \
    --cc=praan@google.com \
    --cc=sumit.semwal@linaro.org \
    --cc=vivek.kasireddy@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox