Linux-PHY Archive on lore.kernel.org
 help / color / mirror / Atom feed
 messages from 2026-07-01 13:02:25 to 2026-07-05 08:10:15 UTC [more...]

[PATCH v2 0/5] phy: cpcap-usb: improve charger detection and export cable state
 2026-07-05  8:10 UTC  (10+ messages)
` [PATCH v2 1/5] phy: cpcap-usb: Prevent line glitches from triggering sysrq
` [PATCH v2 2/5] dt-bindings: phy: motorola,cpcap-usb: add chrg_det interrupt
` [PATCH v2 3/5] ARM: dts: ti: cpcap-mapphone: use charger detection interrupt for CPCAP USB PHY
` [PATCH v2 4/5] phy: cpcap-usb: add DCP detection and make UART idle mode optional
` [PATCH v2 5/5] phy: cpcap-usb: add extcon support

[PATCH v2 0/2] riscv: spacemit: Add K3 PCIe/USB comb phy support
 2026-07-05  1:59 UTC  (6+ messages)
` [PATCH v2 1/2] dt-bindings: phy: Add Spacemit K3 USB3/PCIe "
` [PATCH v2 2/2] phy: spacemit: Add USB3/PCIe comb PHY driver for Spacemit K3

[PATCH v2 0/2] iio: inkern: Use namespaced exports
 2026-07-05  1:07 UTC  (5+ messages)
` [PATCH v2 2/2] "

[PATCH 0/5] phy: cpcap-usb: improve charger detection and export cable state
 2026-07-04  7:51 UTC  (11+ messages)
` [PATCH 1/5] phy: cpcap-usb: Prevent line glitches from triggering sysrq
` [PATCH 2/5] phy: cpcap-usb: add DCP detection and make UART idle mode optional
` [PATCH 3/5] dt-bindings: phy: motorola,cpcap-usb: replace se1 interrupt with chrg_det
` [PATCH 4/5] ARM: dts: ti: cpcap-mapphone: use charger detection interrupt for CPCAP USB PHY
` [PATCH 5/5] phy: cpcap-usb: add extcon support

[PATCH v10 00/36] phy: rockchip: usbdp: Clean up the mess
 2026-07-04  0:12 UTC  (47+ messages)
` [PATCH v10 01/36] dt-bindings: phy: rockchip-usbdp: add improved ports scheme
` [PATCH v10 02/36] phy: rockchip: usbdp: Update mode_change after error handling
` [PATCH v10 03/36] phy: rockchip: usbdp: Do not lose USB3 PHY status
` [PATCH v10 04/36] phy: rockchip: usbdp: Fix devm_clk_bulk_get_all check
` [PATCH v10 05/36] phy: rockchip: usbdp: Handle missing clock-names DT property gracefully
` [PATCH v10 06/36] phy: rockchip: usbdp: Drop seamless DP takeover
` [PATCH v10 07/36] phy: rockchip: usbdp: Keep clocks running on PHY re-init
` [PATCH v10 08/36] phy: rockchip: usbdp: Amend SSC modulation deviation
` [PATCH v10 09/36] phy: rockchip: usbdp: Fix LFPS detect threshold control
` [PATCH v10 10/36] phy: rockchip: usbdp: Add missing mode_change update
` [PATCH v10 11/36] phy: rockchip: usbdp: Support single-lane DP
` [PATCH v10 12/36] phy: rockchip: usbdp: Limit DP lane count to muxed lanes
` [PATCH v10 13/36] phy: rockchip: usbdp: Rename DP lane functions
` [PATCH v10 14/36] phy: rockchip: usbdp: Use FIELD_PREP_WM16_CONST
` [PATCH v10 15/36] phy: rockchip: usbdp: Cleanup DP lane selection function
` [PATCH v10 16/36] phy: rockchip: usbdp: Register DP aux bridge
` [PATCH v10 17/36] phy: rockchip: usbdp: Drop DP HPD handling
` [PATCH v10 18/36] phy: rockchip: usbdp: Rename mode_change to phy_needs_reinit
` [PATCH v10 19/36] phy: rockchip: usbdp: Re-init the PHY on orientation change
` [PATCH v10 20/36] phy: rockchip: usbdp: Factor out lane_mux_sel setup
` [PATCH v10 21/36] phy: rockchip: usbdp: Properly handle TYPEC_STATE_SAFE and TYPEC_STATE_USB
` [PATCH v10 22/36] phy: rockchip: usbdp: Use guard functions for mutex
` [PATCH v10 23/36] phy: rockchip: usbdp: Clear USB status on PHY exit
` [PATCH v10 24/36] phy: rockchip: usbdp: Hold mutex in DP PHY configure
` [PATCH v10 25/36] phy: rockchip: usbdp: Add some extra debug messages
` [PATCH v10 26/36] phy: rockchip: usbdp: Avoid xHCI SErrors
` [PATCH v10 27/36] phy: rockchip: usbdp: Handle rk_udphy_reset_deassert errors
` [PATCH v10 28/36] phy: rockchip: usbdp: Only enable USB3 when not in high-speed mode
` [PATCH v10 29/36] phy: core: add notifier infrastructure
` [PATCH v10 30/36] usb: dwc3: core: support PHY reset notifications
` [PATCH v10 31/36] phy: rockchip: usbdp: Add phy reset notification support
` [PATCH v10 32/36] phy: rockchip: usbdp: Drop -EPROBE_DEFER hack
` [PATCH v10 33/36] phy: rockchip: usbdp: Rename mode to hw_mode
` [PATCH v10 34/36] phy: rockchip: usbdp: Simplify power state handling
` [PATCH v10 35/36] phy: rockchip: usbdp: Re-init PHY on mux change
` [PATCH v10 36/36] phy: rockchip: usbdp: Add USB-C state without DP enabled

[PATCH 3/4] arm64: dts: qcom: Add Shikra CQM SoM platform
 2026-07-03 15:32 UTC  (14+ messages)

[PATCH 0/2] dt-bindings: pci: qcom,hawi-pcie: Add Maili PCIe compatibles
 2026-07-03 12:08 UTC  (3+ messages)
` [PATCH 1/2] dt-bindings: pci: qcom,hawi-pcie: Add Maili PCIe compatible
` [PATCH 2/2] dt-bindings: phy: qcom,sc8280xp-qmp-pcie-phy: Add Maili PCIe PHY compatibles

[PATCH v4 0/4] Add USB Phy driver and binding changes for Qualcomm Shikra SoC
 2026-07-02 15:54 UTC  (10+ messages)
` [PATCH v4 1/4] dt-bindings: phy: qcom,qusb2: Document QUSB2 Phy for Shikra
` [PATCH v4 2/4] dt-bindings: phy: qcs615-qmp-usb3dp: Add support for Shikra SoC
` [PATCH v4 3/4] phy: qcom-qusb2: Add support for Shikra
` [PATCH v4 4/4] phy: qcom: qmp-usbc: Add qmp configuration "

[PATCH] phy: renesas: rcar-gen3-usb2: Ignore missing VBUS regulator
 2026-07-02 15:45 UTC  (3+ messages)

[PATCH 0/2] phy: qcom-qusb2: sort out register layouts
 2026-07-02 13:46 UTC  (10+ messages)
` [PATCH 1/2] phy: qcom-qusb2: don't unrelated bits if autoresume is not used
` [PATCH 2/2] phy: qcom-qusb2: fix autoresume handling

[PATCH 0/4 v2] Serdes: s32g: Add support for serdes subsystem
 2026-07-02 12:46 UTC  (3+ messages)

[PATCH V3 0/2] arm64: dts: qcom: Shikra SD Card support
 2026-07-02 12:08 UTC  (5+ messages)
` [PATCH V3 1/2] arm64: dts: qcom: Add SD Card support for Shikra SoC
` [PATCH V3 2/2] arm64: dts: qcom: Enable SD card for Shikra EVK

[PATCH v10 0/5] airoha: an7581: USB support
 2026-07-02 10:26 UTC  (10+ messages)
` [PATCH v10 1/5] dt-bindings: clock: airoha: Add PHY binding for Serdes port
` [PATCH v10 2/5] dt-bindings: phy: Add documentation for Airoha AN7581 USB PHY
` [PATCH v10 3/5] clk: en7523: Add support for selecting the Serdes port in SCU
` [PATCH v10 4/5] phy: move and rename Airoha PCIe PHY driver to dedicated directory
` [PATCH v10 5/5] phy: airoha: Add support for Airoha AN7581 USB PHY

[PATCH v8 0/2] phy: qcom-mipi-csi2: Add a CSI2 MIPI DPHY driver
 2026-07-02  9:28 UTC  (22+ messages)
` [PATCH v8 1/2] dt-bindings: phy: qcom: Add CSI2 C-PHY/DPHY schema
` [PATCH v8 2/2] phy: qcom-mipi-csi2: Add a CSI2 MIPI DPHY driver

[PATCH v4 net-next 0/2] Add multilink SERDES configuration support
 2026-07-02  8:56 UTC  (8+ messages)
` [PATCH v4 net-next 1/2] dt-bindings: phy: cadence-torrent: Update property values to support 3 clocks
` [PATCH v4 net-next 2/2] arm64: dts: ti: Add PLL1 refclk to J784S4 SoC SERDES node

[PATCH V2 0/2] arm64: dts: qcom: Shikra SD Card support
 2026-07-02  6:54 UTC  (7+ messages)
` [PATCH V2 1/2] arm64: dts: qcom: Add SD Card support for Shikra SoC
` [PATCH V2 2/2] arm64: dts: qcom: Enable SD card for Shikra EVK

[PATCH v2 0/4] phy: nuvoton: extend MA35D1 USB2 PHY driver for dual-port OTG support
 2026-07-02  1:49 UTC  (6+ messages)
` [PATCH v2 2/4] dt-bindings: phy: nuvoton,ma35d1-usb2-phy: extend "

[PATCH v9 00/38] phy: rockchip: usbdp: Clean up the mess
 2026-07-02  0:12 UTC  (50+ messages)
` [PATCH v9 01/38] dt-bindings: phy: rockchip-usbdp: add improved ports scheme
` [PATCH v9 02/38] phy: rockchip: usbdp: Update mode_change after error handling
` [PATCH v9 03/38] phy: rockchip: usbdp: Do not lose USB3 PHY status
` [PATCH v9 04/38] phy: rockchip: usbdp: Fix devm_clk_bulk_get_all check
` [PATCH v9 05/38] phy: rockchip: usbdp: Handle missing clock-names DT property gracefully
` [PATCH v9 06/38] phy: rockchip: usbdp: Drop seamless DP takeover
` [PATCH v9 07/38] phy: rockchip: usbdp: Handle rk_udphy_reset_deassert_all errors in init check
` [PATCH v9 08/38] phy: rockchip: usbdp: Keep clocks running on PHY re-init
` [PATCH v9 09/38] phy: rockchip: usbdp: Amend SSC modulation deviation
` [PATCH v9 10/38] phy: rockchip: usbdp: Fix LFPS detect threshold control
` [PATCH v9 11/38] phy: rockchip: usbdp: Add missing mode_change update
` [PATCH v9 12/38] phy: rockchip: usbdp: Support single-lane DP
` [PATCH v9 13/38] phy: rockchip: usbdp: Limit DP lane count to muxed lanes
` [PATCH v9 14/38] phy: rockchip: usbdp: Rename DP lane functions
` [PATCH v9 15/38] phy: rockchip: usbdp: Use FIELD_PREP_WM16_CONST
` [PATCH v9 16/38] phy: rockchip: usbdp: Cleanup DP lane selection function
` [PATCH v9 17/38] phy: rockchip: usbdp: Register DP aux bridge
` [PATCH v9 18/38] phy: rockchip: usbdp: Drop DP HPD handling
` [PATCH v9 19/38] phy: rockchip: usbdp: Rename mode_change to phy_needs_reinit
` [PATCH v9 20/38] phy: rockchip: usbdp: Re-init the PHY on orientation change
` [PATCH v9 21/38] phy: rockchip: usbdp: Factor out lane_mux_sel setup
` [PATCH v9 22/38] phy: rockchip: usbdp: Properly handle TYPEC_STATE_SAFE and TYPEC_STATE_USB
` [PATCH v9 23/38] phy: rockchip: usbdp: Use guard functions for mutex
` [PATCH v9 24/38] phy: rockchip: usbdp: Clear USB status on PHY exit
` [PATCH v9 25/38] phy: rockchip: usbdp: Hold mutex in DP PHY configure
` [PATCH v9 26/38] phy: rockchip: usbdp: Add some extra debug messages
` [PATCH v9 27/38] phy: rockchip: usbdp: Avoid xHCI SErrors
` [PATCH v9 28/38] phy: rockchip: usbdp: Disable USB3 on probe
` [PATCH v9 29/38] phy: rockchip: usbdp: Handle rk_udphy_reset_deassert errors
` [PATCH v9 30/38] phy: rockchip: usbdp: Only enable USB3 when not in high-speed mode
` [PATCH v9 31/38] phy: core: add notifier infrastructure
` [PATCH v9 32/38] usb: dwc3: core: support PHY reset notifications
` [PATCH v9 33/38] phy: rockchip: usbdp: Add phy reset notification support
` [PATCH v9 34/38] phy: rockchip: usbdp: Rename mode to hw_mode
` [PATCH v9 35/38] phy: rockchip: usbdp: Simplify power state handling
` [PATCH v9 36/38] phy: rockchip: usbdp: Rename phy_needs_reinit to orientation_changed
` [PATCH v9 37/38] phy: rockchip: usbdp: Re-init PHY on mux change
` [PATCH v9 38/38] phy: rockchip: usbdp: Power optimizations

[PATCH v4 0/8] phy: rockchip: samsung-hdptx: Clock fixes and API transition cleanups
 2026-07-01 18:50 UTC  (2+ messages)

[PATCH] dt-bindings: phy: mediatek,tphy: Add support for MT8189 SoC
 2026-07-01 16:59 UTC  (3+ messages)

[PATCH 00/12] PHY: MediaTek DP PHY refactor and MT8196 eDP
 2026-07-01 14:38 UTC  (12+ messages)
` [PATCH 01/12] dt-bindings: phy: Document MT8195 and MT8196 DisplayPort PHYs
` [PATCH 02/12] phy: phy-mtk-dp: Rename regs to regmap in struct mtk_dp_phy
` [PATCH 10/12] phy: phy-mtk-dp: Add bitrate register val definitions to SoC data
` [PATCH 11/12] phy: phy-mtk-dp: Add PHYD Lane EN register mask "


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox