On Wed, 2016-06-15 at 13:03 +0200, Thomas Renninger wrote: > Hi Ben, > > On Friday, June 10, 2016 02:05:54 AM Ben Hutchings wrote: > > The current choice of variable names is rather confusing.  LIB_MIN is > > used for the soname version, which would normally be the *major* part > > of the version. > > > > - Rename LIB_MAJ (the full version) to LIB_VER and LIB_MIN (the soname > >   version) to LIB_SONAME_VER > > - Define LIB_SONAME_VER to be the first component of LIB_VER > > - Bump the full version to 1.0.0, since the soname version is currently 1 > > I am currently working on adding rapl/powercapping things into > cpupower. > I will collect/integrate your patches and send them altogether. The ABI break has already happened, so changing the soname version is a bug fix that should go into 4.7.  But I agree this second patch doesn't need to. Ben. -- Ben Hutchings Reality is just a crutch for people who can't handle science fiction.