From: Lukasz Luba <lukasz.luba@arm.com>
To: "Rafael J. Wysocki" <rafael@kernel.org>
Cc: linux-kernel@vger.kernel.org, daniel.lezcano@linaro.org,
linux-pm@vger.kernel.org, rui.zhang@intel.com
Subject: Re: [PATCH v2 3/8] thermal: gov_power_allocator: Move memory allocation out of throttle()
Date: Wed, 20 Dec 2023 16:21:05 +0000 [thread overview]
Message-ID: <18918cb6-2a1d-4a07-a9dc-a1d4de3860c3@arm.com> (raw)
In-Reply-To: <CAJZ5v0j_FNhi_nzBz-n9Dk4_VBm2yiRLnkAS5btNE8cYD+trRQ@mail.gmail.com>
On 12/20/23 14:35, Rafael J. Wysocki wrote:
> On Tue, Dec 12, 2023 at 2:48 PM Lukasz Luba <lukasz.luba@arm.com> wrote:
>>
>> The new thermal callback allows to react to the change of cooling
>> instances in the thermal zone. Move the memory allocation to that new
>> callback and save CPU cycles in the throttle() code path.
>>
>> Signed-off-by: Lukasz Luba <lukasz.luba@arm.com>
>> ---
>> drivers/thermal/gov_power_allocator.c | 144 ++++++++++++++++++++------
>> 1 file changed, 113 insertions(+), 31 deletions(-)
>>
>> diff --git a/drivers/thermal/gov_power_allocator.c b/drivers/thermal/gov_power_allocator.c
>> index 38e1e89ba10c..3328c3ec71f2 100644
>> --- a/drivers/thermal/gov_power_allocator.c
>> +++ b/drivers/thermal/gov_power_allocator.c
>> @@ -61,6 +61,13 @@ static inline s64 div_frac(s64 x, s64 y)
>> * @trip_switch_on should be NULL.
>> * @trip_max: last passive trip point of the thermal zone. The
>> * temperature we are controlling for.
>> + * @num_actors: number of cooling devices supporting IPA callbacks
>> + * @buffer_size: IPA internal buffer size
>> + * @req_power: IPA buffer for requested power
>> + * @max_power: IPA buffer for max allocatable power
>> + * @granted_power: IPA buffer for granted power
>> + * @extra_actor_power: IPA buffer for extra power
>> + * @weighted_req_power: IPA buffer for weighted requested power
>> */
>> struct power_allocator_params {
>> bool allocated_tzp;
>> @@ -69,6 +76,13 @@ struct power_allocator_params {
>> u32 sustainable_power;
>> const struct thermal_trip *trip_switch_on;
>> const struct thermal_trip *trip_max;
>> + int num_actors;
>> + int buffer_size;
>
> None of the above can be negative, so maybe consider using unsigned int?
True, I'll change them to unsigned.
>
>> + u32 *req_power;
>> + u32 *max_power;
>> + u32 *granted_power;
>> + u32 *extra_actor_power;
>> + u32 *weighted_req_power;
>> };
>>
>> /**
>> @@ -387,39 +401,24 @@ static int allocate_power(struct thermal_zone_device *tz, int control_temp)
>> u32 *weighted_req_power;
>> u32 power_range, weight;
>> int total_weight = 0;
>> - int num_actors = 0;
>
> You could retain this local var and set it to params->num_actors. It
> is kind of inconsistent to drop it and still use the local variables
> above.
OK, I'll do that.
[snip]
>> +
>> + req_power = kcalloc(num_actors * 5, sizeof(u32), GFP_KERNEL);
>
> I'd use sizeof(*req_power) instead of sizeof(u32) here and below.
OK
>
>> + if (!req_power) {
>> + ret = -ENOMEM;
>> + goto clean_buffers;
>> + }
>> +
>> + params->num_actors = num_actors;
>> + params->buffer_size = num_actors * 5 * sizeof(u32);
>> +
>> + _power_buffers_init(params, req_power, &req_power[params->num_actors],
>> + &req_power[2 * params->num_actors],
>> + &req_power[3 * params->num_actors],
>> + &req_power[4 * params->num_actors]);
>
> Why don't you use the local var in this instead of the struct member?
> It would be easier to read then IMO.
>
> Also, I would rather use pointer arithmetic, so it would become
>
> _power_buffers_init(params, req_power, req_power + num_actors,
> req_power + 2 * num_actors, req_power + 3 * num_actors, req_power + 4
> * num_actors);
>
> And note that you could introduce something like
>
> struct power_actor {
> u32 req_power;
> u32 max_power;
> u32 granted_power;
> u32 extra_actor_power;
> u32 weighted_req_power;
> };
>
> and use a single array of these instead of 5 different arrays of u32,
> which would result in more straightforward code if I'm not mistaken.
That sounds like a good idea. Let me implement it and see - but it
should be a better way. Thanks!
next prev parent reply other threads:[~2023-12-20 16:20 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-12-12 13:48 [PATCH v2 0/8] Add callback for cooling list update to speed-up IPA Lukasz Luba
2023-12-12 13:48 ` [PATCH v2 1/8] thermal: core: Add governor callback for thermal zone change Lukasz Luba
2023-12-20 13:51 ` Rafael J. Wysocki
2023-12-20 16:17 ` Lukasz Luba
2023-12-20 17:44 ` Rafael J. Wysocki
2023-12-20 17:46 ` Lukasz Luba
2023-12-12 13:48 ` [PATCH v2 2/8] thermal: gov_power_allocator: Refactor check_power_actors() Lukasz Luba
2023-12-12 13:48 ` [PATCH v2 3/8] thermal: gov_power_allocator: Move memory allocation out of throttle() Lukasz Luba
2023-12-20 14:35 ` Rafael J. Wysocki
2023-12-20 16:21 ` Lukasz Luba [this message]
2023-12-12 13:48 ` [PATCH v2 4/8] thermal: gov_power_allocator: Simplify checks for valid power actor Lukasz Luba
2023-12-20 14:40 ` Rafael J. Wysocki
2023-12-20 16:22 ` Lukasz Luba
2023-12-12 13:48 ` [PATCH v2 5/8] thermal: gov_power_allocator: Refactor checks in divvy_up_power() Lukasz Luba
2023-12-20 14:41 ` Rafael J. Wysocki
2023-12-12 13:48 ` [PATCH v2 6/8] thermal/sysfs: Update instance->weight under tz lock Lukasz Luba
2023-12-20 14:53 ` Rafael J. Wysocki
2023-12-20 16:23 ` Lukasz Luba
2023-12-12 13:48 ` [PATCH v2 7/8] thermal/sysfs: Update governors when the 'weight' has changed Lukasz Luba
2023-12-20 14:57 ` Rafael J. Wysocki
2023-12-12 13:48 ` [PATCH v2 8/8] thermal: gov_power_allocator: Support new update callback of weights Lukasz Luba
2023-12-20 14:59 ` Rafael J. Wysocki
2023-12-20 16:14 ` Lukasz Luba
2023-12-20 12:54 ` [PATCH v2 0/8] Add callback for cooling list update to speed-up IPA Lukasz Luba
2023-12-20 13:37 ` Rafael J. Wysocki
2023-12-20 16:25 ` Lukasz Luba
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=18918cb6-2a1d-4a07-a9dc-a1d4de3860c3@arm.com \
--to=lukasz.luba@arm.com \
--cc=daniel.lezcano@linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=rafael@kernel.org \
--cc=rui.zhang@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox