Linux Power Management development
 help / color / mirror / Atom feed
From: Daniel Lezcano <daniel.lezcano@oss.qualcomm.com>
To: rafael@kernel.org
Cc: linux-pm@vger.kernel.org, shuah@kernel.org,
	linux-kselftest@vger.kernel.org,
	manaf.pallikunhi@oss.qualcomm.com
Subject: [PATCH v2 5/6] powercap: dtpm: Rename Rockchip virtual node descriptor
Date: Wed, 23 Sep 2026 16:34:15 +0200	[thread overview]
Message-ID: <20260923143416.3713485-6-daniel.lezcano@oss.qualcomm.com> (raw)
In-Reply-To: <20260923143416.3713485-1-daniel.lezcano@oss.qualcomm.com>

The virtual DTPM node descriptor is named after the RK3399 even though
it does not contain any SoC-specific information.

Rename it to rockchip_virtual so it can be reused by other Rockchip SoC
hierarchies.

No functional change intended.

Signed-off-by: Daniel Lezcano <daniel.lezcano@oss.qualcomm.com>
---
 drivers/soc/rockchip/dtpm.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/soc/rockchip/dtpm.c b/drivers/soc/rockchip/dtpm.c
index 451417ae5715..5f7f238a15fe 100644
--- a/drivers/soc/rockchip/dtpm.c
+++ b/drivers/soc/rockchip/dtpm.c
@@ -11,7 +11,7 @@
 #include <linux/of.h>
 #include <linux/platform_device.h>
 
-static struct dtpm_node rk3399_virtual = {
+static struct dtpm_node rockchip_virtual = {
 	.type = DTPM_NODE_VIRTUAL,
 };
 
@@ -33,12 +33,12 @@ static struct dtpm_node rk3399_gpu = {
 static struct powercap_node __initdata rk3399_nodes[] = {
 	[0] = {
 		.name = "rk3399",
-		.data = &rk3399_virtual,
+		.data = &rockchip_virtual,
 	},
 	[1] = {
 		.name = "package",
 		.parent = &rk3399_nodes[0],
-		.data = &rk3399_virtual,
+		.data = &rockchip_virtual,
 	},
 	[2] = {
 		.name = "cpu0-cpufreq",
-- 
2.43.0


  parent reply	other threads:[~2026-09-23 14:34 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-23 14:34 [PATCH v2 0/6] powercap: Add generic hierarchy support and convert DTPM Daniel Lezcano
2026-09-23 14:34 ` [PATCH v2 1/6] powercap: Add generic zone hierarchy creation helpers Daniel Lezcano
2026-09-29 18:02   ` Rafael J. Wysocki (Intel)
2026-09-23 14:34 ` [PATCH v2 2/6] selftests/powercap: Add powercap hierarchy creation API tests Daniel Lezcano
2026-09-23 14:34 ` [PATCH v2 3/6] powercap: dtpm: Remove duplicate RK3399 CPU hierarchy nodes Daniel Lezcano
2026-09-23 14:34 ` [PATCH v2 4/6] powercap: dtpm: Use generic powercap hierarchy helpers Daniel Lezcano
2026-09-23 14:34 ` Daniel Lezcano [this message]
2026-09-23 14:34 ` [PATCH v2 6/6] powercap: dtpm: Add RK3588 hierarchy Daniel Lezcano
2026-09-28 21:13 ` [PATCH v2 0/6] powercap: Add generic hierarchy support and convert DTPM Daniel Lezcano

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260923143416.3713485-6-daniel.lezcano@oss.qualcomm.com \
    --to=daniel.lezcano@oss.qualcomm.com \
    --cc=linux-kselftest@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=manaf.pallikunhi@oss.qualcomm.com \
    --cc=rafael@kernel.org \
    --cc=shuah@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox