Linux PWM subsystem development
 help / color / mirror / Atom feed
 messages from 2026-06-25 14:31:34 to 2026-07-06 10:39:37 UTC [more...]

[PATCH v1 0/5] pwm: Unify arrays of various *_device_id
 2026-07-06 10:39 UTC  (11+ messages)
` [PATCH v1 1/5] pwm: pca9685: Drop unused assignment of acpi_device_id driver data
` [PATCH v1 2/5] pwm: Use named initializers for arrays of acpi_device_id
` [PATCH v1 3/5] pwm: Unify coding style of acpi_device_id arrays
` [PATCH v1 4/5] pwm: Unify coding style of of_device_id arrays
` [PATCH v1 5/5] pwm: lpss-pci: Unify coding style of pci_device_id array

[PATCH v2 0/2] pwm: loongson: Fix PWM configuration handling
 2026-07-06  8:03 UTC  (5+ messages)
` [PATCH v2 1/2] pwm: loongson: Fix low pulse buffer register handling
` [PATCH v2 2/2] pwm: loongson: Reload PWM configuration through counter reset

[PATCH] pwm: th1520: use vertical import style
 2026-07-06  2:52 UTC 

[PATCH v5 00/20] rust: I/O type generalization and projection
 2026-07-06  1:02 UTC  (51+ messages)
` [PATCH v5 01/20] rust: io: add dynamically-sized `Region` type
` [PATCH v5 02/20] rust: io: add missing safety requirement in `IoCapable` methods
` [PATCH v5 03/20] rust: io: restrict untyped IO access and `register!` to `Region`
` [PATCH v5 04/20] rust: io: implement `Io` on reference types instead
` [PATCH v5 05/20] rust: io: generalize `MmioRaw` to pointer to arbitrary type
` [PATCH v5 06/20] rust: io: rename `Mmio` to `MmioOwned`
` [PATCH v5 07/20] rust: io: implement `Mmio` as view type
` [PATCH v5 08/20] rust: pci: io: make `ConfigSpace` a view
` [PATCH v5 09/20] rust: io: use view types instead of addresses for `Io`
` [PATCH v5 10/20] pwm: th1520: remove unnecessary `deref`
` [PATCH v5 11/20] rust: io: remove `MmioOwned`
` [PATCH v5 12/20] rust: io: move `Io` methods to extension trait
` [PATCH v5 13/20] rust: io: add projection macro and methods
` [PATCH v5 14/20] rust: io: add I/O backend for system memory with volatile access
` [PATCH v5 15/20] rust: io: implement a view type for `Coherent`
` [PATCH v5 16/20] rust: io: add `read_val` and `write_val` functions on `Io`
` [PATCH v5 17/20] gpu: nova-core: use I/O projection for cleaner encapsulation
` [PATCH v5 18/20] rust: dma: drop `dma_read!` and `dma_write!` API
` [PATCH v5 19/20] rust: io: add copying methods
` [PATCH v5 20/20] rust: io: implement `IoSysMap`

[PATCH 0/7] rust: Use kernel style vertical imports in various drivers
 2026-07-05 15:03 UTC  (19+ messages)
` [PATCH 1/7] samples: rust_dma: use vertical import style
` [PATCH 2/7] pwm: th1520: "
` [PATCH 3/7] cpufreq: rcpufreq_dt: "
` [PATCH 4/7] block: rnull: "
` [PATCH 5/7] net: phy: ax88796b: "
` [PATCH 6/7] net: phy: qt2025: "
` [PATCH 7/7] drm/nova: "

[PATCH 00/10] Initial Apple silicon M4 device trees and dt-bindings
 2026-07-05 13:17 UTC  (11+ messages)
` [PATCH 01/10] dt-bindings: arm: cpus: Add Apple M4 CPU core compatibles
` [PATCH 02/10] dt-bindings: interrupt-controller: apple,aic2: Add apple,t8132 compatible
` [PATCH 03/10] dt-bindings: watchdog: apple,wdt: Add t8132 compatible
` [PATCH 04/10] dt-bindings: arm: apple: apple,pmgr: "
` [PATCH 05/10] dt-bindings: power: apple,pmgr-pwrstate: "
` [PATCH 06/10] dt-bindings: pinctrl: apple,pinctrl: "
` [PATCH 07/10] dt-bindings: i2c: apple,i2c: "
` [PATCH 08/10] dt-bindings: pwm: apple,s5l-fpwm: "
` [PATCH 09/10] dt-bindings: arm: apple: Add M4 based devices
` [PATCH 10/10] arm64: dts: apple: Add minimal t8132 (M4) device trees

[PATCH] pwm: pxa: Depend on OF and simplify accordingly
 2026-07-05  8:39 UTC 

[PATCH v1] pwm: Use named initializers for platform_device_id arrays
 2026-07-03 21:28 UTC  (2+ messages)

[PATCH] pwm: mc33xs2410: Initialize spi_device_id arrays using member names
 2026-07-03 21:21 UTC  (2+ messages)

[PATCH v6 0/3] Add RP1 PWM controller support
 2026-07-03 17:05 UTC  (4+ messages)
` [PATCH v6 1/3] dt-bindings: pwm: Add Raspberry Pi RP1 PWM controller
` [PATCH v6 2/3] pwm: rp1: Add RP1 PWM controller driver
` [PATCH v6 3/3] arm64: dts: broadcom: rpi-5: Add RP1 PWM node

[PATCH v5 0/3] Add RP1 PWM controller support
 2026-07-03 16:38 UTC  (12+ messages)
` [PATCH v5 1/3] dt-bindings: pwm: Add Raspberry Pi RP1 PWM controller
` [PATCH v5 2/3] pwm: rp1: Add RP1 PWM controller driver

[PATCH v7 0/4] Introduce Allwinner H616 PWM controller
 2026-07-03 16:00 UTC  (6+ messages)
` [PATCH v7 1/4] dt-bindings: pwm: allwinner: add h616 pwm compatible
` [PATCH v7 2/4] pwm: sun8i: Add H616 PWM support
` [PATCH v7 3/4] arm64: dts: allwinner: h616: add PWM controller
` [PATCH v7 4/4] MAINTAINERS: Add entry on Allwinner sun8i/H616 PWM driver

[PATCH v10 0/3] Update designware pwm driver
 2026-07-03  9:34 UTC  (4+ messages)
` [PATCH v10 1/3] dt-bindings: pwm: dwc: Document optional resets property
` [PATCH v10 2/3] dt-bindings: pwm: dwc: Add eswin compatible
` [PATCH v10 3/3] pwm: dwc: add of/platform support

[PATCH v21 0/6] Add PWM support for IPQ chipsets
 2026-07-02 23:40 UTC  (2+ messages)
` (subset) "

[PATCH v9 0/3] Update designware pwm driver
 2026-07-02  9:25 UTC  (5+ messages)
` [PATCH v9 1/3] dt-bindings: pwm: dwc: Document optional resets property
` [PATCH v9 2/3] dt-bindings: pwm: dwc: Add eswin compatible
` [PATCH v9 3/3] pwm: dwc: add of/platform support
    `  "

[PATCH v21 0/3] Add OpenCores PTC PWM support
 2026-07-01  7:44 UTC  (4+ messages)
` [PATCH v21 1/3] dt-bindings: pwm: opencores: Update compatibles, examples and maintainers
` [PATCH v21 2/3] riscv: dts: starfive: Correct pwm nodes
` [PATCH v21 3/3] pwm: Add OpenCores PTC PWM driver

[PATCH v6 0/7] Tegra264 PWM support
 2026-07-01  3:20 UTC  (8+ messages)
` [PATCH v6 1/7] dt-bindings: pwm: Document Tegra264 controller
` [PATCH v6 2/7] pwm: tegra: Prefix driver-local macros and functions
` [PATCH v6 3/7] pwm: tegra: Avoid hard-coded max clock frequency
` [PATCH v6 4/7] pwm: tegra: Modify read/write accessors for multi-register channel
` [PATCH v6 5/7] pwm: tegra: Parametrize duty and scale field widths
` [PATCH v6 6/7] pwm: tegra: Add support for Tegra264
` [PATCH v6 7/7] arm64: tegra: Add PWM controllers on Tegra264

[PATCH v5 0/7] Tegra264 PWM support
 2026-07-01  2:34 UTC  (5+ messages)

[PATCH v4 0/7] ForLt/CovariantForLt split, auxiliary closure API and DevresLt
 2026-06-30 13:50 UTC  (13+ messages)
` [PATCH v4 1/7] rust: types: rename ForLt to CovariantForLt
` [PATCH v4 2/7] rust: types: introduce ForLt base trait for CovariantForLt
` [PATCH v4 3/7] rust: auxiliary: add registration_data_with() for ForLt types
` [PATCH v4 4/7] rust: auxiliary: sample: demonstrate ForLt with invariant Mutex type
` [PATCH v4 5/7] rust: devres: add DevresLt for ForLt-aware device resource access
` [PATCH v4 6/7] rust: pci: return DevresLt from Bar::into_devres()
` [PATCH v4 7/7] rust: io: mem: return DevresLt from IoMem/ExclusiveIoMem::into_devres()

[PATCH v20 0/3] Add OpenCores PTC PWM support
 2026-06-30  9:59 UTC  (8+ messages)
` [PATCH v20 1/3] dt-bindings: pwm: opencores: Update compatibles, examples and maintainers
` [PATCH v20 2/3] riscv: dts: starfive: Correct pwm nodes
` [PATCH v20 3/3] pwm: Add OpenCores PTC PWM driver

[PATCH v5] dt-bindings: pwm: st,sti-pwm: convert to DT schema
 2026-06-30  6:32 UTC  (2+ messages)

[PATCH v6] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
 2026-06-29 14:37 UTC  (2+ messages)

[PATCH v2 00/12] rust: driver: use pointers instead of indices for ID info
 2026-06-29 12:41 UTC  (2+ messages)

[PATCH v2 00/11] rust: driver: use pointers instead of indices for ID info
 2026-06-29 12:39 UTC  (12+ messages)
` [PATCH v2 01/11] rust: driver: remove `IdTable::id`
` [PATCH v2 02/11] rust: driver: simplify `IdArray::new_without_index`
` [PATCH v2 03/11] rust: pci: use `Option<&IdInfo>` for device ID info
` [PATCH v2 04/11] rust: usb: "
` [PATCH v2 05/11] rust: net/phy: remove expansion from doc
` [PATCH v2 06/11] rust: driver: centralize device ID handling
` [PATCH v2 07/11] rust: driver: remove `$module_table_name` from `module_device_table`
` [PATCH v2 08/11] rust: driver: store pointers in `DeviceId`
` [PATCH v2 09/11] rust: driver: remove open-coded matching logic
` [PATCH v2 10/11] rust: driver: remove duplicate ID table
` [PATCH v2 11/11] RFC: rust: driver: support map-like syntax for "

[PATCH v19 0/3] Add OpenCores PTC PWM support
 2026-06-29  2:09 UTC  (4+ messages)
` [PATCH v19 1/3] dt-bindings: pwm: opencores: Update compatibles, examples and maintainers

[PATCH v7] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
 2026-06-29  4:39 UTC  (2+ messages)

[PATCH v3 0/2] rust: clk: Add ExclusiveClk and use it in pwm-th1520
 2026-06-28 20:17 UTC  (3+ messages)
` [PATCH v3 1/2] rust: clk: Add `ExclusiveClk` wrapper for `clk_rate_exclusive_get`
` [PATCH v3 2/2] pwm: th1520: Lock clock rate with clk_rate_exclusive_get

[PATCH v4 0/3] Clk improvements
 2026-06-28 20:15 UTC  (3+ messages)
` [PATCH v4 1/3] rust: clk: use the type-state pattern

[GIT PULL] pwm: Changes for 7.2-rc1 (batch 2)
 2026-06-27 21:13 UTC  (2+ messages)

[PATCH v19 0/8] rust: add `Ownable` trait and `Owned` type
 2026-06-26 11:54 UTC  (9+ messages)
` [PATCH v19 1/8] rust: alloc: add `KBox::into_non_null`
` [PATCH v19 2/8] rust: types: Add Ownable/Owned types
` [PATCH v19 3/8] rust: implement `ForeignOwnable` for `Owned`
` [PATCH v19 4/8] rust: page: convert to `Ownable`
` [PATCH v19 5/8] rust: rename `AlwaysRefCounted` to `RefCounted`
` [PATCH v19 6/8] rust: Add missing SAFETY documentation for `ARef` example
` [PATCH v19 7/8] rust: Add `OwnableRefCounted`
` [PATCH v19 8/8] rust: page: add `from_raw()`

[PATCH v4] dt-bindings: pwm: st,sti-pwm: convert to DT schema
 2026-06-26  8:31 UTC  (2+ messages)

[PATCH v18 0/8] rust: add `Ownable` trait and `Owned` type
 2026-06-25 19:47 UTC  (4+ messages)
` [PATCH v18 3/8] rust: implement `ForeignOwnable` for `Owned`

[PATCH v3 0/7] ForLt/CovariantForLt split, auxiliary closure API and DevresLt
 2026-06-25 14:31 UTC  (3+ messages)
` [PATCH v3 5/7] rust: devres: add DevresLt for ForLt-aware device resource access


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox