Linux PWM subsystem development
 help / color / mirror / Atom feed
From: Thierry Reding <thierry.reding@gmail.com>
To: "Uwe Kleine-König" <u.kleine-koenig@pengutronix.de>
Cc: Laurent Pinchart <laurent.pinchart@ideasonboard.com>,
	Simon Horman <horms+renesas@verge.net.au>,
	Geert Uytterhoeven <geert+renesas@glider.be>,
	Magnus Damm <magnus.damm@gmail.com>,
	Lee Jones <lee.jones@linaro.org>,
	linux-renesas-soc@vger.kernel.org, linux-pwm@vger.kernel.org,
	kernel@pengutronix.de
Subject: Re: [PATCH v2 0/6] pwm: renesas-tpu: Various improvements
Date: Fri, 20 May 2022 16:19:28 +0200	[thread overview]
Message-ID: <YoejcKmXGbKUJkJd@orome> (raw)
In-Reply-To: <20220420121240.67781-1-u.kleine-koenig@pengutronix.de>

[-- Attachment #1: Type: text/plain, Size: 1401 bytes --]

On Wed, Apr 20, 2022 at 02:12:34PM +0200, Uwe Kleine-König wrote:
> Hello,
> 
> I reworked the series to improve the renesas-tpu PWM driver after
> feedback I got from Geert. The changes are:
> 
>  - Add Geert's tags for the first two patches
>    (I didn't add them for the other patches as I changed these enough to
>    not carry the tags forward.)
>  - Use tpu_pwm_disable instead chip->ops->disable (which is NULL now)
>    fixing a crash in v1.
>  - The calculation now uses a switch instead of ilog2.
>    Looking at the compiled code for ARM this is more effective and I
>    assume the same holds true for other platforms.
> 
> Thanks again to Geert for his valuable feedback and testing.
> 
> Best regards
> Uwe
> 
> Uwe Kleine-König (6):
>   pwm: renesas-tpu: Make use of dev_err_probe()
>   pwm: renesas-tpu: Make use of devm functions
>   pwm: renesas-tpu: Implement .apply() callback
>   pwm: renesas-tpu: Rename variables to match the usual naming
>   pwm: renesas-tpu: Improve maths to compute register settings
>   pwm: renesas-tpu: Improve precision of period and duty_cycle
>     calculation
> 
>  drivers/pwm/pwm-renesas-tpu.c | 317 +++++++++++++++++++---------------
>  1 file changed, 180 insertions(+), 137 deletions(-)

Applied, with the checkpatch warning in patch 5/6 addressed (I opted to
replace the tabs by spaces).

Thanks,
Thierry

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

      parent reply	other threads:[~2022-05-20 14:19 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-04-20 12:12 [PATCH v2 0/6] pwm: renesas-tpu: Various improvements Uwe Kleine-König
2022-04-20 12:12 ` [PATCH v2 1/6] pwm: renesas-tpu: Make use of dev_err_probe() Uwe Kleine-König
2022-04-20 12:12 ` [PATCH v2 2/6] pwm: renesas-tpu: Make use of devm functions Uwe Kleine-König
2022-04-20 12:12 ` [PATCH v2 3/6] pwm: renesas-tpu: Implement .apply() callback Uwe Kleine-König
2022-04-20 18:07   ` Geert Uytterhoeven
2022-04-20 12:12 ` [PATCH v2 4/6] pwm: renesas-tpu: Rename variables to match the usual naming Uwe Kleine-König
2022-04-20 12:25   ` Geert Uytterhoeven
2022-04-20 12:12 ` [PATCH v2 5/6] pwm: renesas-tpu: Improve maths to compute register settings Uwe Kleine-König
2022-04-20 18:08   ` Geert Uytterhoeven
2022-06-19 20:03     ` Uwe Kleine-König
2022-04-20 12:12 ` [PATCH v2 6/6] pwm: renesas-tpu: Improve precision of period and duty_cycle calculation Uwe Kleine-König
2022-04-20 18:10   ` Geert Uytterhoeven
2022-04-20 18:12 ` [PATCH v2 0/6] pwm: renesas-tpu: Various improvements Geert Uytterhoeven
2022-05-20 14:19 ` Thierry Reding [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=YoejcKmXGbKUJkJd@orome \
    --to=thierry.reding@gmail.com \
    --cc=geert+renesas@glider.be \
    --cc=horms+renesas@verge.net.au \
    --cc=kernel@pengutronix.de \
    --cc=laurent.pinchart@ideasonboard.com \
    --cc=lee.jones@linaro.org \
    --cc=linux-pwm@vger.kernel.org \
    --cc=linux-renesas-soc@vger.kernel.org \
    --cc=magnus.damm@gmail.com \
    --cc=u.kleine-koenig@pengutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox