From mboxrd@z Thu Jan 1 00:00:00 1970 From: Zhen Lei Subject: [PATCH 1/4] block: Move SECTORS_PER_PAGE and SECTORS_PER_PAGE_SHIFT definitions into Date: Tue, 5 May 2020 19:55:40 +0800 Message-ID: <20200505115543.1660-2-thunder.leizhen@huawei.com> References: <20200505115543.1660-1-thunder.leizhen@huawei.com> Mime-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Content-Transfer-Encoding: 7BIT Return-path: In-Reply-To: <20200505115543.1660-1-thunder.leizhen@huawei.com> Sender: linux-kernel-owner@vger.kernel.org To: Minchan Kim , Nitin Gupta , Sergey Senozhatsky , Jens Axboe , linux-block , Andrew Morton , linux-mm , Alasdair Kergon , Mike Snitzer , dm-devel , Song Liu , linux-raid , linux-kernel Cc: Zhen Lei List-Id: linux-raid.ids This is similar to commit 233bde21a ("block: Move SECTOR_SIZE and SECTOR_SHIFT definitions into "), prepare to clear dozens of duplicated codes. Signed-off-by: Zhen Lei --- drivers/block/zram/zram_drv.h | 2 -- include/linux/blkdev.h | 10 ++++++++-- 2 files changed, 8 insertions(+), 4 deletions(-) diff --git a/drivers/block/zram/zram_drv.h b/drivers/block/zram/zram_drv.h index f2fd46daa760..12309175d55e 100644 --- a/drivers/block/zram/zram_drv.h +++ b/drivers/block/zram/zram_drv.h @@ -21,8 +21,6 @@ #include "zcomp.h" -#define SECTORS_PER_PAGE_SHIFT (PAGE_SHIFT - SECTOR_SHIFT) -#define SECTORS_PER_PAGE (1 << SECTORS_PER_PAGE_SHIFT) #define ZRAM_LOGICAL_BLOCK_SHIFT 12 #define ZRAM_LOGICAL_BLOCK_SIZE (1 << ZRAM_LOGICAL_BLOCK_SHIFT) #define ZRAM_SECTOR_PER_LOGICAL_BLOCK \ diff --git a/include/linux/blkdev.h b/include/linux/blkdev.h index 32868fbedc9e..a752e1c80bf0 100644 --- a/include/linux/blkdev.h +++ b/include/linux/blkdev.h @@ -904,10 +904,16 @@ static inline struct request_queue *bdev_get_queue(struct block_device *bdev) * multiple of 512 bytes. Hence these two constants. */ #ifndef SECTOR_SHIFT -#define SECTOR_SHIFT 9 +#define SECTOR_SHIFT 9 #endif #ifndef SECTOR_SIZE -#define SECTOR_SIZE (1 << SECTOR_SHIFT) +#define SECTOR_SIZE (1 << SECTOR_SHIFT) +#endif +#ifndef SECTORS_PER_PAGE_SHIFT +#define SECTORS_PER_PAGE_SHIFT (PAGE_SHIFT - SECTOR_SHIFT) +#endif +#ifndef SECTORS_PER_PAGE +#define SECTORS_PER_PAGE (1 << SECTORS_PER_PAGE_SHIFT) #endif /* -- 2.26.0.106.g9fadedd