From mboxrd@z Thu Jan 1 00:00:00 1970 From: Matthew Wilcox Subject: Re: [PATCH 1/4] block: Move SECTORS_PER_PAGE and SECTORS_PER_PAGE_SHIFT definitions into Date: Tue, 5 May 2020 05:10:43 -0700 Message-ID: <20200505121043.GG16070@bombadil.infradead.org> References: <20200505115543.1660-1-thunder.leizhen@huawei.com> <20200505115543.1660-2-thunder.leizhen@huawei.com> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii Return-path: Content-Disposition: inline In-Reply-To: <20200505115543.1660-2-thunder.leizhen@huawei.com> Sender: linux-block-owner@vger.kernel.org To: Zhen Lei Cc: Minchan Kim , Nitin Gupta , Sergey Senozhatsky , Jens Axboe , linux-block , Andrew Morton , linux-mm , Alasdair Kergon , Mike Snitzer , dm-devel , Song Liu , linux-raid , linux-kernel List-Id: linux-raid.ids On Tue, May 05, 2020 at 07:55:40PM +0800, Zhen Lei wrote: > +#ifndef SECTORS_PER_PAGE_SHIFT > +#define SECTORS_PER_PAGE_SHIFT (PAGE_SHIFT - SECTOR_SHIFT) > +#endif > +#ifndef SECTORS_PER_PAGE > +#define SECTORS_PER_PAGE (1 << SECTORS_PER_PAGE_SHIFT) > #endif I find SECTORS_PER_PAGE_SHIFT quite hard to read. I had a quick skim of your other patches, and it seems to me that we could replace '<< SECTORS_PER_PAGE_SHIFT' with '* SECTORS_PER_PAGE' and it would be more readable in every case.