From mboxrd@z Thu Jan 1 00:00:00 1970 From: "Leizhen (ThunderTown)" Subject: Re: [PATCH 1/4] block: Move SECTORS_PER_PAGE and SECTORS_PER_PAGE_SHIFT definitions into Date: Wed, 6 May 2020 12:06:12 +0800 Message-ID: <8ec2a734-d23a-83ef-fe06-6b2895a2d392@huawei.com> References: <20200505115543.1660-1-thunder.leizhen@huawei.com> <20200505115543.1660-2-thunder.leizhen@huawei.com> <20200505121043.GG16070@bombadil.infradead.org> Mime-Version: 1.0 Content-Type: text/plain; charset="utf-8" Content-Transfer-Encoding: 7bit Return-path: In-Reply-To: <20200505121043.GG16070@bombadil.infradead.org> Content-Language: en-US Sender: linux-block-owner@vger.kernel.org To: Matthew Wilcox Cc: Minchan Kim , Nitin Gupta , Sergey Senozhatsky , Jens Axboe , linux-block , Andrew Morton , linux-mm , Alasdair Kergon , Mike Snitzer , dm-devel , Song Liu , linux-raid , linux-kernel List-Id: linux-raid.ids On 2020/5/5 20:10, Matthew Wilcox wrote: > On Tue, May 05, 2020 at 07:55:40PM +0800, Zhen Lei wrote: >> +#ifndef SECTORS_PER_PAGE_SHIFT >> +#define SECTORS_PER_PAGE_SHIFT (PAGE_SHIFT - SECTOR_SHIFT) >> +#endif >> +#ifndef SECTORS_PER_PAGE >> +#define SECTORS_PER_PAGE (1 << SECTORS_PER_PAGE_SHIFT) >> #endif > > I find SECTORS_PER_PAGE_SHIFT quite hard to read. I had a quick skim > of your other patches, and it seems to me that we could replace > '<< SECTORS_PER_PAGE_SHIFT' with '* SECTORS_PER_PAGE' and it would be > more readable in every case. OK, I will delete SECTORS_PER_PAGE_SHIFT, and replace the shift with {*|/} SECTORS_PER_PAGE if it's not suitable to be replaced by sectors_to_page()/page_to_sectors(). > > . >