From mboxrd@z Thu Jan 1 00:00:00 1970 From: "Vishwanathapura, Niranjana" Subject: Re: [RFC v1 for accelerated IPoIB 04/25] IB/verb: Add ipoib_options struct and API Date: Wed, 15 Mar 2017 09:42:19 -0700 Message-ID: <20170315164219.GB81782@knc-06.sc.intel.com> References: <1489429896-10781-1-git-send-email-erezsh@mellanox.com> <1489429896-10781-5-git-send-email-erezsh@mellanox.com> <20170313200136.GA2738@obsidianresearch.com> <20170314190300.GA80705@knc-06.sc.intel.com> <20170315062728.GB2079@mtr-leonro.local> Mime-Version: 1.0 Content-Type: text/plain; charset=us-ascii; format=flowed Return-path: Content-Disposition: inline In-Reply-To: <20170315062728.GB2079-U/DQcQFIOTAAJjI8aNfphQ@public.gmane.org> Sender: linux-rdma-owner-u79uwXL29TY76Z2rM5mHXA@public.gmane.org To: Leon Romanovsky Cc: Erez Shitrit , Jason Gunthorpe , Erez Shitrit , Doug Ledford , "linux-rdma-u79uwXL29TY76Z2rM5mHXA@public.gmane.org" , valex-VPRAkNaXOzVWk0Htik3J/w@public.gmane.org List-Id: linux-rdma@vger.kernel.org On Wed, Mar 15, 2017 at 08:27:28AM +0200, Leon Romanovsky wrote: >On Tue, Mar 14, 2017 at 12:03:01PM -0700, Vishwanathapura, Niranjana wrote: >> On Tue, Mar 14, 2017 at 03:25:01PM +0200, Erez Shitrit wrote: >> > On Mon, Mar 13, 2017 at 10:01 PM, Jason Gunthorpe >> > wrote: >> > > On Mon, Mar 13, 2017 at 08:31:15PM +0200, Erez Shitrit wrote: >> > > >> > > > diff --git a/include/rdma/ib_ipoib_accel_ops.h b/include/rdma/ib_ipoib_accel_ops.h >> > > > new file mode 100644 >> > > > index 000000000000..148a5529a559 >> > > > +++ b/include/rdma/ib_ipoib_accel_ops.h >> > > >> > > Both patches need a better naming scheme for this file.. >> > > >> > > rn_opa_vnic.h >> > > rn_ipoib.h >> > > >> > > Maybe? >> > >> > Can work for me. >> > >> > vnic? >> > >> >> I do see why it is an issue for ipoib (we don't want two ipoib.h files). We >> can add rn_ prefix for vnic, but probably opa_vnic.h is good enough. > >Just for the consistency, I would like to see the same "rn_" prefix >for both files (ipoib and opa_vnic). > >Thanks Fine with VNIC. Niranjana -- To unsubscribe from this list: send the line "unsubscribe linux-rdma" in the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org More majordomo info at http://vger.kernel.org/majordomo-info.html