From: Leon Romanovsky <leon@kernel.org>
To: Jason Gunthorpe <jgg@ziepe.ca>
Cc: Doug Ledford <dledford@redhat.com>,
Maor Gottlieb <maorg@mellanox.com>,
linux-rdma@vger.kernel.org,
Potnuri Bharat Teja <bharat@chelsio.com>
Subject: Re: [PATCH rdma-next 09/14] RDMA: Add a dedicated QP resource tracker function
Date: Mon, 25 May 2020 19:26:55 +0300 [thread overview]
Message-ID: <20200525162655.GD10591@unreal> (raw)
In-Reply-To: <20200525143447.GA21596@ziepe.ca>
On Mon, May 25, 2020 at 11:34:47AM -0300, Jason Gunthorpe wrote:
> On Wed, May 13, 2020 at 12:50:29PM +0300, Leon Romanovsky wrote:
> > From: Maor Gottlieb <maorg@mellanox.com>
> >
> > In order to avoid double multiplexing of the resource when it's QP,
> > add a dedicated callback function.
> >
> > Signed-off-by: Maor Gottlieb <maorg@mellanox.com>
> > Signed-off-by: Leon Romanovsky <leonro@mellanox.com>
> > drivers/infiniband/core/device.c | 1 +
> > drivers/infiniband/core/nldev.c | 2 +-
> > drivers/infiniband/core/restrack.c | 2 ++
> > drivers/infiniband/hw/cxgb4/iw_cxgb4.h | 1 +
> > drivers/infiniband/hw/cxgb4/restrack.c | 5 +----
> > include/rdma/ib_verbs.h | 1 +
> > 6 files changed, 7 insertions(+), 5 deletions(-)
> >
> > diff --git a/drivers/infiniband/core/device.c b/drivers/infiniband/core/device.c
> > index 1f9f44e62e49..23af3cc27ee1 100644
> > +++ b/drivers/infiniband/core/device.c
> > @@ -2619,6 +2619,7 @@ void ib_set_device_ops(struct ib_device *dev, const struct ib_device_ops *ops)
> > SET_DEVICE_OP(dev_ops, fill_res_cq_entry);
> > SET_DEVICE_OP(dev_ops, fill_res_entry);
> > SET_DEVICE_OP(dev_ops, fill_res_mr_entry);
> > + SET_DEVICE_OP(dev_ops, fill_res_qp_entry);
> > SET_DEVICE_OP(dev_ops, fill_stat_mr_entry);
> > SET_DEVICE_OP(dev_ops, get_dev_fw_str);
> > SET_DEVICE_OP(dev_ops, get_dma_mr);
> > diff --git a/drivers/infiniband/core/nldev.c b/drivers/infiniband/core/nldev.c
> > index 6207b68453a1..8c748888bf28 100644
> > +++ b/drivers/infiniband/core/nldev.c
> > @@ -499,7 +499,7 @@ static int fill_res_qp_entry(struct sk_buff *msg, bool has_cap_net_admin,
> > if (fill_res_name_pid(msg, res))
> > goto err;
> >
> > - return dev->ops.fill_res_entry(msg, res);
> > + return dev->ops.fill_res_qp_entry(msg, qp);
> >
> > err: return -EMSGSIZE;
> > }
> > diff --git a/drivers/infiniband/core/restrack.c b/drivers/infiniband/core/restrack.c
> > index 031a4f94400e..33d7c0888753 100644
> > +++ b/drivers/infiniband/core/restrack.c
> > @@ -29,11 +29,13 @@ static int fill_res_dummy(struct sk_buff *msg,
> >
> > FILL_DUMMY(mr);
> > FILL_DUMMY(cq);
> > +FILL_DUMMY(qp);
>
> Lists of things should be sorted
I will fix.
>
> > static const struct ib_device_ops restrack_dummy_ops = {
> > .fill_res_cq_entry = fill_res_cq,
> > .fill_res_entry = fill_res_dummy,
> > .fill_res_mr_entry = fill_res_mr,
> > + .fill_res_qp_entry = fill_res_qp,
> > .fill_stat_mr_entry = fill_res_mr,
> > };
>
> Here too
>
> I'm also not sure the FILL_DUMMY obfuscation is worthwhile for 3
> functions.
At the end, we removed a lot of duplicated code, despite adding code the
diffstat shows that we added not so much code after all.
17 files changed, 258 insertions(+), 201 deletions(-)
>
> > @@ -2571,6 +2571,7 @@ struct ib_device_ops {
> > struct rdma_restrack_entry *entry);
> > int (*fill_res_mr_entry)(struct sk_buff *msg, struct ib_mr *ibmr);
> > int (*fill_res_cq_entry)(struct sk_buff *msg, struct ib_cq *ibcq);
> > + int (*fill_res_qp_entry)(struct sk_buff *msg, struct ib_qp *ibqp);
>
> Sorted too
I will fix.
>
> Jason
next prev parent reply other threads:[~2020-05-25 16:27 UTC|newest]
Thread overview: 32+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-05-13 9:50 [PATCH rdma-next 00/14] RAW format dumps through RDMAtool Leon Romanovsky
2020-05-13 9:50 ` [PATCH mlx5-next 01/14] net/mlx5: Export resource dump interface Leon Romanovsky
2020-05-25 14:24 ` Jason Gunthorpe
2020-05-25 15:25 ` Maor Gottlieb
2020-05-13 9:50 ` [PATCH mlx5-next 02/14] net/mlx5: Add support in query QP, CQ and MKEY segments Leon Romanovsky
2020-05-13 9:50 ` [PATCH rdma-next 03/14] RDMA/core: Fix double put of resource Leon Romanovsky
2020-05-13 9:50 ` [PATCH rdma-next 04/14] RDMA/core: Allow to override device op Leon Romanovsky
2020-05-25 14:26 ` Jason Gunthorpe
2020-05-25 16:28 ` Leon Romanovsky
2020-05-25 23:21 ` Kamal Heib
2020-05-26 5:53 ` Leon Romanovsky
2020-05-26 8:07 ` Kamal Heib
2020-05-26 9:44 ` Leon Romanovsky
2020-05-13 9:50 ` [PATCH rdma-next 05/14] RDMA/core: Don't call fill_res_entry for PD Leon Romanovsky
2020-05-13 9:50 ` [PATCH rdma-next 06/14] RDMA/core: Add restrack dummy ops Leon Romanovsky
2020-05-25 14:36 ` Jason Gunthorpe
2020-05-25 16:23 ` Leon Romanovsky
2020-05-13 9:50 ` [PATCH rdma-next 07/14] RDMA: Add dedicated MR resource tracker function Leon Romanovsky
2020-05-13 9:50 ` [PATCH rdma-next 08/14] RDMA: Add a dedicated CQ " Leon Romanovsky
2020-05-13 9:50 ` [PATCH rdma-next 09/14] RDMA: Add a dedicated QP " Leon Romanovsky
2020-05-25 14:34 ` Jason Gunthorpe
2020-05-25 16:26 ` Leon Romanovsky [this message]
2020-05-13 9:50 ` [PATCH rdma-next 10/14] RDMA: Add dedicated cm id " Leon Romanovsky
2020-05-13 9:50 ` [PATCH rdma-next 11/14] RDMA: Add support to dump resource tracker in RAW format Leon Romanovsky
2020-05-25 14:41 ` Jason Gunthorpe
2020-05-25 16:21 ` Leon Romanovsky
2020-05-27 6:14 ` Maor Gottlieb
2020-05-13 9:50 ` [PATCH rdma-next 12/14] RDMA/mlx5: Add support to get QP resource in raw format Leon Romanovsky
2020-05-13 9:50 ` [PATCH rdma-next 13/14] RDMA/mlx5: Add support to get CQ resource in RAW format Leon Romanovsky
2020-05-13 9:50 ` [PATCH rdma-next 14/14] RDMA/mlx5: Add support to get MR " Leon Romanovsky
2020-05-25 14:50 ` Jason Gunthorpe
2020-05-13 10:15 ` [PATCH rdma-next 00/14] RAW format dumps through RDMAtool Leon Romanovsky
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200525162655.GD10591@unreal \
--to=leon@kernel.org \
--cc=bharat@chelsio.com \
--cc=dledford@redhat.com \
--cc=jgg@ziepe.ca \
--cc=linux-rdma@vger.kernel.org \
--cc=maorg@mellanox.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox